VNC and RDP setup help needed...

Hi,

Can I have some remote terminal setup help please…

I have installed VNC and RDP, but even after adding TCP 5901 and 3811 ports to the firewall via YAST2, the connection request times out.

Thanks

Lee

Which VNC and RPD packages have you installed?

BTW, “Remmina” seems to be the preferred RDP client – rather than “rdesktop” …

Assuming that you are using “firewalld” then the config program is “firewall-config”, which I don’t think is in YaST2. The applet in YaST2 pointed to the old SUSE YaST2 firewall so I got rid of it. That might have been a hangover as my system has had a long history of upgrades.

Anyway. I just enable the “rdp” service in “firewall-config” (alternatively from the KDE menu system -> firewall).

All just worked for me and I use a variety of clients.

Yes, I can confirm this – the package “firewall-config” has to be installed – currently nothing pulls it in …

  • What’s weird is, the “yast2-firewall
    ” package’s “README.md” states –

Since the adoption of firewalld this repository contains just some useful clients and libraries for installation and autoinstallation.

YaST currently does not have a module to configure the firewall.

If you are looking for a new option, we recommend to use firewall-config to configure your firewall via a user interface or firewall-cmd for the command line.

  • And, to top that off, the Pattern “patterns-yast-yast2_basis
    ” pulls in “yast2-firewall” … *=2]Need to check if, this is still the case of Leap 15.3 …
    *=2]AFAICS, there ain’t anything in the Release Notes regarding this topic …

[HR][/HR]BTW, the openSUSE documentation for the current Firewall (firewalld) is here – <Masquerading and firewalls | Security and Hardening Guide | openSUSE Leap 15.5.

Tumbleweed does (or more accurately “did and probably still does”) pull in the old YaST2-firewall module.