vmware workstation9 on 12.2 64 : strange dbus error

as usual pasting here with middle button screwed up, so AGAIN, short:

vmware WS9, KDE3 on 12.2 64, 3.4.6 desktop kernel:

$ vmware
Logging to /tmp/vmware-dexter/vmware-modconfig-21765.log
filename: /lib/modules/3.4.6-2.10-desktop/misc/vmmon.ko
supported: external
license: GPL v2
description: VMware Virtual Machine Monitor.
author: VMware, Inc.
srcversion: EE87E1C8CB26EB751242F6C
vermagic: 3.4.6-2.10-desktop SMP preempt mod_unload modversions
process 21760: Attempt to remove filter function 0x7f74325f3080 user data 0x7f7443ffaeb0, but no such filter has been added
D-Bus not built with -rdynamic so unable to print a backtrace

installed a range of dbus packages, tried to restart HALdaemon as suggest in other places, no go.

hints appreciated

I was also having the problem, until last night.

The issue is with the hal daemon. I do not believe it is needed anymore for opensue 12.2

  1. Remove the hal daemon.

    zypper remove

  2. Uninstall vmware workstation 9. Run the following command from the directory with the VMware bundle.

    ./VMware-Workstation-Full-9.0.1-894247.x86_64.bundle -u vmware-workstation

  3. Reinstall vmware workstation 9.


  4. Start vmware.

This worked for me.

This message thread was moved to the VM forum.

Thank You,

I am also facing same problem. When I have searched the directorory /etc/init.d I found two files starting with hal and also I have searched whether Hal daemon is running or not and found it is not running. I think that haldaemon need not to be uninstalled. Are there any other packages need to be uninstalled inorder to run VMware workstation successfully on openSUSE12.2.