vmware workstation 9 install fails on 12.2

has anyone been able to get the vmware workstation 9 installer to run? mine is failing to extract the files.

2012-12-02T14:45:16.525-06:00| vthread-4| I120: The process is 64-bit.
2012-12-02T14:45:16.525-06:00| vthread-4| I120: Host codepage=UTF-8 encoding=UTF-8
2012-12-02T14:45:16.525-06:00| vthread-4| I120: Host is Linux 3.4.11-2.16-desktop openSUSE 12.2 (x86_64)
2012-12-02T14:45:14.838-06:00| vthread-3| I120: Msg_Reset:
2012-12-02T14:45:14.838-06:00|  vthread-3| I120: [msg.dictionary.load.openFailed] Cannot open file  "/etc/vmware/config": No such file or directory.
2012-12-02T14:45:14.838-06:00| vthread-3| I120: ----------------------------------------


... (stuff removed)


2012-12-02T14:45:16.575-06:00|  vthread-4| I120: Could not load Python library from:  /usr/lib/vmware-installer/1.1/python/libpython.so
2012-12-02T14:45:16.575-06:00|  vthread-4| I120: Could not load VMIS .so from  /usr/lib/vmware-installer/1.1/sopython/libpy25.so:  /usr/lib/vmware-installer/1.1/sopython/libpy25.so: cannot open shared  object file: No such file or directory


my best guess is something is missing from my python install. kernel-source, kernel-syms and the compilers are all installed.

any ideas?

thanks.

On 2012-12-04 06:46, ewhite20 wrote:
>
> has anyone been able to get the vmware workstation 9 installer to run?
> mine is failing to extract the files.

Please ask a moderator via personal message to move this thread to the
virtualization forum.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

Please Hold on to your reply’s until I move this to the proper forum.

Thank You,

This message is now open to make your posts.

Consider I don’t use vmware, but it sounds like you have not configured the program properly. I would visit the following forum to ask more questions.

VMware Communities: Social Media & Community for VMware

Thank You,

It is working here with no problems. I suspect your download is corrupted.

i thought i would update this for anyone searching.

the first run of the installer crashed with a message that i have since lost. however, it left behind some files in /etc/vmware-installer. the vmware installer was finding a file in that directory and skipping over some other routines. removing that directory allowed workstation 9 to install and it seems to be working without issue.

i did open a case with vmware as i have paid support. but all the tier one tech would offer is that opensuse is not supported.

On 2012-12-09 18:56, ewhite20 wrote:

> i did open a case with vmware as i have paid support. but all the tier
> one tech would offer is that opensuse is not supported.

Shame on them.
Yes, I expect they only support SLES.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

i think so this problem is language problem. i think, resolving this problem just " LANG=CC " command. please try this command and restart installation vmware.

Good Luck

Murat

Hello Everybody,

I am running into a huge problem making VMware Workstation 9 work on OpenSUSE 12.2.

I am have a Lenovo Thinkpad E430. When I run vmware at the prompt, it tells me that am missing “headers” and yet, I feel that I have installed them.

A “uname -r” reveals the following:

3.4.6-2.10-desktop

A “rpm -qa | grep kernel” shows:

kernel-desktop-3.4.6-2.10.1.x86_64
kernel-xen-devel-3.4.28-2.20.1.x86_64
kernel-source-vanilla-3.4.28-2.20.1.noarch
kernel-syms-3.4.28-2.20.1.x86_64
kernel-source-3.4.28-2.20.1.noarch
kernel-devel-3.4.28-2.20.1.noarch
kernel-desktop-devel-3.4.28-2.20.1.x86_64
kernel-default-devel-3.4.28-2.20.1.x86_64
kernel-firmware-20120719git-2.6.1.noarch

When I run a “vmware-modconfig --console --install-all”, I get:

Failed to setup build environment

This is what my “/tmp/vmware-root/vmware-modconfig-7666.log” reads:

2013-02-11T16:30:07.603+03:00| vthread-3| I120: Log for VMware Workstation pid=2304 version=9.0.1 build=build-894247 option=Release
2013-02-11T16:30:07.603+03:00| vthread-3| I120: The process is 64-bit.
2013-02-11T16:30:07.603+03:00| vthread-3| I120: Host codepage=UTF-8 encoding=UTF-8
2013-02-11T16:30:07.603+03:00| vthread-3| I120: Host is Linux 3.4.6-2.10-desktop openSUSE 12.2 (x86_64)
2013-02-11T16:30:07.574+03:00| vthread-3| I120: Msg_Reset:
2013-02-11T16:30:07.574+03:00| vthread-3| I120: [msg.dictionary.load.openFailed] Cannot open file “/usr/lib/vmware/settings”: No such file or directory.
2013-02-11T16:30:07.574+03:00| vthread-3| I120: ----------------------------------------
2013-02-11T16:30:07.574+03:00| vthread-3| I120: PREF Optional preferences file not found at /usr/lib/vmware/settings. Using default values.
2013-02-11T16:30:07.602+03:00| vthread-3| I120: Msg_Reset:
2013-02-11T16:30:07.602+03:00| vthread-3| I120: [msg.dictionary.load.openFailed] Cannot open file “/root/.vmware/config”: No such file or directory.
2013-02-11T16:30:07.602+03:00| vthread-3| I120: ----------------------------------------
2013-02-11T16:30:07.602+03:00| vthread-3| I120: PREF Optional preferences file not found at /root/.vmware/config. Using default values.
2013-02-11T16:30:07.602+03:00| vthread-3| I120: Msg_Reset:
2013-02-11T16:30:07.602+03:00| vthread-3| I120: [msg.dictionary.load.openFailed] Cannot open file “/root/.vmware/preferences”: No such file or directory.
2013-02-11T16:30:07.602+03:00| vthread-3| I120: ----------------------------------------
2013-02-11T16:30:07.602+03:00| vthread-3| I120: PREF Failed to load user preferences.
2013-02-11T16:30:07.603+03:00| vthread-3| W110: Logging to /tmp/vmware-root/vmware-modconfig-2304.log
2013-02-11T16:30:07.624+03:00| vthread-3| I120: System distribution is SuSE
2013-02-11T16:30:07.624+03:00| vthread-3| I120: System version is 12.2
2013-02-11T16:30:07.624+03:00| vthread-3| I120: Reading in info for the vmmon module.
2013-02-11T16:30:07.624+03:00| vthread-3| I120: Reading in info for the vmnet module.
2013-02-11T16:30:07.624+03:00| vthread-3| I120: Reading in info for the vmblock module.
2013-02-11T16:30:07.624+03:00| vthread-3| I120: Reading in info for the vmci module.
2013-02-11T16:30:07.624+03:00| vthread-3| I120: Reading in info for the vsock module.
2013-02-11T16:30:07.624+03:00| vthread-3| I120: Setting vsock to depend on vmci.
2013-02-11T16:30:07.624+03:00| vthread-3| I120: Created new pathsHash.
2013-02-11T16:30:07.624+03:00| vthread-3| I120: Invoking modinfo on “vmmon”.
2013-02-11T16:30:07.626+03:00| vthread-3| I120: “/sbin/modinfo” exited with status 256.
2013-02-11T16:30:07.626+03:00| vthread-3| I120: Invoking modinfo on “vmnet”.
2013-02-11T16:30:07.628+03:00| vthread-3| I120: “/sbin/modinfo” exited with status 256.
2013-02-11T16:30:07.628+03:00| vthread-3| I120: Invoking modinfo on “vmblock”.
2013-02-11T16:30:07.631+03:00| vthread-3| I120: “/sbin/modinfo” exited with status 0.
2013-02-11T16:30:07.632+03:00| vthread-3| I120: Invoking modinfo on “vmci”.
2013-02-11T16:30:07.634+03:00| vthread-3| I120: “/sbin/modinfo” exited with status 0.
2013-02-11T16:30:07.634+03:00| vthread-3| I120: Invoking modinfo on “vsock”.
2013-02-11T16:30:07.635+03:00| vthread-3| I120: “/sbin/modinfo” exited with status 0.
2013-02-11T16:30:07.644+03:00| vthread-3| I120: Obtaining info using the running kernel.
2013-02-11T16:30:07.644+03:00| vthread-3| I120: Setting header path for 3.4.6-2.10-desktop to “/lib/modules/3.4.6-2.10-desktop/build/include”.
2013-02-11T16:30:07.644+03:00| vthread-3| I120: Validating path “/lib/modules/3.4.6-2.10-desktop/build/include” for kernel release “3.4.6-2.10-desktop”.
2013-02-11T16:30:07.644+03:00| vthread-3| I120: Failed to find /lib/modules/3.4.6-2.10-desktop/build/include/linux/version.h
2013-02-11T16:30:07.644+03:00| vthread-3| I120: Failed version test: /lib/modules/3.4.6-2.10-desktop/build/include/linux/version.h not found.
2013-02-11T16:30:07.759+03:00| vthread-3| I120: Kernel header path retrieved from FileEntry:
2013-02-11T16:30:07.759+03:00| vthread-3| I120: Update kernel header path to
2013-02-11T16:30:07.759+03:00| vthread-3| I120: Validating path “” for kernel release “3.4.6-2.10-desktop”.
2013-02-11T16:30:07.759+03:00| vthread-3| I120: Failed to find /linux/version.h
2013-02-11T16:30:07.759+03:00| vthread-3| I120: Failed version test: /linux/version.h not found.
2013-02-11T16:30:07.759+03:00| vthread-3| I120: Kernel header path is invalid.
2013-02-11T16:30:07.760+03:00| vthread-3| I120: Found compiler at “/usr/bin/gcc”
2013-02-11T16:30:07.764+03:00| vthread-3| I120: Got gcc version “4.7”.
2013-02-11T16:30:07.764+03:00| vthread-3| I120: The GCC version matches the kernel GCC minor version like a glove.
2013-02-11T16:30:07.764+03:00| vthread-3| I120: Using user supplied compiler “/usr/bin/gcc”.
2013-02-11T16:30:07.767+03:00| vthread-3| I120: Got gcc version “4.7”.
2013-02-11T16:30:07.767+03:00| vthread-3| I120: The GCC version matches the kernel GCC minor version like a glove.
2013-02-11T16:30:07.771+03:00| vthread-3| I120: Trying to find a suitable PBM set for kernel “3.4.6-2.10-desktop”.
2013-02-11T16:30:07.771+03:00| vthread-3| I120: No matching PBM set was found for kernel “3.4.6-2.10-desktop”.
2013-02-11T16:30:07.771+03:00| vthread-3| I120: Validating path “” for kernel release “3.4.6-2.10-desktop”.
2013-02-11T16:30:07.771+03:00| vthread-3| I120: Failed to find /linux/version.h
2013-02-11T16:30:07.771+03:00| vthread-3| I120: Failed version test: /linux/version.h not found.
2013-02-11T16:30:07.773+03:00| vthread-3| I120: Validating path “” for kernel release “3.4.6-2.10-desktop”.
2013-02-11T16:30:07.773+03:00| vthread-3| I120: Failed to find /linux/version.h
2013-02-11T16:30:07.773+03:00| vthread-3| I120: Failed version test: /linux/version.h not found.
2013-02-11T16:34:55.262+03:00| vthread-3| I120: Kernel header path retrieved from FileEntry: /lib/modules/3.4.6-2.10-desktop
2013-02-11T16:34:55.262+03:00| vthread-3| I120: Update kernel header path to /lib/modules/3.4.6-2.10-desktop
2013-02-11T16:34:55.262+03:00| vthread-3| I120: Validating path “/lib/modules/3.4.6-2.10-desktop” for kernel release “3.4.6-2.10-desktop”.
2013-02-11T16:34:55.263+03:00| vthread-3| I120: Failed to find /lib/modules/3.4.6-2.10-desktop/linux/version.h
2013-02-11T16:34:55.263+03:00| vthread-3| I120: Failed version test: /lib/modules/3.4.6-2.10-desktop/linux/version.h not found.
2013-02-11T16:34:55.263+03:00| vthread-3| I120: Kernel header path /lib/modules/3.4.6-2.10-desktop is invalid.
2013-02-11T16:34:57.928+03:00| vthread-3| I120: Validating path “/lib/modules/3.4.6-2.10-desktop” for kernel release “3.4.6-2.10-desktop”.
2013-02-11T16:34:57.928+03:00| vthread-3| I120: Failed to find /lib/modules/3.4.6-2.10-desktop/linux/version.h
2013-02-11T16:34:57.928+03:00| vthread-3| I120: Failed version test: /lib/modules/3.4.6-2.10-desktop/linux/version.h not found.
2013-02-11T16:35:01.557+03:00| vthread-3| I120: Kernel header path retrieved from FileEntry: /lib/modules/3.4.6-2.10-desktop/
2013-02-11T16:35:01.557+03:00| vthread-3| I120: Update kernel header path to /lib/modules/3.4.6-2.10-desktop/
2013-02-11T16:35:01.557+03:00| vthread-3| I120: Validating path “/lib/modules/3.4.6-2.10-desktop/” for kernel release “3.4.6-2.10-desktop”.
2013-02-11T16:35:01.557+03:00| vthread-3| I120: Failed to find /lib/modules/3.4.6-2.10-desktop//linux/version.h
2013-02-11T16:35:01.557+03:00| vthread-3| I120: Failed version test: /lib/modules/3.4.6-2.10-desktop//linux/version.h not found.
2013-02-11T16:35:01.557+03:00| vthread-3| I120: Kernel header path /lib/modules/3.4.6-2.10-desktop/ is invalid.
2013-02-11T16:35:02.547+03:00| vthread-3| I120: Validating path “/lib/modules/3.4.6-2.10-desktop/” for kernel release “3.4.6-2.10-desktop”.
2013-02-11T16:35:02.547+03:00| vthread-3| I120: Failed to find /lib/modules/3.4.6-2.10-desktop//linux/version.h
2013-02-11T16:35:02.547+03:00| vthread-3| I120: Failed version test: /lib/modules/3.4.6-2.10-desktop//linux/version.h not found.
2013-02-11T16:36:05.357+03:00| vthread-3| I120: Validating path “/lib/modules/3.4.6-2.10-desktop/” for kernel release “3.4.6-2.10-desktop”.
2013-02-11T16:36:05.357+03:00| vthread-3| I120: Failed to find /lib/modules/3.4.6-2.10-desktop//linux/version.h
2013-02-11T16:36:05.358+03:00| vthread-3| I120: Failed version test: /lib/modules/3.4.6-2.10-desktop//linux/version.h not found.
2013-02-11T16:36:09.992+03:00| vthread-3| I120: Validating path “/lib/modules/3.4.6-2.10-desktop/” for kernel release “3.4.6-2.10-desktop”.
2013-02-11T16:36:09.992+03:00| vthread-3| I120: Failed to find /lib/modules/3.4.6-2.10-desktop//linux/version.h
2013-02-11T16:36:09.992+03:00| vthread-3| I120: Failed version test: /lib/modules/3.4.6-2.10-desktop//linux/version.h not found.
2013-02-11T16:36:16.746+03:00| vthread-3| I120: Kernel header path retrieved from FileEntry: /usr/src
2013-02-11T16:36:16.747+03:00| vthread-3| I120: Update kernel header path to /usr/src
2013-02-11T16:36:16.747+03:00| vthread-3| I120: Validating path “/usr/src” for kernel release “3.4.6-2.10-desktop”.
2013-02-11T16:36:16.747+03:00| vthread-3| I120: Failed to find /usr/src/linux/version.h
2013-02-11T16:36:16.747+03:00| vthread-3| I120: Failed version test: /usr/src/linux/version.h not found.
2013-02-11T16:36:16.747+03:00| vthread-3| I120: Kernel header path /usr/src is invalid.

This shows that the headers cannot be found. However, I just don’t know where to point vmware to look for the headers. I have been struggling with this problem since yesterday. Tried troubleshooting and nothing has worked. I don’t want to use KVM. Originally I was using another distro of Linux with Workstation 7 and it was working well. I though want to use and be familiar with SUSE this time round. I am abit short of time to make this work so any help, pointers…anything would be greatly appreciated.

Thanks in advance.

On 2013-02-12 08:56, Ytphoid wrote:
>
> Hello Everybody,
>
> I am running into a huge problem making VMware Workstation 9 work on
> OpenSUSE 12.2.

Your problem is different than the one originally posted in this thread.
Please start new threads for things.

> I am have a Lenovo Thinkpad E430. When I run vmware at the prompt, it
> tells me that am missing “headers” and yet, I feel that I have installed
> them.

Please use code tags for printouts and commands. Advanced editor, ‘#’
button.
Posting in
Code Tags - A Guide

Search for this thread “VMware cannot find kernel source”, and see if
the last post by mkossmann helps you.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

Thank you for the reply.

mkossmann post was able to point me in the right direction. I discovered that I had the following in my /lib/modules directory - 3.4.28-2.20-default, 3.4.28-2.20-desktop and 3.4.6-2.10-desktop, 3.4.6-2.10-default. My kernel was trying to read headers from 3.4.6-2.10-default and yet the headers (version.h) were in 3.4.28-2.20-default. The sim link that mkossmann was talking about was also already created in the 3.4.28-2.20-default directory. So, I just deleted 3.4.6-2.10-desktop, 3.4.6-2.10-default directories, run vmware again and voila!

Thank you so much for your time and help. My workstation is now running nicely. Hope this can help anybody who has this problem