VMware Workstation 6.5.1 on openSUSE 11.1 will not run

I’ve noticed people had problems with VMware Workstation 6.5.1 and openSUSE in the Dec/Jan time period and tried those fixes. I’m a openSUSE newbie and just installed my first openSUSE install on an:

Intel i7 CPU 920 with 11.7GB RAM, NVIDIA GeForce 9800GTX+ with Linux x86_64, KDE 4.1.3

The install went well (for my first time anyway) except for an audio drive that will not load, but the system falls back to a default driver and works (but this is not the problem I need help on) unless it part of my VMware problem.

1 -installed all packages (gcc, make, kernel-source, linux-kernel-header) no problem

2 - marked the bundle executable, no problem

3 - installed the VMware-Workstation-6.5.1-126130.x86_64, agreed, didn’t add path (because I didn’t know what it was), install completed successfully, no problems

4 - ran vmware - BIG PROBLEM

vmware <enter> (would copy and paste from shell, but don’t know how to)
/usr/lib/vmware/bin/vmware-modconfig-console: unrecognized option ‘–icon-vmware-workstation’

Must use a valid mode. Use one of:
– get-kernel-headers
– get-gcc
– *** several more ***

5 - I tried being root and normal user same error

6 - tried all fixes in other thread

7 - unistalling and reinstalled

8 - ran from terminal and KDE


10 THANKED ONE OF YOU for not making fun of my because I know this is something very small and easy to fix. I just can’t see it.

I would give more information to help, but I don’t know want you may need. Please let me know.

I fixed it! I loaded 6.5.2. Removed 6.5.1 and Installed 6.5.2. One question YaST still shows 6.5.1. Any reason for this?