VMWare server won't compile vsock module

I’ve been trying to install VMWare server on my 11.1 system. When I run the configuration program all the modules compile and load perfectly except for vsock. I get the error message:

Unable to make a vsock module that can be loaded in the running kernel:
insmod: error inserting ‘/tmp/vmware-config2/vsock.o’: -1 Unknown symbol in module
There is probably a slight difference in the kernel configuration between the
set of C header files you specified and your running kernel. You may want to
rebuild a kernel based on that directory, or specify another directory.

I am running the Linux x86_64 kernel and have the source code installed. Since all the other modules compile correctly, I’m a bit at a loss. I have specified as the header directory, the default /lib/modules/ There is also an include2 subdirectory with a lot of header files in it including one called socket.h. I have tried specifying the include2 subdirectory as the header directory, but then I get header not found errors for everything. I’ve also tried to link socket.h and sockios.h from the include2 directory in the corresponding place in the include directory and still get the same error message.

Is there a solution? Some files I might be missing? I’d really appreciate any help.


Does that kill the process, or can you simply move on?

There was a problem like that earlier in these forums where it was psssible IIRC to move on anyway.

It does go on and load the other modules. I’m just concerned that I won’t have Internet connectivity. I want to run an internet telephony device that needs real Windows and the Internet.

Read posts starting number 20 in that thread – it discusses the patch to fix the problem … scattered in the next 10 threads approx from 20 to 30 approx.

Thanks. I took the patch from that page, installed it and everything works ok except usb. I followed the instructions in your tutorial, fsck and the vmx file, but no devices appear. The VMware web interface shows that usb is installed and Windows does show the usb controller, but neither the Device tab on VMWare nor VMware tools show any usb devices.

That’s the limit of my experience (maybe reboot so the “auto” kicks in from fstab).

Thanks for all your help. I meant fstab. I did reboot at the time but, alas, no luck.