VMware Player15 on Leap 15

I am running VMware Player 15.0.2 on 64-bit Leap 15 and running Windows 7 64-bit inside Player. Everything works except for the audio and I can’t get it working. Windows believes the drivers are installed correctly and should play cleanly. There are two settings inside the virtual settings for sound, auto detect and ALSA. Neither works although I currently have it set to ALSA because that has always worked in past versions of OpenSuse. The sound card icon along the bottom of Player’s window also shows the sound card as functional.

Anyone have a suggestion on what to check to fix the sound?

Unfortunately I don’t, which is a reason why I generally recommend LEAP instead of TW as your HostOS when running virtualization… these kinds of problems can happen from time to time due to the nature of TW.

Did you just upgrade recently?
If you have any previous kernels installed, have you tried any other kernel (because nowadays I/O drivers are frequently distributed with the kernel)?
Also, if the audio device is one of the icons at the bottom of the Guest window, you can try doing a hardware pass-through (see the SDB at the following link)



Maybe you can enable it with pavucontrol?

Finally turned music on in the Windows guest and started playing with mixer settings until I stumbled on the discovery the ALSA playback mixer in pavucontrol only appears when audio is playing in the guest. A rather nasty hidden setting I missed for hours. Turning the ALSA audio stream on fixed the problem.

Thanks to everyone who tried to help. This question is answered.