VMware modules need to be compiled every restart

Hi everyone,

As per the title, I am having to recompile the modules vmmon and vmnet every time I restart my PC. For now it’s a minor inconvenience, but there’s a chance it might help solve another problem I’m having with VMware so I would like to fix it.

I have run the following to check secureboot is disabled:

> mokutil --sb-state
SecureBoot disabled

Uname information:

~> uname -a
Linux localhost.localdomain 5.3.18-59.37-default #1 SMP Mon Nov 22 12:29:04 UTC 2021 (d10168e) x86_64 x86_64 x86_64 GNU/Linux

VMware Player version: 16.1.2 build-17966106

I have installed kernel 5.3.18-59.34.1-default alongside as a backup kernel.

Thanks in advance for any assistance.


zypper in kernel-default-extra kernel-default-optional openSUSE-signkey-cert

The last has the certs for using openSUSE signed kmps and secure-boot

The output of that command is “Nothing to do.” Those patterns are already installed and up to date.

Maybe you need:
I use Virtualbox, that is included in openSUSE.

Please check if the package insserv-compat is installed. Both VMPlayer and Workstation Pro use a SysV init script to load the vmmon, vmnet modules. I did install a VMware-Player*.bundle today on a new Leap 15.3 system without the package insserv-compat installed. The result was that the vmware service was not started automatic on boot and the vmplayer UI complained that vmmon has not been loaded. A manual start of the service did fix the problem. Also a recompile of the modules via vmware-modconfig worked because the vmware service is restarted automatic after the installation of the new modules. It seems that the /etc/init.d/vmware script is missing the old LSB init script header if installed on a system without insserv-compat an this leads to the boot problem. Installing insserv-compat and a reinstall of the VMPlayer bundle did fix the problem:

# vmware-installer -u vmplayer
# zypper in insserv-compat
# bash VMware-Player-Full-16.2.1-18811642.x86_64.bundle

I’ve been using VMWorkstaion Pro with Leap for a long time but I wasn’t aware of this behavior. On the Leap machines on which I installed VMWorkstation so far, insserv-compat was probably always present for other reasons :).

Sorry for the delayed response.

Your process worked @rawar. It has been working fine since your post. Thank you.