VMWare Installation Problem

it worked for me on 11.3_x64 with ‘VMware Workstation 7.1 for Linux build 261024’

thank you very much!

try to change the “yes” in /etc/vmware/config to “no”


The solution to this problem I believe can be found here:
SciTechOpArt: How to install VMWare Workstation 7 with Suse Linux 11.3

I am trying to install workstation 7.1 on OS 11.1. All installed well (no errors) via a terminal session (VMware documentation pg 31). When I click on the application icon a dialog box pops up titled VMware Kernel Module Updater. Like the messages above, it details that several modules need to be compliled and loaded into the running kernel.The dialog box also give the option to specify the location of the kernel path headers Is there another location I should point to?
I ran the code, but I received several errors (gcc and kernel headers not installed)

Where am I going wrong?

Well, I read the link above and it gave me a eureka moment. I did not have kernel-source installed. I installed that via Yast and all is well.

On 02/07/2011 12:06 AM, mdcraven wrote:
> I am trying to install workstation 7.1 on OS 11.1.

you do know, i guess, that openSUSE 11.1 has pasted its end of life
and there will be no more security patches…

cite: http://en.opensuse.org/Lifetime

CAVEAT: http://is.gd/bpoMD
[NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.0.11, nVidia
173.14.28 3D, Athlon 64 3000+]
“It is far easier to read, understand and follow the instructions than
to undo the problems caused by not.” DD 23 Jan 11

Where do you run the script that was posted on the previous page?

Anywhere on the system. As it’s run as root user, so it automatically changes back to /root with the first command cd (change back to users home directory).

For the record this script works fine with Opensuse 11.3 64 bit (kernel and VMWare Workstation 6.5.5.

(Assuming you’ve got kernel-syms and kernel-sources and gcc installed and have successfully installed VMWare Workstation - but it fails to start on account of not being able to find the kernel headers then…)

Just copy the script above and paste into a text file (I named mine vmwspatch.sh) and invoke from the directory you’ve saved it in, for example with: “sudo sh ./vmwspatch.sh”. It trundles along for a fair while spitting out all sort of warnings but afterwards VMWare workstation runs when you click its icon - or invoke from command line with “vmware”.

Thanks Malcolm. I came THIS close to tossing it in and downloading virtual box, but really just needed VMWare to work if at all possible. Cheers.