VMware clock slowness with OpenSuSE 11

Hello everybody.

Before switching to OpenSuSE11 I had SLES10 running on a Lenovo laptop which did not have an Intel Centrino with speedstep technology. Under that environment, I installed VMware Server 1.0.5 and eberything worked fine.

Then I switched to a different laptop with a Core2 Duo Intel Centrino + Speedstep on which I installed OpenSuSE 11 (64bit) and VMware Server 1.0.7.

Once installed I noticed some clock timing issues related to the guest OSes I installed; as an example “virtual” SLES10, WindowsXP, Windows2000 all suffered from a clock slowness which I suppose is due to the speedstep tech.

As a workaround, I amended the host (OpenSuSE11) kernel by adding the following options in GRUB:

apm=off acpi=off noapic nohz=off

I manually set the

host.cpukHZ = “2201000”
host.noTSC = TRUE
ptsc.noTSC = TRUE

in /etc/vmware/config. I also added the above kernel modifiers for the SLES10 virtual guest, installed the VMware tools and forced a time synch with the host.

With the above kernel, things seem to be a bit better but if I keep the laptop running for a couple of days, the clock of the host does play up and starts loosing ticks.

I’m pretty sure the speedstep support is causing this issue so, as a first approach, I tried by setting the Power Management -> [ON AC Power] -> Computer Speed Policy = Always maximum speed.

This did not solve the slowness issues I noticed.

Is there a way to disable the speedstep support in OpenSuSE11?

Has anyone tried to run VMware Server on a laptop which support speedstep?