VMWare and Windows Partition

I finally got Vmware workstation installed. I am trying to use my windows partition as part of a virtual machine, however, when I try to do this I get a “Permission Denied” message. I get the same when I try to put KTorrent downloads on the Windows Partition. And again when I try to create desktop short cuts to folders within the windows partition. Yet, I can navigate and open files perfectly within the file explorer. I tried changing the owner from root to me, giving full read/write/execute permissions, and still I get the same error message.

Any other ideas?

If it’s NTFS you need to have it mount with the necessary permissions:
Help: HowTo Mount NTFS Filesystem Partition Read Write Access in openSUSE 10, 11

Not sure how this would apply to VMWare.
I’m a VBox user myself.

I shall try this tomorrow and get back to you; thank you for the quick reply.

It almost worked perfectly. I can copy and paste to windows, I can open up the virtual machines I already had saved on my Windows Partition, I can not, however, use my windows partition as the hard drive for a virtual machine. I aslo can’t use my desktop launcher that points to /windows/D, it says permission denied still.

What I did was gedit etc/fstab as per This tutorial and changed fmask=133,dmask=022 to fmask=113,dmask=002 for the correct ntfs partition.

This is highly discouraged by VMware. Raw disks should be used only with expert understanding and still at great risk.

The danger is that ordinarily the Operating System locks files being used, but Raw Disks bypasses this safety feature and could potentially crash and corrupt the partition/disk. If permissions isn’t an issue, you could already be violating safe practices and the VMware application is trying to protect you from yourself.

Unless you like playing with fire you should just create a virtual disk and copy the data from the physical disk into your virtual disk.

I know all this and have used logical volumes for virtual machines quite a bit in VMWare under windows. Locked files isn’t a problem since the partition I’m aiming to use won’t be booted up. I’ll be accessing the windows partition in linux, two different partitions, two different OS’s. Plus, the up time of the windows partition will be minimal, otherwise I would just boot out of linux and into windows. Never had a problem before.

I can’t just copy the data, because I am not doing this for the sake of data. Data is easy enough. I’m more doing it to access programs that will not and can not run under linux any other way.

On that note, any other ideas what might be going on here?

You might need to be a bit more descriptive what isn’t working.

So, one example I can think of which will fail is if you configure a VM which is located on your NTFS partition and attempt to configure the NTFS partition also as a second virtual disk.

Some parameters off the top of my head…
-What partition is your VMware application located on?
-What partition is your VM located on?
-Do you have multiple VMs running and on what partitions?
-What error are you getting, when you create a Raw Disk or when you attempt to run a VM with the Raw Disk connected?

Personally, the only relatively safe way I would use a Raw Disk is read only, like a virtual CDROM. What you’re doing risks both your Host and Guest VMs plus all the data. Even if you think you might believe things are working well and hasn’t caused a problem before, all it takes is once for an unexplainable glitch or gremlin to cause a catastrophe.