VMware: "An error occurred during the installation"

I’m attempting to install the Tumbleweed snapshot dated 2020-10-19 (x86_64) into a VMware virtual machine using VMware Workstation 15. I’m using the DVD image. The system boots fine and starts the installation process. Fairly early on it notes that my machine has a network and asks if I want to enable online repositories. I say “yes.” It appears to do that fine, but then displays a red box with the message, “An error occurred during the installation.” Any ideas on what I should be looking at to get past this problem?


When something like that has happened here, there either a message giving more information or there is a “details” button I can use to get more information.

You have not told us enough about your situation, for us to be able to make useful suggestions.

There is no other message and there is no “details” button. There is only a red box with the message “An error occurred…” with an “OK” button. This is on a blue background. I reran the installation to study more closely where in the process the failure occurs. It actually appears to happen during the process of adding online repositories. It appears to add the “Main Repository (non-OSS)” successfully, but I think it fails during the addition of the “Main Repository (OSS)”. It’s hard to be sure, but that’s what it appears to be doing when the screen switches to the blue background with the red box.

I do notice that very briefly I can see the normal console screen with some text on it. This happens as the screen is switching to display the error. I didn’t notice this before. Using Alt+Fn I can see on the third console (Alt+F3) the following suggestive messages:

loading file:/var/adm/mount/driverupdate → /download/file_0014
error 37: Couldn’t open file /var/adm/mount/driverupdate
starting setsid -wc inst_setup yast
install program exit code 137
sync… ok

There are a number of other files that it can’t open listed before this, but the errors are all shown as “(ignored).” That said, it appears to me that the installer program is exiting without a message here. I do have a root prompt on the second console. Is there some place where I can look for more information?


If it is happening while adding repos, then it could be a network problem.

I almost never add online repos during an install. I prefer a quick install, then update later.

I tried the installation without the OSS repository selected (but I did keep the non-OSS and “main update” repositories selected). That worked fine! The installation proceeded normally and it appeared to download updates from the main update repository normally. It seems like the network is fine (plus my host can use the network without any problems). Interacting with the OSS repository specifically seemed to be the cause of the problem. I feel like a clearer error message would have been helpful here.

I tried to add the OSS repository after the installation by going into YaST and selecting the repositories tab. It looks like that repository is already there. It’s in the list anyway, and when I select it I see package names. I’m not really sure what I’m looking at. I’m new to OpenSuSE (hence this installation). When you say you like to “update later” what do you mean, precisely?


With TW you do **zypper dup **to do updates

Yes, it would already be there. Even if you don’t use a repo for the install, it will still configure the standard repos for you. So, as gogalthorp suggested, you can just use “zypper dup” from a command line to fully update your system.

Okay, sounds great. Thanks!

The OSS repository is an enlarged version of your DVD installation media.
When you enable your OSS, you can then disable your installation source (ie the virtual CDROM) for later installing and updating.

BTW - Your installation problem suggests to me you are using an out of date Tumbleweed install medium.
Whenever you install a Tumbleweed, you should generally always download the latest installer, don’t use something you downloaded even yesterday.


This is still an issue, and it’s an issue with LEAP as well. As found in the thread, if you activate the additional online repos, the install will fail. Right after the time zone selection, before the user account creation, it fails out to the blue screen with red warning described by the OP. This is a defect in the installer that should be fixed, and the fail condition clearly should be improved to provide better (any) information.

There is no logical reason why this problem ever existed at all,
Except one situation.

Because TW versions are deprecated every few days or so,
It’s absolutely critical that when installing Tumbleweed (not any other version of openSUSE), you absolutely should **download a brand new TW install source **minutes before you start installing so that the installer is pointing to the latest, current install sources.

If you use an old TW installer, it will recognize its installer is invalid and prompt to download a new installer.
This is** not the same **as the prompt to “install online sources” during the install itself!
I’ve only found this download of an updated installer to work hit and miss, so it’s not worth even doing… My recommendation again is to just install a new TW installer (NET version if you want to decrease the download size).