VMWare 6.0.4 - Slow, Slow VM boot times with Suse 11 x86-64

When I “power on” a VM image now, it is taking between 2-5 minutes for it to come to the login screen on any image. I am not joking about the amount of time. It appears to start as normal, then the VM appears to come to a dead halt for 60-120 seconds (image type does not matter, XP Pro or Server 2003, or Linux Ubuntu) before it seems to start up and finish. It is just flat out slow, slow, slow!

With 10.3, this used to take between 15-20 seconds. Performance is just shoddy as can be. This is with the gold 11 release.

I’ve updated the system with the latest patches, updated the programs to the latest releases, and recompiled the kernel to be rid of the VMWare GCC error and to switch it to AMD processors, the 1000mhz timer and low latency desktop.

No joy and speedup with the changes.

System is a workstation with a set of 2ghz dual core, dual CPU AMD Opteron (270 Italy) with 6 gigs of memory.

Two questions:
Have you also re-run the VMWare tools install within the guest?
Is the boot quicker when you disable the guest nic?

There have been many reports of VMWare products slowing down starting kernel 2.6.24.
I have VMWare workstation 6.0.3 running on openSUSE 11.0 and have had no issues to speak of. You could try if uninstalling 6.0.4 and installing 6.0.3 using the vmware-any-any17 patch helps.

Have a look here for details: openSUSE Forums - View Single Post - Suse 11.o Beta And Vmware 6.0.3

Strange though that 6.0.4 still would have problems with the newer kernels.

hope that helps,

Not clear what OS is the Host and which is the Guest.

Regardless, you might want to take a look at the error logging for your Host.

And, especially if your Guest is 64-bit, you’ll need to determine if Pacifica has been enabled in your BIOS… Otherwise you might be seeing VMware trying to implement Hardware assist before determining that’s not possible and then doing software I/O translation only.

Suse 11 is the host. I tried the vmware anywhere tools, but the vmware-config would no longer run, complaining about the alien modules.

I did a new install of Suse 11 while retaining my home and data partitions. VMWare ran fine under Suse 10.3, but since the upgrade, something has gone south with it. I recreated a new profile and re-installed VMWare. Still a no go on the performance side.

Previous VMWare worked ok on both KDE 3.5x and the 4.x beta under 10.3. I’ve not a clue why it isn’t working well now. Nothing in the logs looks odd. It is just slower than molasses.

That said, the whole system appears a bit slower for some reason. I wonder if it is the new kernel rather than the client, something that doesn’t sit well with this system. It is a Tyan Thunder K8 with dual Opteron 270 processors at 2 ghz.

As a test rather than using VMWare workstation v 6.0.4 you could uninstall it and retry using the 6.0.3 version along with the steps in the above link in my first post.

I’ve got it running on two systems without any issues… so it could be 6.0.4 is causing issues in combination with the kernel?

Hope that helps,

edit: when looking at your running (linux) processes… are the CPU values higher than normal?