"vm-install: Error: none" on openSUSE 11.4 x86_64


I installed openSUSE 11.4 x86_64 and later on added the Xen functionality by clicking in YaST2 on “Hypervisor und Hilfsprogramme installieren” (Install hypervisor and helper programs). After that, I rebooted into the Xen kernel:

ask@ewzw032:~> uname -a
Linux ewzw032 #1 SMP 2011-07-21 02:17:24 +0200 x86_64 x86_64 x86_64 GNU/Linux

Now I’m trying to install virtual machine from YaST2; to do so I start yast2 and click on “Virtuelle Maschinen installieren” (Install virtual machines). It runs vm-install; when I run vm-install in a console, I get:

ask@ewzw032:~> sudo env LC_ALL=C /usr/bin/vm-install
Error: None

Uhm, what gives? :’(

I’ve read the thread “Xen - vm-install failing to launch”, but reinstalling the virt-viewer package didn’t help me at all - no change after having done so :frowning:

Could somebody please try to help? What am I missing?

Thanks a lot,

I ran into the same issue on my installation. My problem looks to be the same as Bug 691256

Try executing ‘chkconfig xencommons off’ and reboot to see if that clears your issue…