VLC tries to start but crashes

VLC had been working well, but after some updates, it crashes after trying to start. When starting from the menu, it puts a slot in the taskbar and has the bouncing pylon for a few seconds, then those disappear. When starting in console, it immediately returns
“VLC media player 1.1.7 The Luggage (revision exported)
Floating point exception”.

VLC starts correctly from console with “strace vlc”.

I deleted the configuration files “vlc-qt-interface.conf” and “vlcrc” in ~/.config/vlc/, but this made no difference when trying to start VLC.

The system is OpenSuSE 11.3, 32 bit; KDE 4.4.4 release 3; NVIDIA 260.19.29.

The problem exists with both VLC versions 1.1.7-1.pm.2.2 from Packman, and 1.1.7-3.1 from Videolan.

I suspect this is similar to an Amarok problem described at Amarok Keep Crash and Amarok opens and crashes immediately

Do any other users experience this behavior with VLC?


You shouldn’t even be trying the one from VideoLan, if you have, you just made a right mess.

Let me see your repo list:

zypper lr -d

Yes it seems to be a problem with many applications on 32-bit openSUSE 11.3 with NVIDIA 260.* drivers. Downgrading to NVIDIA 256.53 is known to fix the problem with floating point exception.

I’m using that same packman version here, but on 64bit 11.3, and it is working extremely well.

I’m wondering what updates you applied? Also wondering how you control both packman and videolan repos? Enabling both has caused problems for users, especially when updating and ending up with mixed but incompatible packages. The forum is littered with advice about not doing it.

This reads to be very similar to the symptoms of a problem that users of a 32-bit openSUSE-11.3 with the proprietary nVidia driver and KDE-4.4.4 are experiencing … ie it could be a known and rather ugly bug.

caf4926, repo list is:

#  | Alias                                 | Name                                  | Enabled | Refresh | Priority | Type     | URI                                                                             | Service
1  | Download                              | Download                              | Yes     | Yes     |   99     | plaindir | dir:///home/howard/Download                                                     |        
2  | KDE_Extra                             | KDE Extra                             | Yes     | Yes     |   99     | rpm-md   | http://download.opensuse.org/repositories/KDE%3a/Extra/openSUSE_11.3/           |        
3  | Mozilla                               | Mozilla                               | Yes     | Yes     |   99     | rpm-md   | http://download.opensuse.org/repositories/mozilla/openSUSE_11.3/                |        
4  | OpenOffice                            | OpenOffice                            | Yes     | Yes     |   99     | rpm-md   | http://download.opensuse.org/repositories/OpenOffice.org:/STABLE/openSUSE_11.3/ |        
5  | Packman                               | Packman                               | Yes     | Yes     |   99     | rpm-md   | http://packman.unixheads.com/suse/11.3/                                         |        
6  | Updates for openSUSE 11.3 11.3-1.82   | Updates for openSUSE 11.3 11.3-1.82   | Yes     | Yes     |   99     | rpm-md   | http://download.opensuse.org/update/11.3/                                       |        
7  | Videolan                              | Videolan                              | No      | No      |   99     | rpm-md   | http://download.videolan.org/pub/videolan/vlc/SuSE/11.3                         |        
8  | libdvdcss                             | libdvdcss                             | Yes     | Yes     |   99     | rpm-md   | http://opensuse-guide.org/repo/11.3/                                            |        
9  | nVidia Graphics Drivers               | nVidia Graphics Drivers               | Yes     | Yes     |   99     | rpm-md   | http://download.nvidia.com/opensuse/11.3/                                       |        
10 | openSUSE-11.3 11.3-1.82               | openSUSE-11.3 11.3-1.82               | Yes     | No      |   99     | yast2    | cd:///?devices=/dev/sr0,/dev/sr1                                                |        
11 | openSUSE-11.3-NonOSS-Add-on_11.3-1.80 | openSUSE-11.3-NonOSS-Add-on 11.3-1.80 | Yes     | No      |   99     | yast2    | cd:///?devices=/dev/sr0,/dev/sr1                                                |        
12 | repo-debug                            | openSUSE-11.3-Debug                   | No      | Yes     |   99     | NONE     | http://download.opensuse.org/debug/distribution/11.3/repo/oss/                  |        
13 | repo-non-oss                          | openSUSE-11.3-Non-Oss                 | Yes     | Yes     |   99     | yast2    | http://download.opensuse.org/distribution/11.3/repo/non-oss/                    |        
14 | repo-oss                              | openSUSE-11.3-Oss                     | Yes     | Yes     |   99     | yast2    | http://download.opensuse.org/distribution/11.3/repo/oss/                        |        
15 | repo-source                           | openSUSE-11.3-Source                  | No      | Yes     |   99     | NONE     | http://download.opensuse.org/source/distribution/11.3/repo/oss/ 

I have previously (and again now) had the Packman vlc. When it stopped working, I uninstalled it, deleted the config files, disabled the Packman repo, added and enabled the Videolan repo, and installed the Videolan version. There was no change in behavior, so I uninstalled it, deleted the config files, disabled the Videolan repo, enabled the Packman repo and put its version back.

As far as updates, I cannot be certain what occurred since vlc last worked, because I do not use vlc very often. There are frequent updates to vlc from Packman. There was a recent nVidia update installed 14 January 2011, so that could be the culprit.

What results are people having with more recent KDE versions?

I believe many 32-bit openSUSE-11.3 KDE-4.4.4 users with the proprietary nVidia driver, are getting a Floating Point error when they try to run ‘vlc’. I know I do. The work around is as you noted, which is to run ‘strace vlc’.

If you are a 32-bit KDE-4.4.4 (or newer KDE version) nVidia user, then do not believe this has anything to do with the repository where you obtained vlc. This is a bug, which is either in the 32-bit openSUSE, or in the 32-bit openSUSE packaged KDE4, or in the 32-bit proprietary nVidia driver.

Do you have any more info on this problem oldcpu? I’m getting it (11.3, Nvidia drivers, KDE 4.4.4). Is there a better workaround than running programs with strace?

Ok. You appear to have taken precautions with packman/videolan repos. I agree there have been frequent packman updates to vlc recently. That could be why it seems to be starting and performing so well (IMO the best of the mm players here right now, particularly the audio with e.g equalizer, and headphone spatializer features).

Since I’m using it mainly on 64bit 11.3 with KDE systems at 4.4.4 & 4.5.5, but only with intel graphics, and the results are good, it would seem that @oldcpu has identified the most likely cause of your problem. :wink:

I do not know much about it. It is pretty nasty. I don’t know when there will be a fix, and it could take time. It does not effect 64-bit PCs with a 64-bit openSUSE.

So if you have 64-bit hardware, and you are running 32-bit openSUSE, now may be a good time for a clean install to 64-bit.

I don’t have a 32 bit machine with nvidia.
So the others seem to be on the money with their advice. I’m just wondering if they can tell you if it’s any different using the nouveau driver, or is it the nvidia hardware at issue?

And what about gnome users?

The bug only impacts KDE4 users (on a 32-bit openSUSE with the proprietary nVidia driver). LXDE, Gnome, Xfce 32-bit openSUSE users are not effected. openSUSE KDE4 users with the nouveau video driver are unaffected.

So one could switch to Gnome, LXDE or Xfce.

And another work around is to roll back to the nouveau video driver on one’s 32-bit openSUSE PC. Although IMHO if one has 64-bit hardware and nVidia graphic hardware and a 32-bit openSUSE w/KDE4 installed, this is a good excuse to move to 64-bit.

But with 11.4 not far away
One might want to wait and either use Gnome or the nouveau driver in kde

I suspect 32-bit openSUSE-11.4 KDE4 users with the proprietary nVidia driver may also be impacted by this (I don’t know). A lot depends on how quick one can install, how happy one is with nouveau driver, how much one likes a different desktop … all sort of subjective possibilities. :slight_smile:

In my case I’ve had a couple of major tasks lined up for a while - move to 64-bit (was going to be with 11.4) and encrypt my LVM partition (which holds /, swap and /home). Since the latter requires a complete re-install since that partition will be wiped I decided to go for 64-bit.

Thanks for the replies, everyone.

I’ll stick with the console “strace vlc” workaround. For the amount I use vlc on this machine, that is quite tolerable.


FWIW, nVidia driver just updated to version 260.19.36_k2.6.34.0_12-22.1, but no change in vlc’s behavior.

I’m seeing the same issue with gnome. I’m running 32bit 11.3 with gnome and using the proprietary nvidia drivers. The strace work-around also works in this case.

Hmm … that is the first I’ve heard of a Gnome user having this problem. Do you have both Gnome and KDE installed and switch back and forth ?