VLC suddenly stopped showing .flv videos!

openSUSE 11.2 with KDE desktop, I have been using vlc to play .flv files without any difficulty or problems for months but it has suddenly stopped giving me any image on screen. The video is “running” according to progress bar and there is sound but just a black screen.

Trouble is I cannot pin this down to any particular update so I am asking if anybody else has had this happen?

I have run 1 click install multimedia and there were a few files updated but still no picture. I shall have to go through all the multimedia chacks and no time right now.
Meanwhile ideas for likely sources of problem welcomed.
Budgie2

In preferences > video
output section
try a different setting (mine is default) but you might try x11

Hi caf4926,
After a shut down things were OK again next day but then went wrong again later. Something else I am doing/running is causing some interference but at present no time to sort it out. Many thanks for the suggestion which I shall try anyhow,
regards,
Budgie2

Just check if logging out and back in will have the same result as reboot/shutdown
If it does, it may indicate a connection to X