VLC seg faults

For the last few weeks VLC has been seg faulting any time I try to play a video. I was using the version from Packman, so I tried the package from KDE:/Unstable and it does the same thing. The app launches fine and plays music with no problem. The seg fault only happens with videos, including wmv, flv, and mpg.

Anyone else having this problem? Anyone know how to troubleshoot this?

No problem here
Try starting vlc like this

vlc -vv

That’s 2 x v not a w
Then open a video that has been problematic
keep a check on the terminal feedback

I have done this before. I don’t know if there’s anything useful here, but here is a portion of the output:

 [0x6090c0] main libvlc warning: cannot read /usr/lib64/vlc/plugins/plugins-04081e-1f8.dat (No such file or directory)
[0x639230] signals interface warning: signal 17 overridden (0x7f55d5b3e210)
[0x639230] signals interface warning:  /usr/lib64/libQtCore.so.4(?)(nil)]
[0x7f55b0000e40] main input debug: `file:///local/home/****/Cinema/15.wmv' successfully opened
[0x7f55b0000e40] main input debug: Buffering 0%
[0x7f55b0000e40] main input debug: Buffering 11%
[0x7f55b0000e40] main input debug: Buffering 22%
[0x7f55b0000e40] main input debug: Buffering 33%
[0x7f55b0000e40] main input debug: Buffering 33%
[0x7f55b0000e40] main input debug: Buffering 66%
[0x7f55b0000e40] main input debug: Stream buffering done (333 ms in 0 ms)
[0x7f55b0000e40] main input debug: no usable vout present, spawning one
[0x7f5594059890] main spu text debug: looking for text renderer module: 3 candidates
[0x7f5594059890] freetype spu text debug: Building font databases.
[0x7f5594059890] freetype spu text debug: Took 0 microseconds
[0x7f558c005680] lua art finder debug: Trying Lua playlist script /usr/lib64/vlc/lua/meta/art/04_musicbrainz.luac
[0x7f558c005680] lua art finder debug: Trying Lua scripts in /usr/share/vlc/lua/meta/art
[0x7f558c005680] main art finder debug: no art finder module matching "any" could be loaded
[0x7f558c005680] main art finder debug: TIMER module_need() : 28.448 ms - Total 28.448 ms / 1 intvls (Avg 28.448 ms)
[0x63f7e0] main playlist debug: art not found for 15.wmv
[0x7f5594059890] freetype spu text debug: Using Serif Bold as font from file /usr/share/fonts/truetype/DejaVuSans.ttf
[0x7f5594059890] freetype spu text debug: using fontsize: 2
[0x7f5594059890] main spu text debug: using text renderer module "freetype"
[0x7f5594059890] main spu text debug: TIMER module_need() : 5.455 ms - Total 5.455 ms / 1 intvls (Avg 5.455 ms)
[0x7f559405ae20] main scale debug: looking for video filter2 module: 18 candidates
[0x7f559405ae20] swscale scale debug: 32x32 chroma: YUVA -> 16x16 chroma: YUVA with scaling using Bicubic (good quality)
[0x7f559405ae20] main scale debug: using video filter2 module "swscale"
[0x7f559405ae20] main scale debug: TIMER module_need() : 1.157 ms - Total 1.157 ms / 1 intvls (Avg 1.157 ms)
[0x7f55940686a0] main scale debug: looking for video filter2 module: 18 candidates
[0x7f55940686a0] yuvp scale debug: YUVP to YUVA converter
[0x7f55940686a0] main scale debug: using video filter2 module "yuvp"
[0x7f55940686a0] main scale debug: TIMER module_need() : 0.150 ms - Total 0.150 ms / 1 intvls (Avg 0.150 ms)
[0x7f5594054030] main video output debug: window size: 448x336
[0x7f5594054030] main video output debug: Deinterlacing available
[0x7f5594054030] main video output debug: deinterlace 0, mode blend, is_needed 0
[0x7f5594054030] main video output debug: looking for video output module: 1 candidate
[0x7f5594054030] vout_wrapper video output debug: Opening vout display wrapper
[0x7f558c000fc0] main generic debug: looking for vout display module: 8 candidates
[0x7f558c003b20] main window debug: looking for vout window xid module: 4 candidates
[0x7f558c003b20] qt4 window debug: requesting video...
[0x6342c0] qt4 interface debug: Video was requested 0, 0
[0x7f558c003b20] main window debug: using vout window xid module "qt4"
[0x7f558c003b20] main window debug: TIMER module_need() : 2.309 ms - Total 2.309 ms / 1 intvls (Avg 2.309 ms)
[0x7f558c0013a0] main inhibit debug: looking for inhibit module: 2 candidates
[0x7f558c0013a0] main inhibit debug: using inhibit module "xdg_screensaver"
[0x7f558c0013a0] main inhibit debug: TIMER module_need() : 0.133 ms - Total 0.133 ms / 1 intvls (Avg 0.133 ms)
Segmentation fault

I’ve included some of the warnings I found plus all of the output after clicking on the video file.

It’s something you should report at Packman IMO
I’m a mere mortal and can’t really decipher that output.
But there are some Supreme Beings over @Packman

may depend on your video driver try a previous version

Bingo! Thank you for the suggestion, barril!

I have a Nvidia graphics card. I noticed that recently VLC will segfault when opening any video file. At first I thought this was an issue from Packman, since I had pulled in a package update for VLC around the same time. What I also did around this time is update my Nvidia driver. The segfaults only occur with the latest Nvidia driver (295.20). I completely uninstalled this version and then installed the previous stable release, 290.10.

I no longer have segfaults with VLC!

As a note of reference, I install my Nvidia drivers the “hard way” by manually installing them from the nvidia.com web site. I prefer this method, since I can choose precisely what version I want, whether I want a beta or stable release, and I can install, uninstall, upgrade, and switch versions without rebooting.

To the OP: Have you tried reverting to the previous stable Nvidia driver? What kind of video card does your system have?

You were right. I changed to the 290.10 driver and VLC starting playing videos again. Now the question is why was the problem with VLC and not with any other media players?

You guys should bug report this info

Against VLC? This regression was introduced with the latest Nvidia driver (295.20). Upon browsing the nView forums, it seems that there are other cases of segfaults introduced with this driver release.

If you are using manually installed up to date nvidia drivers and the problem surfaced with that, then Find Submissions
It may also be worth mentioning at vlc and or packman

If this is what I ran into a couple years ago, it’s an old “problem” that’s easily resolved… the default streaming buffer is simply set too small.

If you have sufficient available RAM,

I <think> this might be the setting (might need to be verified). Although the setting is for “output” this setting might also be the cache size for inbound streams:

VLC > Tools > Preferences > “All” setting instead of default “Simple” setting > Stream output > Stream output muxer caching (ms)

I set mine to 30000.

Try it, and report if there is any improvement. If it’s not the right setting, I <know> it’s somewhere in the “All” settings…

Also, I think that there is a VLC repo and you should really be using that package instead of one from Packman…


Also, I think that there is a VLC repo and you should really be using that package instead of one from Packman…

Not a good idea

Not a good idea?
It was an officially recognized repo (in YAST) when I was running 11.3. Don’t know its current overall status since I’m currently runniing 12.1 now and numerous repos were removed while their packages are now found in the main repos.

At the time I installed the packages from the VLC repo, it resolved some problems that existed in the Packman version (but that was a long time ago).


You can use VLC with the OBS multimedia repos, but do not include packman.

Or you can use Packman and not include VideoLan

It’s been that way a long time.