VLC problem with videos

Hello,

I just installed OpenSuse, all the codecs and VLC. But I have a problem: On mkv files, only sounds is playing and on avi files the image is shattered and opened in a separate window from the original VLC one.

I’m using an Asus laptop with intel HD graphics.

Any hel please for a new user :slight_smile: ?
Thank you!

on avi files the image is shattered and opened in a separate window from the original VLC one

it’s a known vlc or qt 5.5 bug see here
https://forums.opensuse.org/showthread.php/510603-VLC-Opens-2-windows
atm there is no fix as the vlc devs are playing dumb
https://forum.videolan.org/viewtopic.php?f=13&t=129151

On mkv files, only sounds is playing

2 possibilities
#1 that mkv file only has sound so there is no video to play if there was it would open in a new window like the avi file
#2 you have mixed/missing packages, how and from where did you install vlc? For multimedia to work you need to have the packman repository and you need to do a full vendor switch with it
https://en.opensuse.org/SDB:Vendor_change_update#Full_repository_Vendor_change
post your repo list

zypper lr -d

it seams someone from the packman team did a Qt4 build of vlc, that one has no 2 window issues
get it from here
http://pmbs-api.links2linux.org:8080/home:/sb56637/
here’s how to install it?

sudo zypper ar -f http://pmbs-api.links2linux.org:8080/home:/sb56637/openSUSE_Leap_42.1/ vlc-qt4
sudo zypper dup --from vlc-qt4

the builder is not from packman but did one hell of a job, the 2 window bug has been around for months, thankfully someone had the good idea of not reinventing the wheel and used qt4 instead of qt5