VlC player does not work in root mode

hey friends,
VLC player installed in my computer does not work when im logged in as a “root”…i changed the permission of the file in “/usr/bin/vlc”& also “/usr/bin/vlc-wrapper”

Can anyone help me to solve this issue…
Any help would be appreciated.

Do NOT login to the GUI as root.

NEVER!

As Ako put it, you should neverever run VLC as root, never.

Even the wrapper itself will explain this to you.

I just tried (as a little experiment) to do what vlc tells you about using vlc-wrapper und suid and it did not work as suggested.

Luckily it seems this “feature” has been removed/disabled.

As an addition to the above, read this: SDB:Login as root - openSUSE

Okay thanks… for al those replys