vlc player behaviour

Leap42.1/KDE default installation. Really everything works fine except there is the strange behaviour with the vlc player. It plays most the videos I have, but on some videos the screen is black and there is only the sound. It is not really a problem since the other players play these videos without problems - I just wonder if anybody knows the reason and how to fix it. Somewhere I have read that the package libvdpau… can cause problems and somewhere else I have read that this package is needed for some Intel graphics cards. Since I have an intel graphics card I have not tried if it makes any difference to remove that package. But may be someone had this problem before and solved it?

some Intel chips do not support vdpau only va-api vdpau is nvidia technology, if you are on an intel machine that has issues remove vdpau, but first check if all multimedia is from packman, what’s your repo list

zypper lr -d

Thank you, I_A, I am sure I switched all MM packages to packman, I have set up the MM packages according to the MM-guide (including the switching to packman). What I forgot to say is that all the videos I have tried to play here - those which work in VLC and those which don’t are .mp4 format. Anyway here are the repositories but I don’t think you will find anything amiss here - at least I cannot see any mixup. And the fact that these videos play in all other media players installed indicates that this is something specific of VLC which I prefer.

uli@linux-osd0:~> zypper lr -d
# | Alias                         | Name                            | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                               | Service
1 | download.opensuse.org-non-oss | Main Repository (NON-OSS)       | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.1/repo/non-oss/ |        
2 | download.opensuse.org-oss     | Main Repository (OSS)           | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.1/repo/oss/     |        
3 | libdvdcss                     | libdvdcss                       | No      | ----      | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/openSUSE_Leap_42.1/                |        
4 | openSUSE-42.1-0               | openSUSE-42.1-0                 | No      | ----      | Yes     |   99     | yast2  | hd:///?device=/dev/disk/by-id/scsi-1USB_DISK_2.0-part2            |        
5 | packman                       | packman                         | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://packman.inode.at/suse/openSUSE_Leap_42.1/                  |        
6 | repo-debug-update             | openSUSE-Leap-42.1-Update-Debug | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/leap/42.1/oss           |        
7 | repo-update                   | openSUSE-Leap-42.1-Update       | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.1/oss/                |        

Could it be one of the vdpau packages?

uli@linux-osd0:~> rpm -qa | grep vdpau

I am not sure if they are needed for the graphics card which is:

00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b) (prog-if 00 [VGA controller])
        Subsystem: Intel Corporation Haswell-ULT Integrated Graphics Controller
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0
        Interrupt: pin A routed to IRQ 44
        Region 0: Memory at f7800000 (64-bit, non-prefetchable) [size=4]
        Region 2: Memory at e0000000 (64-bit, prefetchable) [size=256]
        Region 4: I/O ports at f000 [size=64]
        Expansion ROM at <unassigned> [disabled]
        Capabilities: <access denied>
        Kernel driver in use: i915
        Kernel modules: i915

Any ideas?

just to be sure do this

zypper dup --from 5

if that doesn’t fix things yes remove all those packages as Intel does not support vdpau at all, there should be a library that redirects vdpau to va-api but it might not work, anyway nouveau is an opensource driver for nvidia’s chips it might be installed by default and is useless on intel hardware.

Thank you, I_A, that was successful!
As expected the MM install was correct:

linux-osd0:~ # zypper dup --from 5
Loading repository data...
Reading installed packages...
Computing distribution upgrade...

Nothing to do.
linux-osd0:~ # 

However after removing the vdpau packages the VLC player plays the other packages as well. Thank you very much!