vlc not working

Hey, I have recently moved to “openSUSE 13.2 x86_64, linux 3.16.6-2-desktop” and I installed “vlc” using the command

zypper install vlc

. But now when I try to play a file “some_video.mp4” it gives the error

No suitable decoder module:
VLC does not support the audio or video format “h264”. Unfortunately there is no way for you to fix this.
No suitable decoder module:
VLC does not support the audio or video format “mp4a”. Unfortunately there is no way for you to fix this.

I tried installing the codecs using

zypper install vlc-codec

to which it says:

Loading repository data…
Reading installed packages…
Package ‘vlc-codecs’ not found.
Resolving package dependencies…

Nothing to do.

Which package do I have to add or do I need to edit the package repository?

Thanks

http://opensuse-community.org/

Yes. Adding a repository is the approach.

The package you tried to install was correct. The problem likely was you did not have the 3rd party repository that had vlc-codecs. Typically most of us on this forum recommend adding the packman repository for multimedia.

https://en.opensuse.org/Additional_package_repositories#Packman

Please note in the link I provided above, there is reference to both a vlc repository and a packman repository. The two respositories package rpms in ways that are not consistent with each other, hence it is best to use either one or the other, but not both. Using both can lead to breakage. Thus most of us on this forum recommend the packman repository and not the vlc repository. I typically install the “All of Packman” repos and not the “Essentials and Multimedia”. By selecting “All of Packman” one gets everything that was in “Essentials and Multimedia” .

And of course, following the link given by Sauerland is the MUCH quicker no need to understand and hence what I would refer to as the no brainer fast way to do this.

“Sauerland” and “oldcpu”, thanks for the help. I installed the

codecs-gnome.ymp
but when I try to play the “file_name.mp4” in “VLC” player, it gives me the following error:

No suitable decoder module:

VLC does not support the audio or video format “mpga”. Unfortunately there is no way for you to fix this.

No suitable decoder module:

VLC does not support the audio or video format “mpga”. Unfortunately there is no way for you to fix this.

No suitable decoder module:

VLC does not support the audio or video format “mpga”. Unfortunately there is no way for you to fix this.

But the video is working in “Totem” player. Suggestions?

Yes, install “vlc-codecs”.
That’s not done by that GNOME codec installer.

It should be found now that you added the Packman repo.

Thanks!! VLC is now playing the videos. lol!