I installed VLC from packman but it does not display any video.

I thought this might have something to do with the repo

so I input:

sudo zypper dup --from packman

I tried to use VLC again but the same issue persists

I am currently running KDE

How can I fix this?

I know That there is nothing wrong with the video file, as I was able to play it on another ubuntu laptop, as well as another laptop which had opensuse and i3 without any problem

I should also mention that I did install openSUSE leap 42.3 on this exact machine a few days ago when I was testing out distros.

I was using i3-gaps at the time, and VLC worked flawlessly

Not sure why it isnt working now as I did the same thing on this current install with the main difference being KDE

not sure if it matters… but im on a desktop PC with AMD cpu and nvidia gtx 960

do as described in the previous post only replace the TW repo with the LEAP repo

zypper ar -f ftp://packman.inode.at/suse/openSUSE_Leap_42.3/ packman
zypper dup --from packman
zypper in vlc-codecs libxine2-codecs

note the last line vlc-codecs does not exist in oss so only doing zypper dup --from packman is not enough you need to install vlc-codecs
you mentioned packman but didn’t tell us your repo list, what does this say

zypper lr -d

the only repo I added is the packman repo in addition to the default repo after a fresh install
VLC was the first thing I tried to get up and running…
so stepwise I did the following immediately after I installed openSUSE
added packman repo
installed packman vers of VLC and its dependencies, including the two that was mentioned in your post,

attempted to use VLC but there was no video, or sound
To be sure I converted all possible packages to packman

attempted to play VLC again to no avail and it has led me to posting here

I do not understand why this worked fine before with a different DE

My repo list btw

#  | Alias                           | Name                                    | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                      | Service
 1 | download.opensuse.org-non-oss   | Main Repository (NON-OSS)               | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.3/repo/non-oss/        |        
 2 | download.opensuse.org-non-oss_1 | Update Repository (Non-Oss)             | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.3/non-oss/                   |        
 3 | download.opensuse.org-oss       | Main Repository (OSS)                   | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.3/repo/oss/            |        
 4 | download.opensuse.org-oss_1     | Main Update Repository                  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.3/oss                        |        
 5 | openSUSE-Leap-42.3-0            | openSUSE-Leap-42.3-0                    | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.3/repo/oss/            |        
 6 | packman                         | packman                                 | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_42.3/       |        
 7 | repo-debug                      | openSUSE-Leap-42.3-Debug                | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/42.3/repo/oss/      |        
 8 | repo-debug-non-oss              | openSUSE-Leap-42.3-Debug-Non-Oss        | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/42.3/repo/non-oss/  |        
 9 | repo-debug-update               | openSUSE-Leap-42.3-Update-Debug         | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/42.3/oss/                 |        
10 | repo-debug-update-non-oss       | openSUSE-Leap-42.3-Update-Debug-Non-Oss | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/42.3/non-oss/             |        
11 | repo-source                     | openSUSE-Leap-42.3-Source               | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/42.3/repo/oss/     |        
12 | repo-source-non-oss             | openSUSE-Leap-42.3-Source-Non-Oss       | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/42.3/repo/non-oss/ |        

what’s your graphic card
some intel chips have issue with vdpau which I believe is the default in vlc I don’t know why
you can switch to va-api in vlc preferences
the above is not my picture found it with google search
or install libvdpau-va-gl which redirects vdpau to vaapi

zypper in libvdpau-va-gl

or uninstall libvdapu1

zypper rm libvdpau*

another thing that could be an issue is vlc-codec-gstreamer
this is not installed by default but if you installed it it will use gstreamer as a decoding backend in vlc and that one has issues on nvidia chips as it tries to use va-api where there is no va-api support
so what’s the output of

zypper se -si vlc-codec-gstreamer

just out of curiosity do kaffeine or dragon work
dragon uses gstreamer and kaffeine uses libxine2 so it’s a way to see where the issue is libvlc or there are some missing packages (both libxine2 and gstreamer use vdpau or va-api on supported hardware)
you can also run vlc from a terminal window and see the errors (if any) it displays

May also be worth taking a look from the GUI at Tools -> Messages

Perhaps also try explicitly setting the Audio & Video output modules, as opposed to using the “Automatic” setting.

That’s what I found was necessary on a TW install where I lost video. ( https://forums.opensuse.org/showthread.php/528572-VLC-No-video-after-a-recent-snapshot?p=2848153#post2848153 )

I tried all the suggested solution none of them fixed the issue

both kaffiene and dragon do not work.

The fix was to just to set the following preferences in vlc:
Video -> Output Modules -> OpenGL -> OpenGL Extension = GLX
I didnt think this would be the solution because it was set to automatic on the first install and worked just fine (on the same system),

Im at a loss here because Im not sure what the reasoning is for this issue forcing me to make the change in vlc, is there a reasonble way to understand or track down why this occured in the first place?

Thanks for all the help though, much appreciated.

you didn’t tell us what graphic card you have and which driver you use what’s the output of

sudo lspci -v | grep VGA 

you graphic system doesn’t seam to have any hardware acceleration
if you have an nvidia card you should know that the noveau driver needs a blob from the nvidia driver package to get hardware acceleration
if you’re on intel you should not have this issue as intel drivers are build-in the kernel
amd users have it more complex the older cards have been depreciated by amd and the newer ones need the propitiatory driver see
https://en.opensuse.org/SDB:AMDGPU-PRO (current amd driver for new cards)
https://en.opensuse.org/SDB:AMD_fglrx (abandoned by amd does not work on 42.3)
https://en.opensuse.org/SDB:Radeon (open sourced I’m not sure about hardware acceleration)