VLC not playing mp4 files

On Tue, 20 Mar 2018 15:16:01 +0000, vinoman2 wrote:

> it still brings up errors

What are the errors?

Nobody can troubleshoot them if you don’t tell us what you see in the
terminal window.

For most people, VLC does just work. But you seem to have had it
installed from the main repo rather than from packman initially, so folks
are trying to help you get this switched over.

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

You need to accept all vendor changes, i.e. choose Option 1 everytime.

Or add the --allow-vendor-change switch to let zypper switch automatically.

sudo zypper dup --from "Packman Repository" --allow-vendor-change

Why can’t vlc work by just installing it? I’ve installed it 20 times on many other distros and it has always worked.

It does work, and it can play back virtually everything if you switch to Packman, which you didn’t.

And if you prefer other distributions, just use them and not openSUSE…

You want to change Packages to Packman Repo so this is the Solution:

Problem: problem with installed package libgstbasecamerabinsrc-1_0-0-1.12.4-5.1.x86_64
Solution 1: install libgstbasecamerabinsrc-1_0-0-1.12.4-8.3.x86_64 (with vendor change)
openSUSE –> http://packman.links2linux.de

And if you get antother Error, please post it completly from Terminal…

Why can’t vlc work by just installing it?

VLC works on openSUSE, but openSUSE does not ship any patented codecs, only free Codecs.
The patented codecs are offered by the Packman Team, so you have to enable it and switch all installed Packages to Packman, if possible.

Thanks for letting me know that I needed to install vlc using packman instead of the other repo. I did reinstall thinking that it would install from Packman. Will reinstall again

You should still do a full switch to Packman to get all uncrippled multimedia packages from there.

Please listen what people try to tell you to do.
Do NOT reinstall.
Do the “Switch to Packman” as explained.

Got it. Thank you it’s working now.

Hurray! Congratulations.

:shake: New to openSUSE coming over from an ubuntu based system, had a wee bit of trouble with the same VLC problem until I followed your instructions above. Just wanted to give ye a heartfelt Thanks for your help, also this being my first post/reply to these forums. Thank You again for this solution.:good:

welcome to both opensuse and the opensuse forums
it’s good to know you fixed your media issues
if you have any other questions/issues feel free to ask for help

A post was split to a new topic: VLC from Packman not playing mp4 files