VLC no longer playing video files

Recently found that VLC will no longer play any video file I throw at it, the opposite of its usual behaviour. It seems to be okay with audio but when opening a video file the first frame appears, the player hangs for a while sending the CPU usage up, and occasionally if I click around on other windows, close a program (doesn’t seem to matter which) or do other random things like bring the preferences dialog to the front, the audio will begin playing and there might be a small advance in the frames, but that’s all.

This is VLC 2.0.3 and all its dependencies from the Packman repo on a standard 12.2 installation with KDE 4.8.5 and no other weird repos added. I have 3D disabled on my system because it’s an old laptop with a Radeon 9700 card that is completely unstable with the Radeon drivers, but everything else works fine. I’ve tried lots of things including: disabling desktop effects; resetting VLC’s configuration options to defaults; unticking options such as ‘use GPU acceleration’ or ‘video acceleration (overlay)’; closing all other applications; switching from gstreamer to VLC Phonon backend and logging back in again; uninstalling VLC and all its two dozen or so dependencies, deleting a few VLC config files from my home directory and reinstalling VLC.

It was all fine after I upgraded the machine to 12.2 but this began happening a little while ago. I don’t know if it was a an update of VLC itself from 2.0.1 or some other update that caused it to go wrong, or whether the program itself has just become corrupted somewhere. I don’t have any other video player installed and none that I’d want to use anyway. It’s not the end of the world but I just wonder if anybody else has noticed a similar problem in recent weeks, because there’s no obvious changes that I’ve done on this machine other than install online updates.

If you run KDE, you should have Kaffeine too. Did you by any chance “clean out” KDE, i.e. remove lots of applications?

No mass app-removal, although shortly before the distro upgrade I did have to force a clean-out of the /tmp and /var/tmp folders since they had filled up the root partition and the YaST -> Sysconfig Editor -> Cron options to clean them weren’t doing anything.

I used to like the old version of Kaffeine but not the KDE4 remake, which I remove along with Dragon should I see it installed by default; I don’t need more than one video app. Main gripe with the newer Kaffeine is that it always seems to pick the wrong aspect ratio for anything I play, so a 4:3 film shows as 16:9 and vice-versa, and setting the menu option to 1:1, Auto or Default doesn’t help. I prefer reality to the weird world of squashed heads; they should name Kaffeine after another drug.

How did you force this clean-out? It may very well be the cause of the trouble you’re experiencing now. The options to clear the temp folders are not under Cron, they’re found by searching for TMP

In YaST -> System -> /etc/sysconfig Editor, you have to click on System in the tree on the left, followed by Cron, and then adjust CLEAR_TMP_DIRS_AT_BOOTUP. (I’d tried setting to both ‘yes’ and ‘/tmp /var/tmp’ but no success). I seem to recall reading a bug report about this issue that had been around since a year or so before. And I believe that in 12.2 the job of clearing temp directories has been handed over to systemd. I forget what I did in the end though I suspect I had to simply delete everything, reboot and hope for the best. I probably left the root-owned files or moved them to the recycle bin as backup, because it was the user files that were hogging most of the gigabytes of space.

Regardless, I’m 99% certain I had video files playing in VLC after doing the distro upgrade and it’s something that has changed since then. I could take another look at Kaffeine but I note that it’s only in the OSS repo and not Packman, so I wonder if that’s going to result in non-playable codecs.

There’s one option I can think of: start the software manager, go repo view, select the Packman repo, hit “Switch system packages to versions …”. Take a good look, if there’s any packages selected for install.

A second thought: if you run vlc from a terminal window, it will generate output. Does it show any errors/warnings?

Not sure if the errors I’m getting are very useful. It’s being choosy now about what files it will play. At least some of them now play. It spits out several identical lines of unicode errors as follows:

user@domain:~> vlc file:///home/user/Downloads/test.mp4 
VLC media player 2.0.3 Twoflower (revision 2.0.2-93-g77aa89e)
[0x93e6898] dbus interface: listening on dbus as: org.mpris.MediaPlayer2.vlc
[0x93e6008] main interface error: no suitable interface module
[0x935c3f0] main libvlc error: interface "globalhotkeys,none" initialization failed
[0x935c3f0] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
TagLib: String::prepare() - Unicode conversion error.
------- (x12)
TagLib: String::prepare() - Unicode conversion error.
libva: VA-API version 0.33.0
libva: va_getDriverName() returns -1

Another file I tried provided various other errors:

[0x868eaa8] main access error: cannot resolve images.google.com port 80 : Name or service not known
[0x868eaa8] access_http access error: cannot connect to images.google.com:80
[0x868eaa8] access_mms access error: invalid chunk FATAL (0x213c)
[0x868eaa8] access_mms access error: header size == 0
[0x8612948] main art finder error: no suitable access module for `http://images.google.com/images?q=Lavf53.32.100%20Lavf53.32.100%20cover'
[0x8671730] main access error: cannot resolve www.last.fm port 80 : Name or service not known
[0x8671730] access_http access error: cannot connect to www.last.fm:80
[0x8671730] access_mms access error: error: HTTP/1.1 404 Not Found
[0x8612948] main art finder error: no suitable access module for `http://www.last.fm/music/Lavf53.32.100/Lavf53.32.100'

Not sure if any of that was related to the specific file as I don’t see the connection with all these online services, it was just an ordinary clip from a digital camera.

On 2012-10-29 12:06, gumb wrote:
> No mass app-removal, although shortly before the distro upgrade I did

How did you do the upgrade, online or offline? There maybe things left to be done.

Online upgrade method
Offline upgrade method

Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” (Minas Tirith))

Same problem here. I’ve done a security update on 1st Nov. (I remember it was about libva) and now I’ve got VLC problem. VLC said that it’s not possible to find h264 codec. At that point I re-installed VLC, libva and so on both from packman and videolan repository but now I can open the video, but after 3/4 seconds the video hangs and only the audio works. I think the problem is with libva. I’ve got opensuse 11.4 and intel chipset 865g.

Videolan and Packman Repo at the same Time is no good Idea. Try to delete the Videolan Repo and switch all packages to Packman.

I removed videolan and installed vlc only from packman, no results. I’ve got the same problem.

Not exactly a solution, but for anybody else who was experiencing this issue, I’ve since upgraded from 12.2 to 12.3 by wiping / and keeping /home, then I reinstalled VLC from Packman and it all works. Perhaps there was a buggy dependency in the 12.2 repos, I’ll never know now.