VLC lost frames

I’ve had DVD’s running perfectly fine before but now movies has started to flicker heavily whenever I try to play a DVD. I opened Media Information in VLC and saw that it had a lot of Lost Frames, almost as many as displayed. I have updated everything to latest version and I’ve rechecked that the correct codecs and everything are installed according to the Multi-Media and restricted format post.

Like I said it has been running fine before, I’m not sure what broke it. I’ve tried to figure out when it stopped working and it might have been when I installed a game called 8kingdoms from Packman. It also installed a dependency but I don’t remember the name of it. I’ve also tried different output methods but they are all the same.

If I try to play the DVD with mplayer it shows up but with a duplicated picture of the first frame behind the normal video and some of the desktop showing through next to the video. I guess this is some decoding problem.

If anyone could help me I’d be most greatful.

openSUSE 11.1

Please post result of

zypper lr -d

1 | 20091209-235346 | 20091209-235346 | No | No | 99 | rpm-md | Index of /repositories/home:/enzokiel/openSUSE_11.1_Update |
2 | ATI | ATI | No | No | 99 | rpm-md | http://www2.ati.com/suse/11.1/ |
3 | ATI Repository | ATI Repository | Yes | No | 99 | rpm-md | http://www2.ati.com/suse/11.1 |
4 | Packman_Repository | Packman Repository | Yes | Yes | 10 | rpm-md | Index of /packman/suse/11.1 |
5 | openSUSE 11.1-0 | openSUSE 11.1-0 | Yes | No | 99 | yast2 | cd:///?devices=/dev/sr0 |
6 | repo | openSUSE BuildService - KDE:Community | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/Community/openSUSE_11.1 |
7 | repo-debug | openSUSE-11.1-Debug | No | Yes | 100 | NONE | Index of /debug/distribution/11.1/repo/oss |
8 | repo-non-oss | openSUSE-11.1-Non-Oss | Yes | Yes | 100 | yast2 | Index of /distribution/11.1/repo/non-oss |
9 | repo-oss | openSUSE-11.1-Oss | Yes | Yes | 100 | yast2 | Index of /distribution/11.1/repo/oss |
10 | repo-source | openSUSE-11.1-Source | No | Yes | 100 | NONE | Index of /source/distribution/11.1/repo/oss |
11 | repo-update | openSUSE-11.1-Update | Yes | Yes | 20 | rpm-md | Index of /update/11.1 |
12 | repo_1 | openSUSE BuildService - OpenOffice.org | Yes | Yes | 99 | rpm-md | Index of /repositories/OpenOffice.org:/STABLE/openSUSE_11.1 |
13 | repo_2 | openSUSE BuildService - Mozilla | Yes | Yes | 99 | rpm-md | Index of /repositories/mozilla/openSUSE_11.1

Good.
Have you done an unconditional update in Packman?

Have you tried a different video output setting in VLC? (X11)

What about smplayer?

Not sure what an unconditional update means, I’ve mad sure all the packages from Packman is up to date if that is what you mean, updated from Yast.

I’ve tried all the different output methods in VLC and all my video players (Kaffeine, VLC and Smplayer) gives the same flickering images.

Yast - Software Management - Filter by repository
Select Packman
From the top Menu ‘Package’ In drop box select Update all in this list Unconditionally.

Yast - Software Management -Update All_HowTo - openSUSE Forums

No I haven’t, I’m on a very limited connection (satellite link) so I’d rather not. It would probably take me a couple of days to complete that update. I have however checked each package individually that they are the latest version.

OK.
So did you try smplayer/mplayer

I just tried a .avi file and it is also hacking and flickering. Yes I’ve tried all my mediaplayers and they all give the same result

Have you disabled desktop effects (If you use them), to see if that changes anything.
Have you had any recent video driver updates or xorg?

Desktop effects are disabled. I have not updated my video drivers, and I haven’t installed the ATI drivers since it has all been working fine with standard SUSE drivers. I added the ATI repositories to install the drivers to see if that might solve the problem but they were not downloading at all (might have been my slow connection). I don’t think they should be necessary though since it has been working great without them before.

The fact that all multi-media is playing the same regardless of it being a DVD,.avi etc… And all media players give the same result, I would have to say it is more likely a hardware issue. By that I mean your video card.
As I take it the .avi files were playing from the HD not a cd or dvd?

Thats correct, .avi was played from HD. I tried another tip, comment out #Virtual 3840 1200 from xorg.conf but the result was the same. I believe this is a matter of encoding/decoding rather than the playing.

When I tried to run this 8kingdoms game it started in fullscreen and changed my screen resoultion, but then it crashed. Could it be something that wasn’t reset due to the crash?

please open a terminal and do this:

cat /etc/X11/xorg.conf

Is it an ATI graphics you have. Did you try re-installing it?

Yes it’s an ATI Radeon X1200. I have not tried to reinstall it, it has worked great with SUSE since install so there has been no need to install separate drivers.

@linux-g60w:~> cat /etc/X11/xorg.conf

/…/

SaX generated X11 config file

Created on: 2009-12-22T04:01:13+0100.

Version: 8.1

Contact: Marcus Schaefer <sax@suse.de>, 2005

Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>

Automatically generated by [ISaX] (8.1)

PLEASE DO NOT EDIT THIS FILE!

Section “Files”
FontPath “/usr/share/fonts/misc:unscaled”
FontPath “/usr/share/fonts/local”
FontPath “/usr/share/fonts/75dpi:unscaled”
FontPath “/usr/share/fonts/100dpi:unscaled”
FontPath “/usr/share/fonts/Type1”
FontPath “/usr/share/fonts/URW”
FontPath “/usr/share/fonts/Speedo”
FontPath “/usr/share/fonts/PEX”
FontPath “/usr/share/fonts/cyrillic”
FontPath “/usr/share/fonts/latin2/misc:unscaled”
FontPath “/usr/share/fonts/latin2/75dpi:unscaled”
FontPath “/usr/share/fonts/latin2/100dpi:unscaled”
FontPath “/usr/share/fonts/latin2/Type1”
FontPath “/usr/share/fonts/latin7/75dpi:unscaled”
FontPath “/usr/share/fonts/baekmuk:unscaled”
FontPath “/usr/share/fonts/japanese:unscaled”
FontPath “/usr/share/fonts/kwintv”
FontPath “/usr/share/fonts/truetype”
FontPath “/usr/share/fonts/uni:unscaled”
FontPath “/usr/share/fonts/CID”
FontPath “/usr/share/fonts/ucs/misc:unscaled”
FontPath “/usr/share/fonts/ucs/75dpi:unscaled”
FontPath “/usr/share/fonts/ucs/100dpi:unscaled”
FontPath “/usr/share/fonts/hellas/misc:unscaled”
FontPath “/usr/share/fonts/hellas/75dpi:unscaled”
FontPath “/usr/share/fonts/hellas/100dpi:unscaled”
FontPath “/usr/share/fonts/hellas/Type1”
FontPath “/usr/share/fonts/misc/sgi:unscaled”
FontPath “/usr/share/fonts/xtest”
FontPath “/opt/kde3/share/fonts”
InputDevices “/dev/gpmdata”
InputDevices “/dev/input/mice”
EndSection

Section “ServerFlags”
Option “AllowMouseOpenFail” “on”
Option “ZapWarning” “on”
EndSection

Section “Module”
Load “extmod”
Load “dbe”
Load “glx”
Load “freetype”
Load “dri”
EndSection

Section “InputDevice”
Driver “kbd”
Identifier “Keyboard[0]”
Option “Protocol” “Standard”
Option “XkbLayout” “se”
Option “XkbModel” “microsoftpro”
Option “XkbRules” “xfree86”
EndSection

Section “InputDevice”
Driver “synaptics”
Identifier “Mouse[1]”
Option “Buttons” “5”
Option “Device” “/dev/input/mice”
Option “Emulate3Buttons” “on”
Option “HorizScrollDelta” “0”
Option “InputFashion” “Mouse”
Option “Name” “Synaptics;Touchpad”
Option “Protocol” “explorerps/2”
Option “SHMConfig” “on”
Option “Vendor” “Sysp”
Option “ZAxisMapping” “4 5”
EndSection

Section “InputDevice”
Driver “mouse”
Identifier “Mouse[3]”
Option “Buttons” “5”
Option “Device” “/dev/input/mice”
Option “Name” “ImPS/2 Generic Wheel Mouse”
Option “Protocol” “explorerps/2”
Option “Vendor” “Sysp”
Option “ZAxisMapping” “4 5”
EndSection

Section “Monitor”
DisplaySize 331 207
HorizSync 30-62
Identifier “Monitor[0]”
ModelName “AUO LCD MONITOR”
Option “DPMS”
Option “PreferredMode” “1280x800”
VendorName “AUO”
VertRefresh 50-60
UseModes “Modes[0]”
EndSection

Section “Modes”
Identifier “Modes[0]”
EndSection

Section “Screen”
DefaultDepth 24
SubSection “Display”
Depth 15
Modes “1280x800” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
#Virtual 3840 1200
EndSubSection
SubSection “Display”
Depth 16
Modes “1280x800” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
#Virtual 3840 1200
EndSubSection
SubSection “Display”
Depth 24
Modes “1280x800” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
#Virtual 3840 1200
EndSubSection
SubSection “Display”
Depth 8
Modes “1280x800” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
#Virtual 3840 1200
EndSubSection
Device “Device[0]”
Identifier “Screen[0]”
Monitor “Monitor[0]”
EndSection

Section “Device”
BoardName “Radeon X1200”
Driver “radeonhd”
Identifier “Device[0]”
Screen 0
VendorName “ATI”
EndSection

Section “ServerLayout”
Identifier “Layout[all]”
InputDevice “Keyboard[0]” “CoreKeyboard”
InputDevice “Mouse[1]” “CorePointer”
InputDevice “Mouse[3]” “SendCoreEvents”
Option “Clone” “off”
Option “Xinerama” “off”
Screen “Screen[0]”
EndSection

Section “DRI”
Group “video”
Mode 0660
EndSection

Section “Extensions”
EndSection

That does look OK.
I’m kinda out of ideas and I’m away to bed. I’ll check back in the morning. Sorry i haven’t been much help;)

Thanks for your help so far, I hope you or someone else will find out what this is all about. I have been googling but so far I haven’t found anyone with the same problem.

Hmmm, just found out that when playing an .avi file in original size I don’t loose any frames. The DVD however loses frames no matter what size. If I set down my screen resolution to 800x600 the DVD doesn’t lose as many frames but still loses some. Seems almost like it’s some hardware performance problem.

Remember you were saying about this. I wonder if you are right about it being responsible.

If you don’t have another user account, create one and login to it. You need auto-login disabled
Disable Auto-Login - openSUSE Forums

See if the same happens in the new user account (We can easily delete this later)

I just tried with a new user account, still losing a lot of frames.