VLC issue: no sound, no video... nothing

Hi all!

First of all, a short introduction (this is my 1st post here): fed up with windows, I’m trying to switch to Linux (dual boot ^^). It’s not always easy and I’m experiencing some difficulties sometimes.

One of them is that I can’t play anything with VLC. I use the gnome desktop, my openSUSE version is 11. There is no error message. The progress bar does progress, but without any sound or video.
I also tried to install Foobar2000, through Wine. And I’ve no playback neither.

Any ideas? need more details?

Thanks a lot! :o)

Aow, another thing: I’m french, trying to write properly in english but I guess it’s not perfect! sorry in advance! ^^

Welcome to our forum, and thank you for participating. Since you are new to openSUSE Linux, I recommend you read this openSUSE Linux concepts page, to become more familiar with to level concepts:
Concepts - openSUSE

I will assume you have sound working in other applications. Please advice me if you have no sound in any application. You can test for sound by copying and pasting the following in an xterm/konsole:
speaker-test -Dplug:front -c2 -l5 -twav

Typically openSUSE users will obtain their “vlc” from one of two repositories (videolan or Packman). From which repository did you obtain the version of “vlc” on your PC? Note it is often best not to mix rpms from these two repositories. Hence I recommend you set up your repositories with the Packman repository per the guidance in this URL:
Repositories/11.0 - openSUSE-Community
Add only OSS, NON-OSS, Update and Packman. Only select those 4 for now.

Now install vlc again, and also install

  • w32codec-all
  • xvid

And finally, if you have 3D affects enabled, you could have problems seeing the video on vlc, in which case inside the vlc program switch its video input to x11 (or disable special effects).

I can not help with Foobar2000.

Good luck, and Welcome to our forum.

hey oldcpu! thanks for your reply! http://matere.superforum.fr/users/a3/30/30/81/smiles/647135.gif

Indeed, it was useful, thanks for the link! http://matere.superforum.fr/users/a3/30/30/81/smiles/166291.gif

Yup, sound works: I was listening to Herbie Hancock while writing the first post… with banshee…

I obtained VLC fron the VLC repository http://matere.superforum.fr/users/a3/30/30/81/smiles/192196.gif
So I did like you said: I deleted the VLC repository, and installed VLC from packman (which was already installed), and w32codec-all and xvid.

But it still doesn’t work http://matere.superforum.fr/users/a3/30/30/81/smiles/117223.gif
When I try to open a video (avi, mkv, wmv) file, it returns a error message without details, or VLC simply kills itself. With mp3s, it opens, it seems to play it, but there’s no sound.

I thought that VLC is “shipped” with all the codecs (except realmedia ones).

I’ve read of that claim, but in practise I find that not to be the case.
Also, if you have custom 3D desktop selected, in vlc you could change your video input to ‘x11’.

http://matere.superforum.fr/users/a3/30/30/81/smiles/656580.gif

I assume you meant “output”. Yeah, I have images, but still no sound. Perhaps by playing with the audio outputs?

We make progress! ^^

yeeeaaah!

with “Linux OSS audio output” for audio output, it works! http://matere.superforum.fr/users/a3/30/30/81/smiles/586261.gif

thank you again!

Congratulations. … Does it not work with the “ALSA” setting? I ask that, because if you wish to have multiple applications able to play sound at once, they all must be using ALSA.

Well, I spoke too fast: it doesn’t play the sound anymore. The video is ok, but when I try to increase the volume, VLC crashes. And it tends to reset the outputs to “default”. http://matere.superforum.fr/users/a3/30/30/81/smiles/113784.png

get MPlayer or Xine, dude. Solves all your problems. VLC is very buggy

IMHO this is not vlc by itself, but its interaction with other factors. Please copy and paste in an xtern/konsole and run the following two diagnostic scripts and post on this thread the output URLs that they provide:

wget -O alsa-info.sh http://www.alsa-project.org/alsa-info.sh && bash alsa-info.sh 

For this next script, when prompted for a password enter the root password, and type “NO” for every question that you do not understand.

su -c 'wget -O tsalsa wget http://home.cfl.rr.com/infofiles/tsalsa && bash tsalsa' 

again, post here the URL that each of these scripts create.

Also copy and paste the following (one line at a time) into an xterm/konsole and post here the output of:
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
cat /etc/modprobe.d/sound

Please also point to a location on the web (if possible) of the video that is causing your vlc to crash when you try to change the audio.

Just to figure what’s happening, could you execute vlc in a console and post the messages while the program is playing some file?

here it is the first URL: http://pastebin.ca/1063738

tsalsa.txt - nopaste.com (beta)

rpm -qa | grep alsa

alsa-oss-1.0.15-48.1
alsa-utils-1.0.16-35.1
alsa-plugins-1.0.16-57.1
alsa-1.0.16-39.1
alsa-plugins-pulse-1.0.16-57.1

rpm -qa | grep pulse

pulseaudio-module-bluetooth-0.9.10-26.1
pulseaudio-module-lirc-0.9.10-26.1
libpulse0-0.9.10-26.1
pulseaudio-module-x11-0.9.10-26.1
pulseaudio-module-zeroconf-0.9.10-26.1
libpulse-mainloop-glib0-0.9.10-26.1
pulseaudio-0.9.10-26.1
pulseaudio-module-gconf-0.9.10-26.1
pulseaudio-esound-compat-0.9.10-26.1
alsa-plugins-pulse-1.0.16-57.1
libpulsecore4-0.9.10-26.1
libpulse-browse0-0.9.10-26.1
pulseaudio-utils-0.9.10-26.1
gstreamer-0_10-pulse-0.9.7-42.pm.1

rpm -q libasound2

libasound2-1.0.16-39.1

cat /etc/modprobe.d/sound

options snd slots=snd-hda-intel
# u1Nb.xqPQcijbrk4:82801H (ICH8 Family) HD Audio Controller
alias snd-card-0 snd-hda-intel
baobob@linux-dxu6:~/Desktop> vlc projettripspain.wmv
VLC media player 0.8.6h Janus
[00000317] dc1394 demuxer error: Bad MRL, please check the option line (MRL was: projettripspain.wmv)
*** PULSEAUDIO: Unable to connect: Connection refused
[00000366] esd audio output error: cannot open esound socket (format 0x00001021 at 44100 Hz)
*** PULSEAUDIO: Unable to connect: Connection refused
X Error of failed request:  BadAlloc (insufficient resources for operation)
  Major opcode of failed request:  140 (XVideo)
  Minor opcode of failed request:  19 ()
  Serial number of failed request:  86
  Current serial number in output stream:  87

In Achieve Zen with openSUSE 11 it’s already said that “VLC required root to have audio, wtf?”.

I would say if someone with PulseAudio (and ALSA redirecting to it) wants to get sound from VLC he should one of these:

  • Add himself to the audio group? Some people have reported to work.
  • Remove alsa-plugins-pulse package.
  • Use VLC with EsounD?
  • Ask Packman to package vlc-plugin-pulse

I tried your 3 first tips. But I can’t find vlc-plugin-pulse with the software manager, in the packman reposery.http://matere.superforum.fr/users/a3/30/30/81/smiles/440836.gif

Well it seems a problem related to sound server. But you also have no video output. What is your graphic card? I had a problem whit the video driver also. I have a fresh test install but now i am not at home. I could try to replicate the operation tomorrow if you let of know your hardware.

Let say that, most of the time, the video is ok. I can’t telle exactly what is my graphic card. It’s built in the mother board I think, Intel Graphics Media Accelerator X3100, something like that.

unfortunately, MPlayer didn’t solve all my problems: it behaves like vlc. http://matere.superforum.fr/users/a3/30/30/81/smiles/623562.gif

This looks like a 3D desktop error. Do you still get this with your 3D desktop disabled?

You could try ensure your alsa is setup for your PC hardware. Here are two possible edits you could try for your /etc/modprobe.d/sound file. After each edit, restart your alsa with “rcalsasound restart”

options snd slots=snd-hda-intel
# u1Nb.xqPQcijbrk4:82801H (ICH8 Family) HD Audio Controller
alias snd-card-0 snd-hda-intel
options snd-hda-intel=auto

then restart alsa with rcalsasound restart and test. Ensure you have alsa selected in your vlc sound output.

If that doesn’t work, for your acer PC try

options snd slots=snd-hda-intel
# u1Nb.xqPQcijbrk4:82801H (ICH8 Family) HD Audio Controller
alias snd-card-0 snd-hda-intel
options snd-hda-intel=acer

then restart alsa with rcalsasound restart and test. Ensure you have alsa selected in your vlc sound output.

But if this a 3D graphic problem, then the above will not help.