VLC installation problem

Hello everyone.

I have openSuse 11.3 installed on my machine and today i tried to install VLC player.
So i added the vlc repostiories(Index of /pub/videolan/vlc/SuSE/11.4/) from yast.
When i tried to install the vlc though it came up with an dependence issue saying nothing provides libdvbpsi.so.6 need by vlc-noX
So i check for that library and it turns out that a newer version of it is installed (libdvbpsi.so.7), but the installation still will not proceed.

I also try installing it by breaking the dependencie but when i run vlc in cmd it comes up with an error saying this:

VLC media player 2.0.3 Twoflower (revision 2.0.2-93-g77aa89e)
[0x80503f0] main libvlc: Running vlc with the default interface. Use ‘cvlc’ to use vlc without interface.
vlc: symbol lookup error: /usr/lib/vlc/plugins/gui/libqt4_plugin.so: undefined symbol: _ZN9QListData6detachEi

which i can’t understand anyway.
For what is worth i have the packman repository installed and i have switched all the multimedia packages that i had already installed to it.

So if anyone could lend me a hand that would be great.

Thanks for your time!

11.3 is no longer supported
And you shouldn’t use vlc repo either

Packman here
Index of /pub/linux/packman/suse/11.3

Guide here

Thanks for your reply!
I installed vlc from packman.
Though i don’t understand why shouldn’t use VLC repository.
Anyway thanks again.

Because multimedia mostly comes from Packman and vlc repo should only be used to supply libdvdcss and then disabled - the vlc repo generally cause conflicts with the general multimedia supplied by packman.