VLC GUI can't run properly ons OpenSUSE 13.2

Dear all,

I installed VLC from the packman repository. Unfortunately, VLC fails to open the dialogue window with the following error:


VLC media player 2.2.4 Weatherwax (revision 2.2.4)
[0000000000f61aa8] core demux error: corrupt module: /usr/lib64/vlc/plugins/access/libdvdnav_plugin.so
[0000000000e910b8] core libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
[0000000000f9de08] skins2 interface error: no suitable dialogs provider found (hint: compile the qt4 plugin, and make sure it is loaded properly)
[0000000000f9de08] skins2 interface error: cannot instantiate qt4 dialogs provider
[0000000000f9de08] [cli] lua interface: Listening on host "*console".

Only when using “Open With” and specifying vlc, I am able to open some strange version of VLC which has no tabs and basically just shows the video. Even stopping it is problematic, and I had to do it via the command line.

The repositories I have enabled list as follows:

sudo zypper lr -d
# | Alias               | Name                         | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                          | Service
--+---------------------+------------------------------+---------+-----------+---------+----------+--------+--------------------------------------------------------------+--------
1 | ftp.gwdg.de-suse    | Packman Repository           | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_13.2/     |        
2 | repo-non-oss        | openSUSE-13.2-Non-Oss        | Yes     | ( p) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.2/repo/non-oss/ |        
3 | repo-oss            | openSUSE-13.2-Oss            | Yes     | ( p) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.2/repo/oss/     |        
4 | repo-update         | openSUSE-13.2-Update         | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.2/                    |        
5 | repo-update-non-oss | openSUSE-13.2-Update-Non-Oss | Yes     | ( p) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.2-non-oss/

About an year ago I managed to install VLC, but now I run again into some nasty problems…

I would appreciate your help,

You say that you installed VLC from the Packman repo, but did you also do the “switch to Packman” that is needed for full multimedia support? Else there can stil be crippled libraries from the OSS repo used by VLC.

Please post output from

rpm -qa | grep vlc

Also, make sure that vlc-qt is installed (though it shouldn’t normally be possible to not have it installed…).

Your error message about dvdnav implies that you did not do a full switch to Packman as hcvv wrote (i.e. you have a different dvdnav installed than vlc expects), so do this as a first step.

If that doesn’t help, please post the list of Qt5 packages you have installed:

rpm -qa | grep Qt5

And the output of:

ldd /usr/lib64/vlc/plugins/gui/libqt4_plugin.so

(if you use a 32bit system, omit the “64” in lib64)

VLC from Packman works fine here on my 13.2 system, and I never had problems with it either.

In your case, the Qt interface cannot be loaded though.

Thank you all for the replies,

I was able to miraculously cure the problem by running update. I don’t know what exactly happened but for now it works ok.

Here are the outputs you requested: (hope there are no further hidden mistakes. )

rpm -qa | grep vlc
vlc-2.2.4-3.3.x86_64
vlc-qt-2.2.4-3.3.x86_64
vlc-noX-lang-2.2.4-3.3.noarch
vlc-codecs-2.2.4-3.3.x86_64
libvlccore8-2.2.4-3.3.x86_64
vlc-noX-2.2.4-3.3.x86_64
libvlc5-2.2.4-3.3.x86_64

rpm -qa | grep Qt5
libQt5Widgets5-5.4.2-22.3.x86_64
libQt5Core5-5.4.2-22.3.x86_64
libQt5Gui5-5.4.2-22.3.x86_64
libQt5X11Extras5-5.4.2-9.3.x86_64
libQt5DBus5-5.4.2-22.3.x86_64
ldd /usr/lib64/vlc/plugins/gui/libqt4_plugin.so
        linux-vdso.so.1 (0x00007ffc934c8000)
        libvlccore.so.8 => /usr/lib64/libvlccore.so.8 (0x00007f3d75eab000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f3d75c8e000)
        libQt5Widgets.so.5 => /usr/lib64/libQt5Widgets.so.5 (0x00007f3d75418000)
        libXi.so.6 => /usr/lib64/libXi.so.6 (0x00007f3d75208000)
        libQt5X11Extras.so.5 => /usr/lib64/libQt5X11Extras.so.5 (0x00007f3d75004000)
        libQt5Gui.so.5 => /usr/lib64/libQt5Gui.so.5 (0x00007f3d748e7000)
        libQt5Core.so.5 => /usr/lib64/libQt5Core.so.5 (0x00007f3d74223000)
        libX11.so.6 => /usr/lib64/libX11.so.6 (0x00007f3d73ee5000)
        libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00007f3d73bdc000)
        libm.so.6 => /lib64/libm.so.6 (0x00007f3d738db000)
        libc.so.6 => /lib64/libc.so.6 (0x00007f3d73534000)
        libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007f3d7331c000)
        librt.so.1 => /lib64/librt.so.1 (0x00007f3d73114000)
        libidn.so.11 => /usr/lib64/libidn.so.11 (0x00007f3d72ee0000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00007f3d72cdb000)
        libdbus-1.so.3 => /lib64/libdbus-1.so.3 (0x00007f3d72a94000)
        /lib64/ld-linux-x86-64.so.2 (0x00007f3d766cd000)
        libgobject-2.0.so.0 => /usr/lib64/libgobject-2.0.so.0 (0x00007f3d72843000)
        libglib-2.0.so.0 => /usr/lib64/libglib-2.0.so.0 (0x00007f3d72534000)
        libXext.so.6 => /usr/lib64/libXext.so.6 (0x00007f3d72322000)
        libpng16.so.16 => /usr/lib64/libpng16.so.16 (0x00007f3d720e5000)
        libharfbuzz.so.0 => /usr/lib64/libharfbuzz.so.0 (0x00007f3d71e8b000)
        libz.so.1 => /lib64/libz.so.1 (0x00007f3d71c75000)
        libGL.so.1 => /usr/lib64/libGL.so.1 (0x00007f3d719e5000)
        libicui18n.so.53.1 => /usr/lib64/libicui18n.so.53.1 (0x00007f3d715a1000)
        libicuuc.so.53.1 => /usr/lib64/libicuuc.so.53.1 (0x00007f3d7121f000)
        libpcre16.so.0 => /usr/lib64/libpcre16.so.0 (0x00007f3d70fbc000)
        libxcb.so.1 => /usr/lib64/libxcb.so.1 (0x00007f3d70d9b000)
        libffi.so.4 => /usr/lib64/libffi.so.4 (0x00007f3d70b93000)
        libpcre.so.1 => /usr/lib64/libpcre.so.1 (0x00007f3d70926000)
        libfreetype.so.6 => /usr/lib64/libfreetype.so.6 (0x00007f3d7068f000)
        libgraphite2.so.3 => /usr/lib64/libgraphite2.so.3 (0x00007f3d70472000)
        libexpat.so.1 => /usr/lib64/libexpat.so.1 (0x00007f3d70247000)
        libglapi.so.0 => /usr/lib64/libglapi.so.0 (0x00007f3d7001d000)
        libXdamage.so.1 => /usr/lib64/libXdamage.so.1 (0x00007f3d6fe1a000)
        libXfixes.so.3 => /usr/lib64/libXfixes.so.3 (0x00007f3d6fc13000)
        libX11-xcb.so.1 => /usr/lib64/libX11-xcb.so.1 (0x00007f3d6fa11000)
        libxcb-glx.so.0 => /usr/lib64/libxcb-glx.so.0 (0x00007f3d6f7f9000)
        libxcb-dri2.so.0 => /usr/lib64/libxcb-dri2.so.0 (0x00007f3d6f5f3000)
        libxcb-dri3.so.0 => /usr/lib64/libxcb-dri3.so.0 (0x00007f3d6f3f0000)
        libxcb-present.so.0 => /usr/lib64/libxcb-present.so.0 (0x00007f3d6f1ed000)
        libxcb-sync.so.1 => /usr/lib64/libxcb-sync.so.1 (0x00007f3d6efe6000)
        libxshmfence.so.1 => /usr/lib64/libxshmfence.so.1 (0x00007f3d6ede3000)
        libXxf86vm.so.1 => /usr/lib64/libXxf86vm.so.1 (0x00007f3d6ebdd000)
        libdrm.so.2 => /usr/lib64/libdrm.so.2 (0x00007f3d6e9d0000)
        libicudata.so.53.1 => /usr/lib64/libicudata.so.53.1 (0x00007f3d6e7cf000)
        libXau.so.6 => /usr/lib64/libXau.so.6 (0x00007f3d6e5ca000)

Most likely explanation I think (which I already wanted to hint at) is that you still had Qt5 5.3.2 from the standard 13.2 repo installed.
Packman builds against the update repo, so its vlc-qt package requires Qt5 5.4.2, which got installed by updating the system.

Here are the outputs you requested: (hope there are no further hidden mistakes. )

No, looks fine.

No, looks fine.

I hope it really is. I also don’t have problems with flash player too. On my old system I had quite a mess with the players, now after a clean install it is all fine.
Best Regards.

Flash player is not using Qt5, and it is a binary blob anyway, unrelated to most packages on your system.

Hi,
after solving my problem with VLC, I run into the situation where my “Lenovo Display port” treats the external screen as an individual one and shows something different from what I see on my laptop screen. Is it possible to simply duplicate what I see on my laptop screen on the external screen? I am not sure whether I broke something on my system or this is option that has to be fixed. With HDMI this is done automatic.

New problem, please a new thread.

How do you think that the title of this thread will draw the attention of people to a screen problem?

New thread, maybe in another forum (well, this one should have been in Mutimedia shouldn’t it?), good telling title. That is the way to advertize your problem.

I managed to solve the screen problem, but run into another vlc nasty pitfall.
VLC plays movies very slow i.e. mp4 & wmv . On SUSE 13.1 I solved this by deleting :

 libvdpau_va_gl1

Are there better ways to do that, after all deleting libraries sounds like a bad solution to me.

As I said, another problem, another thread! Many people will look if there are new threads with new problems. They will not look at the end of old threads?

You need help, do not send your questions to a black hole!

This thread is CLOSED.