VLC from Packman not playing mp4 files

Thanks everyone for the help :blush: !!

However I was running into a trouble just blindly following the 4 line commands as suggested by @I_A
I didn’t realize that the same URL would not work for me since my openSUSE version is different. So, I changed the link at the end from ‘openSUSE_Tumbleweed/’ to 'openSUSE_Leap_15.4/ ’ since I have Leap_15.4 instead of Tumbleweed, which makes sense. But somehow, it was still not working :expressionless:

Then from the official website I found a replacement for this first line of command, where the link specified is also different.

sudo zypper ar -cfp 90 'https://ftp.fau.de/packman/suse/openSUSE_Leap_$releasever/' packman

Here, you can also notice that you just type openSUSE_Leap_$releasever at the end so it automatically sets the version. After doing this, all the lines as given by @I_A worked smoothly except, I also added -–allow-vendor-change at the end of second line as suggested by others and also seen in the official website. I didn’t actually try if it would work without specifying this.

So, finally for any new openSUSE users my answer is this:

  • You need to have VLC installed from ‘packman’ repository for it’s best perfomance
  • For this you need to make sure you have this repository in your system now. To list out current repositories type zypper lr -d and you will see it there, if it is there.
  • Some time it will be there but disabled, may be enabling it will make the rest of the steps possible!
  • May be your problem is you are not able to proceed even though it is there. Then I would suggest you to remove whatever you have anyway, and start from a fresh beginning - try it once.
  • To remove the repository use the following command:
sudo zypper removerepo http://packman.inode.at/suse/openSUSE_Leap_15.4/

( *specify the right link as printed out by the command zypper lr -d )

  • Now starting freshly, add the pacman repository by running:
sudo zypper ar -cfp 90 'https://ftp.fau.de/packman/suse/openSUSE_Leap_$releasever/' packman

( *Again, remember to find the latest URL for you & your openSUSE version - may be you could just try changing ‘Leap’ to ‘Tumbleweed’ or whatever you have! )

  • Now, just run rest of the commands
sudo zypper dup --from packman --allow-vendor-change
sudo zypper in vlc-codecs 
sudo zypper rm vlc-codec-gstreamer

Doing this, everything working for me! :slight_smile:

btw, a question to @I_A: I am still not sure why we are removing ‘vlc-codec-gstreamer’, could you please clarify a little more?

At the same time, I have been facing a minor problem that, in my black and white video made using ffmpeg with ‘h264’ codec, Black was appearing as Green! - I could fix by going to Tools-> Preferences menu, and choosing Hardware-accelarated-decoding from ‘Automatic’ to any of { VDPAU video decoder/ VA-API video decoder via DRM } or just disabling it works as well. VA-API decoder do not work without DRM!

p.s: I am new to openSUSE and also have only less knowledge about repositories and how it works, so I might have made some wrong usage of words or concepts. Glad if someone could correct them :slight_smile:
Still I hope blindly following this should also work as it worked for me in 2 computers!!