VLC fails to open certain video types (notably FLV).

Hi! :slight_smile:

I installed VLC on a fresh system, but it failed to play certain video types (notably FLV).
On OpenSUSE 13.1 x64 with KDE.
VLC installed with 1-click from VLC page.
(I also tried the one from Packman with the additional codecs, with similar results).

giorgos@linux-a2h3:~> rpm -qa | grep vlc
giorgos@linux-a2h3:~> zypper lr -d
#  | Ψευδώνυμο                 | Όνομα                              | Ενεργοποιημένο | Ανανέωση | Προτεραιότητα | Τύπος  | URI                                                             | Υπηρεσία
 1 | SuSE                      | SuSE                               | Yes            | Yes            |   99          | rpm-md | http://download.videolan.org/SuSE/13.1/                         |         
 2 | nVidia Graphics Drivers   | nVidia Graphics Drivers            | Yes            | Yes            |   99          | rpm-md | http://download.nvidia.com/opensuse/13.1/                       |         
 3 | repo-debug                | openSUSE-13.1-Debug                | No             | Yes            |   99          | NONE   | http://download.opensuse.org/debug/distribution/13.1/repo/oss/  |         
 4 | repo-debug-update         | openSUSE-13.1-Update-Debug         | No             | Yes            |   99          | NONE   | http://download.opensuse.org/debug/update/13.1/                 |         
 5 | repo-debug-update-non-oss | openSUSE-13.1-Update-Debug-Non-Oss | No             | Yes            |   99          | NONE   | http://download.opensuse.org/debug/update/13.1-non-oss/         |         
 6 | repo-non-oss              | openSUSE-13.1-Non-Oss              | Yes            | Yes            |   99          | yast2  | http://download.opensuse.org/distribution/13.1/repo/non-oss/    |         
 7 | repo-oss                  | openSUSE-13.1-Oss                  | Yes            | Yes            |   99          | yast2  | http://download.opensuse.org/distribution/13.1/repo/oss/        |         
 8 | repo-source               | openSUSE-13.1-Source               | No             | Yes            |   99          | NONE   | http://download.opensuse.org/source/distribution/13.1/repo/oss/ |         
 9 | repo-update               | openSUSE-13.1-Update               | Yes            | Yes            |   99          | rpm-md | http://download.opensuse.org/update/13.1/                       |                                                                                
10 | repo-update-non-oss       | openSUSE-13.1-Update-Non-Oss       | Yes            | Yes            |   99          | rpm-md | http://download.opensuse.org/update/13.1-non-oss/               |         

Try to reinstall vlc from the packman repository because your vlc packages looks outdated. And remove the ~/.config/vlc/ directory to delete the old vlc configuration.
Maybe that helps.

Since this is a fresh installation I always set up my audio from Packman first.
Please delete all of the VLC packages installed from VideoLan repo. Next delete the VideoLan repository and add the Packman and libdvdcss repositories.

Close Yast and open konsole and type in “su -” without quotes followed by your password.

Copy and paste the line below:

zypper install libxine2-codecs ffmpeg lame gstreamer-0_10-plugins-good gstreamer-0_10-plugins-bad gstreamer-0_10-plugins-ugly gstreamer-0_10-plugins-bad-orig-addon gstreamer-0_10-plugins-good-extra gstreamer-0_10-plugins-ugly-orig-addon gstreamer-0_10-plugins-ffmpeg libdvdcss2 flash-player dvdauthor07 gstreamer-plugins-base gstreamer-plugins-bad gstreamer-plugins-bad-orig-addon gstreamer-plugins-good gstreamer-plugins-ugly gstreamer-plugins-ugly-orig-addon gstreamer-plugins-good-extra gstreamer-0_10-plugins-fluendo_mpegdemux gstreamer-0_10-plugins-fluendo_mpegmux k3b-codecs gecko-mediaplayer vlc vlc-codecs smplayer h264enc x264 w32codec-all

Restart VLC and open the file again. It will work including mpeg-4, mpg3, wav, QuickTime and more.


Follow Up

Check this link for reference: https://forums.opensuse.org/blog.php/204-caf4926

The OP doesn’t have Packman repo although they mention trying VLC from there.

It’s possible to use just VideoLan repo, though you will limit your overall multimedia options.
If using just VideoLan you can add this repos

su -
zypper ar -f http://gstreamer.leuenberger.net/openSUSE_13.1/ gstreamer


zypper dup --from gstreamer

THANKS guys!!! :wink:
Problem solved.

I installed vlc from Packman (and also the dvdcss library repository).
I still don’t know what went wrong in the first place.
I’m suspecting, that I forgot to delete the config files, but I’m not sure.

**THANKS A MILLION!!! ** :slight_smile:

It is suggested that you disable VLC repo if you are using packman repo

I tried both repos (restoring an earlier system image), but I think before installing Packman repo, I had already (by mistake) installed vlc from normal repo that lead to problem.

Good job! It’s great to hear that your sound problem has been resolved!

If you get the different version and dependencies from different repos mixed together they generally don’t work. I suspect that is what happened. openSUSE doe not directly support non-open codecs and such so you have to get closed source stuff from Packman and also their version which in general will not match the openSUSE repo version.


Agreed. I experienced these issues more with the openSUSE 11x series.
Once openSUSE evolved and **added **the “Change vendor” or “Switch system packages” switch to Yast Software Management I was able to resolve these issues.