VLC DVD Problem

Hi. First I need to say I didn’t check to see if this was anywhere else in the forums. I’ve been trying to find a solution online but can’t and I’m really too tired right now to search through posts.
I’ve been using linux since 2007ish.

I was using openSuSE 13.1 with MPlayer as my goto media player and VLC for DVDs.

When I upgraded to openSuSE 13.2 I lost the ability to play back DVDs and flash. I installed all codecs required but still no dice. The wierd thing is that they can both play anything except DVDs. I’ve tested them on different formats and everything plays. However, when I put in a DVD the disk itself is recognised and comes up on the quicklaunch device manager.

If I select play with VLC, VLC starts but has an empty window as if you had to open it normally without loading a file or DVD. When I click play nothing happens. If I then try load up the DVD from within VLC same thing. I also tried using MPlayer and navigating to the VOB files and trying to play those. Doesn’t work either.

I really don’t get it. I can play anything (flash, mpeg, divx, mp4, etc. etc.) But DVDs don’t play.

Anyone got an idea what’s up?

first things first post your repo list
zypper lr -d
from the sound of things it looks like you’re missing libdvdcss, I think there are 2 repo’s hosting it

sudo zypper ar http://opensuse-guide.org/repo/13.2/ "libdvdcss repository"
sudo zypper in libdvdcss

or use the 1 click media installer from here

Sorry about that. I thought of mentioning my repos but thought it wasn’t important. I’m using Packman for my multimedia libs. I did try using one click but for some reason it messed up my ability to play various media formats. After reading a bit I kinda came to the conclusion it somehow crossed packages from different repos so I removed my VLC repos and used packman only (I made the mistake of having both enabled). I then removed all players and codecs and reinstalled them and my video worked fine again (all formats) - just not DVD playback. So I’m a little weary of trying one click again.

Also, to my knowledge I installed libdvdcss but I’ll check and post again.

sighs and slaps face with desk

Thanks deeply for your help. It was libdvdcss. I feel really stupid now. I even thought of checking libdvdcss but ignored the thought as I was so sure I remembered installing it.

Thanks again for your help. hands a pizza flavoured cookie