vlc dependancies

Hi, I’ve just installed opensuse 11.1 kde 3.5x.
When I goto install vlc from the packman repo I get this error :

nothing provides libcv.so.1.2 needed by vlc-noX-1.0.2-0.pm.5.9.i586

I tried the oneclick link on the packman webpage

PackMan :: Package details for vlc

with the same error.

If I enable the videolan repo then installing from there gives no dependency issues but I don’t want to go down that route if poss.

Any ideas ?

Don’t install from VLC repo.

The issue you report is there for me too. But I already have vlc installed, so I just left it. I sent a report to Packman but not sorted yet. You can also work round by choosing
Do Not Install opencv-2.0.0…

Try to update your system and see if this can resolve the issue:

zypper up

Also enable the oss,non-oss and update repo and disable all others. and run the above command in terminal as root.

I ran an update from konsole, and whilst I got some updates not handled by the updater applet (including yast2-online-update) the problem with vlc persists.

Thanks for your quick replies.

Incidentally I’m Installing 11.1 KDE 4x on another machine, it’ll be interesting to see if the dependency is the same for that version of KDE.

The packaging error is at Packman not openSUSE, so the error will be the same. I just deleted vlc and libcv.so.1.2 (which I did have). Now I get the same issue as you and vlc will not install.
No matter, I never actually use vlc and it’s sure to be fixed soon. There have been hundreds of package changes in Packman recently.

This is the respose from Packman:

opencv has been updated, vlc is in building queue and will be rebuilt on
new opencv soon.

Thanks caf for the information.

All sorted now, I wish politicians were as responsive (and useful) as you guys.


rotfl! That’ll be the day. All help offered freely and happily.