VLC audio distortion, WMA2 only

I have VLC loaded on a number of 12.2 PCs, all with the same problem. I can view or listen to most feeds, but the exception is WMA2. The audio is severely distorted (all PCs). This consequently affects many feeds, including all BBC radio.

VLC streaming WMA2 has worked perfectly OK in all previous openSuSE versions and as it seems to affect all of my 12.2 installations I am guessing it might be a bug (VLC version 2.0.5)?

If I play same stream (presumably also WMA2) but via the BBC website in my Opera browser, then it plays perfectly OK.

Seems to be a long standing issue

#1817 (WMA2 inside ASF causes crackles and other anomalies) – VLC](http://trac.videolan.org/vlc/ticket/1817)

playing BBC1 and BBC World Service wma streams in VLC 2.0.5 works fine for me.
What version of ffmpeg do you have installed?

It seems I don’t have ANY version of ffmpeg loaded. I am guessing installation of VLC would normally include ffmpeg, if required? I checked, and the other PCs don’t have ffmpeg loaded, either. But if I select ffmpeg for installation there are several conflicts. Nevertheless, have loaded ffmpeg 1.0.1-3.3 but same problem persists.

If the vlc is from packamn i would try vlc from VLC site to check whether there are any packman related issues.
VideoLAN - VLC media player for openSUSE
openSUSE used to have vlc repo in the past but it had major conflict of packages with packman and hence community opted for removal of the same.

You will have had a group of files that are part of ffmpeg already installed. Mostly beginning with libav-
The fact that you received conflicts when installing ffmpeg suggests to me that you have files known to cause problems with wma .

You should switch all your multimedia to what is currently in packman.
There is a guide in the forum on how to do this but I can’t link to it at the moment as I am posting from my phone. It should be easy to find.

OK - I’m back on a real computer. :slight_smile:

My guess is your are suffering from the same problem as this thread.


the problem was caused by an ffmpeg (libavcodec) upgrade in packman.
The update was rolled back two or three weeks ago to an earlier version which fixed up the noise issues in wma files.

when you installed ffmpeg you should have let it downgrade the files listed as conflicts - specifically libavcodec54 (and probably some others).
My libavcodec54 version number is currently 1.0.1-3.3

Hallelujah! I just reinstalled ffmpeg and libavcodec54 and accepted recommended downgrades of other packages AND IT WORKS! :slight_smile:

Thanks for everyone’s help!

glad it worked out :slight_smile:

I also had problems playing some DVDs using AC3 audio with the newer ffmpeg version, downgrading also solved this problem… fyi.