VLC and Other Video Players Not Working

I cant open your link. Page is broken.

Once you have removed one of the packman repos and the vlc repo go to YaST -> View dropdown button -> Patterns -> select Packman repo in list -> Click Switch system packages -> then click accept.

Try now and open it http://20.imagebam.com/download.php?ID=54459645&salt=6b67e9&sec=7cbc64&filesize=177798&filename=repo-filter-packman-switch.png

Silly me, forgot that it is under Yast -> Software Management. Then go to View dropdown button -> Patterns -> select Packman repo in list -> Click Switch system packages -> then click accept.

I cant see pacman repo in list.

You can’t???

write this

su 
# zypper lr -d

And post results.

#  | Alias                              | Name                               | Enabled | Refresh | Priority | Type   | URI                                                                                               | Service
---+------------------------------------+------------------------------------+---------+---------+----------+--------+---------------------------------------------------------------------------------------------------+--------
1  | Packman Repository                 | Packman Repository                 | Yes     | Yes     |   99     | rpm-md | http://ftp.uni-erlangen.de/pub/mirrors/packman/suse/11.3/                                         |        
2  | google-chrome                      | google-chrome                      | Yes     | Yes     |   99     | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/i386                                                 |        
3  | libdvdcss                          | libdvdcss                          | Yes     | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/11.3/                                                              |        
4  | libdvdcss repository               | libdvdcss repository               | Yes     | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/11.3/                                                              |        
5  | openSUSE-11.3-Non-Oss              | openSUSE-11.3-Non-Oss              | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.3/repo/non-oss                                       |        
6  | openSUSE-11.3-OssopenSUSE-11.3-Oss | openSUSE-11.3-OssopenSUSE-11.3-Oss | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.3/repo/oss                                           |        
7  | openSUSE:Tumbleweed                | openSUSE:Tumbleweed                | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/openSUSE:/Tumbleweed/standard/                          |        
8  | openSUSE:Tumbleweed:Raw            | openSUSE:Tumbleweed:Raw            | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/openSUSE:/Tumbleweed:/Raw/openSUSE_Tumbleweed_standard/ |        
9  | packman                            | packman                            | Yes     | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/misc/packman/suse/11.3/                                              |        
10 | repo-debug                         | openSUSE-11.3-Debug                | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/debug/distribution/11.3/repo/oss/                                    |        
11 | repo-non-oss                       | openSUSE-11.3-Non-Oss              | No      | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.3/repo/non-oss/                                      |        
12 | repo-oss                           | openSUSE-11.3-Oss                  | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.3/repo/oss/                                          |        
13 | repo-source                        | openSUSE-11.3-Source               | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/source/distribution/11.3/repo/oss/                                   |        
14 | repo-update                        | openSUSE-11.3-Update               | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/11.3/                                                         |        
linux-prob:/home/baris # 

Run this in Terminal. First become root by doing:

su -

Then remove one of the Packman repos with this command

zypper rr 1

Once you have done that follow the instructions from my previous post:

which in group pacman repo list? I did say but I can’t still see pacman repo list this menu :confused:

Packman is in that repo list twice. Have a look at number 1 and number 9.

I saw pacman in the repositories. There are lots of packages. Which one should I choose?

Since you have already followed the multimedia guide I don’t think you will need anything additional. Just click on the “switch system packages” button in the Packman repo in YaST. Then click apply.

Ok. I did. What can I do now?

Well since you have followed the multi-media guide, removed the Videolan repo, removed the extra packman repo and have switched packages to the other Packman repo in YaST it should be working fine now. Check and see.

Do you have a terminal code for them?

What I mean is to try VLC and see whether it is working now.

Okay it done. VLC is working but, when I try to open mpeg video VLC closes…

Run VLC in the terminal like this:


vlc

Is there any output from the terminal when you try to play a mpeg video in vlc? If there is post it here.

Andrew maybe the problem is about xorg from soundcards.

baris@linux-prob:~> vlc
VLC media player 1.1.7 The Luggage (revision exported)
Blocked: call to unsetenv("DBUS_ACTIVATION_ADDRESS")
Blocked: call to unsetenv("DBUS_ACTIVATION_BUS_TYPE")
[0x80503fc] main libvlc: vlc varsayılan arayüz içe çalışır. Arayüz olmadan çalıştırmak için 'cvlc' kullanın.
Blocked: call to setlocale(6, "")
Blocked: call to dlopen("/usr/lib/kde4/plugins/gui_platform/libkde.so", 1)
Blocked: call to setlocale(6, "")
Warning: call to rand()
Warning: call to rand()
Warning: call to rand()
Warning: call to rand()
Warning: call to rand()
(6867): Trying to open ksycoca from  "/var/tmp/kdecache-baris/ksycoca4"
Blocked: call to putenv("LANGUAGE=")
/usr/bin/xdg-screensaver: line 543: dcop: komut yok
Blocked: call to setlocale(1, "C")
Blocked: call to setlocale(1, "tr_TR.UTF-8")
Blocked: call to setlocale(1, "C")
Parçalama arızası

Parçalama arızası: segmentation fault