vlc and mplayer very slow on kde 4.3

i reinstall fresh opensuse 11.1 x64. the i upgrade kde to the factory kde (4.3 rc1) using zypper dup . after that i install vlc and mplayer .

when i play a movie , vlc so slow that you can notice flick. while mplayer still playable but still notice slow.

i don’t have such problem on kde 4.1 . also others program run pretty fast compare on kde 4.1 .why only effect video playback?

the nvidia driver up todate

when you play a file with mplayer through the terminal, what does it report? what’s the output?

did you update your distro to opensuse 11.2?

zypper dup --help

Maybe check and see if playback is better if you switch video playback in the settings fro VLC to x11

mplayer

MPlayer dev-SVN-r29116-4.3-openSUSE Linux 11.1 (x86_64)-Packman (C) 2000-2009 MPlayer TeamCan’t open joystick device /dev/input/js0: No such file or directory
Can’t init input joystick
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing aaa.mkv.
[mkv] Track ID 1: video (V_MPEG4/ISO/AVC), -vid 0
[mkv] Track ID 2: audio (A_AC3), -aid 0, -alang jpn
[mkv] Track ID 3: subtitles (S_TEXT/ASS), -sid 0, -slang eng
[mkv] Will play video track 1.
Matroska file format detected.
VIDEO: [avc1] 1280x720 24bpp 23.976 fps 0.0 kbps ( 0.0 kbyte/s)
SUB: Could not determine file format
Cannot load subtitles: ./aaa.txt

Opening video decoder: [ffmpeg] FFmpeg’s libavcodec codec family
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)

==========================================================================
Opening audio decoder: [liba52] AC3 decoding with liba52
Using SSE optimized IMDCT transform
Using MMX optimized resampler
AUDIO: 48000 Hz, 2 ch, s16le, 320.0 kbit/20.83% (ratio: 40000->192000)
Selected audio codec: [a52] afm: liba52 (AC3-liba52)

[AO OSS] audio_setup: Can’t open audio device /dev/dsp: Device or resource busy
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback…
VDec: vo config request - 1280 x 720 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [xv] 1280x720 => 1280x720 Planar YV12
A: 6.8 V: 6.8 A-V: 0.001 ct: 0.002 0/ 0 64% 8% 1.1% 7 0
Exiting… (Quit)

vlc

VLC media player 1.1.0-git Yellow *******
[0x72a758] main interface error: no interface module matched “globalhotkeys,none”
[0x72a758] main interface error: no suitable interface module
[0x608638] main libvlc error: interface “globalhotkeys,none” initialization failed
[0x608638] main libvlc: Running vlc with the default interface. Use ‘cvlc’ to use vlc without interface.
[0x608638] main libvlc error: option sub-original-fps does not exist
[0x8929b8] main input error: no suitable demux module for `/subtitle:///media/disk/aaa.txt’
[0xb57a58] a52 decoder: A/52 channels:2 samplerate:48000 bitrate:320000
[0xb90258] freetype spu text error: failed to load font file /usr/share/fonts/truetype/FreeSerifBold.ttf
No accelerated IMDCT transform found
QPainter::begin: Paint device returned engine == 0, type: 1
QPainter::setClipRegion: Painter not active
QPainter::setClipping: Painter not active, state will be reset by begin
QPainter::begin: Paint device returned engine == 0, type: 1
QPainter::begin: Paint device returned engine == 0, type: 1
QPainter::setClipRegion: Painter not active
QPainter::setClipping: Painter not active, state will be reset by begin
QPainter::begin: Paint device returned engine == 0, type: 1
QPainter::begin: Paint device returned engine == 0, type: 1
QPainter::setClipRegion: Painter not active
QPainter::setClipping: Painter not active, state will be reset by begin
QPainter::begin: Paint device returned engine == 0, type: 1
number of reference frames exceeds max (probably corrupt input), discarding one
number of reference frames exceeds max (probably corrupt input), discarding one
number of reference frames exceeds max (probably corrupt input), discarding one
number of reference frames exceeds max (probably corrupt input), discarding one
number of reference frames exceeds max (probably corrupt input), discarding one
number of reference frames exceeds max (probably corrupt input), discarding one
number of reference frames exceeds max (probably corrupt input), discarding one
number of reference frames exceeds max (probably corrupt input), discarding one
number of reference frames exceeds max (probably corrupt input), discarding one
number of reference frames exceeds max (probably corrupt input), discarding one
number of reference frames exceeds max (probably corrupt input), discarding one
number of reference frames exceeds max (probably corrupt input), discarding one
number of reference frames exceeds max (probably corrupt input), discarding one
number of reference frames exceeds max (probably corrupt input), discarding one
[0xe26da8] avcodec decoder error: more than 5 seconds of late video -> dropping frame (computer too slow ?)

i don’t think so . i only added

Index of /repositories/KDE:/KDE4:/Factory:/Desktop/openSUSE_11.1

Index of /repositories/KDE:/KDE4:/Community/openSUSE_11.1_KDE4_Factory_Desktop

Index of /repositories/KDE:/KDE4:/Playground/openSUSE_11.1_KDE4_Factory_Desktop

Index of /repositories/KDE:/Backports/openSUSE_11.1

that all.

it seems your file is broken as reported by vlc (test on another one?). Also if your nVIDIA GPU supports VDPAU you may want to give it a try

mplayer file.mkv -vc ffh264vdpau