Vista x64 "No MBR found Press Ctrl Alt Delete to reboot”

I’m new to Linux/Dual boot kinda stuff but I have managed to get the thing working at last.

I’m writing this just in case there are others out there who have the same problem or made the same mistakes and have nearly given up trying to dual boot Vista x64 Ultimate and SUSE 11.1.

My goal was to KEEP my Vista installed on its SATA drive and chuck SUSE on the small IDE drive I’ve been using for a LAN shared drive.

So I downloaded and burnt SUSE to disk Re-booted and proceeded to install to the IDE drive.
Once in and updated I went looking for Windows on reboot…
just to find that the MBR for Vista had vanished.
I followed the advise give in the help sections here but with no joy.
Not because the advise is bad. Its spot on but once I’d told Grub where to find the Windows install I got the same results…
“No MBR found Press Ctrl Alt Delete to reboot”.

Time for a walk and think…
(the following is only a guess & I’m sure I will be corrected if I’m wrong)

I had the feeling that Vista had put its MBR on the IDE drive and I’d just tap-danced SUSE all over it OOPS! I hadn’t considered this before as it makes no sense to me for Vista to do it this way. Unless it just likes to get its mitts on everything.

I fixed by…

Power down PC to dead.
Disconnect the NON-Vista drive from motherboard.
Boot and Repair Vista with its install disk
Vista is now on one hard drive. No choice given to it…HA!

Power down.
Reconnected the second drive (IDE)
Re-install SUSE to it. (wouldn’t repair)


On reboot Windows worked fine when chosen.

Its not pretty but it worked.

Feel free to rip to bits Boffins. lol!