Virtualization with xen - nothing added in menu.lst


I tried to use the YAST’s virtualization option to install hypervisor and xen, but it didn’t change my boot/grub/menu.lst, so i cant boot using the xen host kernel.

I could put the option there manually, but I don’t know what to insert.

Any help would be appreciated!

Hi there,

Are you sure the Xen kernel was installed? It should update menu.lst automatically I believe. I would check that first with:

rpm -qa | grep kernel

And if installed modify your menu.lst with something like this (substituting you kernel and initrd version,and your partition UUID for resume (or just use resume=/dev/sdx and not UUID))

###Don’t change this comment - YaST2 identifier: Original name: xen###
title Xen – openSUSE 11.1 -
root (hd0,0)
kernel /xen.gz
module /vmlinuz- resume=/dev/disk/by-id/ata-WDC_WD1200JB-00GVA0_WD-WCALA1864433-part6 splash=silent showopts vga=0x346
module /initrd-

I had Xen set up nicely, with one client. I then installed updates. That broke Xen quite dramatically.

  1. The system wouldn’t boot. I had to boot to the rescue system and reinstall the boot block.

root (hd0,5)
setup (hd0)

where the root value is taken from your menu.lst. It’s your root partition. I believe hd0,5 is /dev/sda6, because numbering is from 0.

  1. It omitted Xen from menu.lst. I added it manually. Like you I tried to use install hypervisor, but it didn’t update menu.lst.

I added the following entry:

title Xen
root (hd0,5)
kernel /boot/xen.gz
module /boot/vmlinuz-xen resume=/dev/sda5 splash=silent showopts vga=0x31a
module /boot/initrd-xen

root (hd0,5) should be replaced with your root partition. You can take the value from the non-Xen entry. Resume should be your swap partition. You can probably copy that from the other entry as well. I don’t know whether “repair=1” from the normal entry is needed or not. I didn’t use it, but I may not have needed it yet.

Very distressing.

I’m also finding the vm-install is broken in two ways:

  1. When creating a vm using Redhat 5, it has a minimum of 512M for memory and a maximum of 256M. Sort of hard to satisfy. Fortunately that stuff is in Python, so it’s easy to fix.

  2. When creating the new vm, output is routed to my terminal, except for the slight detail that the kernel is trying to send it to the display. So there’s no way to interact with the installer. Once the system is set up this can be fixed by adding console=xvc0 to the kernel line, but I don’t see a way to do that in vm-install. I’m using the GUI installer, but this is going to cause trouble later when I need to set up a vm via ssh.