virtualization options for win xp guest in opensuse

I’ve been running openSUSE versions from 9.2 onwards on a dual-boot laptop, which has a messy partition scheme including a Windows XP installation. Since I practically never use Windows, I’m seeking soon to do a reformat of the whole drive and a fresh installation of SUSE 11.1 with a virtualized copy of my Windows system available in case I need it.

Virtualization is completely new on me and most of the terminology goes way over my head. I was thinking I’d use Virtualbox since it allows Windows XP as a guest, but upon reading their FAQs I’m not sure if I can use it to make a virtual machine of my existing Windows installation? I know VMWare has such an option but is that the only one? What would be the best method for going about this?

Also, is it possible to put the XP virtual machine on some other medium like a DVD or USB stick, and run it directly off there as and when required?

If you have a windows cd you will be able to run it in virtualbox or vmware.
You can use wmware to make an image of you windows setup but not with the free version.
If you dot have any specific settings there are to ways to do things

  1. Use your cd to install in a VM
  2. Make a bootable iso of the cd which you store on your pc and install from that.
    The second version is what i prefer as i don’t need to load the cd if i want to add/remove something from windows

If you want to make an iso with service packs there’s a tutorial here just skip the last step and then use magiciso to convert to an iso


There’s a great program for customising windows installations and making a bootable disk that allows slipstreaming service packs, hotixes and drivers very easily that I’ve used for a number of years

It’s caled nLite, this is their site: nLite - Deployment Tool for the bootable Unattended Windows installation

They also have a version for vista called vLite that I’ve also used and found works just as well as nLite, though it doesn’t have as many ‘tweaking’ options yet as nLite

I have seen a tutorial somewhere on making a vm of an existing windows installation for vbox, but what you had to do with hal to get it booting made it such a rigmarole that it’s probably quicker to just make a vm using a fresh install as geoffro described … at least that’s how it seemed to me

If that xp has been on there since the days of suse 9.2 it’s probably well overdue a re-install anyway :wink:

Sorry, I forgot to mention one crucial thing -

I don’t have the CD!

I have a feeling there is some tedious and laborious way to go about creating installation discs, although I had a feeling that something I once did to the system precluded that possibility. Finding all this out will mean rebooting and spending at least 5 minutes in a raw Windows environment, which may be bad for my health.

Ideally, though, I wanted to avoid having to do a fresh install of the Windows installation, as I did configure quite a lot of things and spent what seemed like days downloading all the necessary Windows updates when I first got this laptop. It would be nice if there were some way to just freeze it exactly as it is now and make a virtualized version.

I found the tutorial I mentioned in my previous post, and it doesn’t look as tricky as I remembered, but then it was a while ago I found it

Here’s the page: Migrate_Windows - VirtualBox

If you can’t get it working I do have an idea for another way that may well work, let us know how you get on and if you can’t get the method above working I’ll test it out for ya, I may well just try it anyway out of curiosity

Thanks for the offer of help. I read through the Virtualbox page you suggested, and whilst it may not be over-complicated in itself, having seen some forum posts on their site it seems that the whole process is somewhat dodgy and not thoroughly tested. One person suggests that the program they recommend for merging the IDE channels totally ruined their system. It only really covers the import side of things. To actually export an existing Windows system with Virtualbox seems like a very bad idea at the present time.

I had another look through the VMWare site and it seems that the VMWare Converter product would make a fairly pain-free copy of my existing Windows installation, and it’s a free download, whilst the VMWare Player would then import it in Linux, and that’s also free. What I don’t quite understand is the default VMware tools provided in openSUSE. They state ‘Open Virtual Machine Tools (open-vm-tools) are the open source implementation of VMware Tools’, and there’s mention of them being usable for Unix-based guests. I don’t know if these would be sufficient for importing my Windows machine or whether I must specifically download some other proprietary version from the VMWare site (registration is required before I can get to that step or see what the files are).

Alas, all this now has to take a back seat once again since some other problems I’m having with my system have re-emerged, just after I thought I’d finally banished them. Until I can figure out a way of not being dumped at a command line login every time I boot the system I’ve no intention of doing a major reformat and reinstall, possibly only to find that problem still exists.

Sounds like your graphics drivers aren’t properly installed

You usually get a message regarding runlevel 5 just above the login prompt when this happens (going from a vague memory it says something like runlevel 5 not reached)

Is that the case with you?

I get to runlevel 5 but no graphical login. I posted on it earlier, here:
cli instead of graphical login with kde3/4 - openSUSE Forums

I’ve tried absolutely everything I can think of now, aside from either reinstalling the system or installing the proprietary ATI driver. I’m waiting for the latter to reinstate the repository for openSUSE 11.1 before I try it. However, all my attempts to install the ATI driver in the past ballsed up my system so I’m not holding out too much hope.

I switched the login from kdm to kdm3, and for a couple of times it worked, but not any longer. Auto-login is disabled, by the way (many others have got problems at the moment due to that but it doesn’t affect me). I’ve spent the last two weeks exhausting every other possibility and my days have been dull as dishwater :frowning:

I’d like to post a bug report but the whole thing is so vague I wouldn’t really know where to start or what log info to include. I don’t know if the problem lies with Xorg, the Radeon driver, kdm, the KDE4 implementation, or some other SUSE-specific configuration with the 11.1 release.

I’m running a Win XP guest in openSUSE 11.1, I installed VirtualBox and it is amazingly fast and simple to use.

Don’t forget to add your userid to vboxusers unless you want to run it as root and don’t forget to

chmod +x /etc/init.d/rc.vboxdrv so the kernel mod will be loaded at boot time.

I would certainly try installing the Ati driver manually, doesn’t sound like it can make things any worse and may help

Get it here: Drivers & Software

My wife’s machine is on a radeon x1650 and it works ok on a manual install of the driver

I do have to use aticonfig --initial to get it working properly though