I installed VB with yast, when I try to run it, it just hangs & never loads.
I am not sure where to start to trouble shoot this.
Suse 11.1-i586 kde

Which version, the OSE version from the OpenSUSE repositories or the Sun version from

If the OSE version, somebody else will have to guide you, I prefer the Sun version.

If the Sun version, first make sure you have the most up to date, 2.1.4. Even so, it may not contain the right kernel module for your kernel and you need to build it. For make sure you have kernel-source, gcc, make and (I think) pam-devel packages installed, then from the command line as root do:

/etc/init.d/vboxdrv setup

This will do a compile. If the compile fails, look at the log file where it says and fix the problem and try again.

And also make sure that any users wanting to use VB are in group vboxusers. Use YaST user management to add users to that group.

From the repo. I tried from the sun site, but it said it could not install.

Can you help me with that?
subprocess failed. Error: RPM failed: error: Failed dependentcies:pam-develis needed VirtualBox-2.1.4_42893_openSUSS111.i586

Install pam-devel first.

I would remove virtualbox ose via yast and then in yast select the following kernel-source, kernel-syms, xerces c, xalan c, gcc, make, and pam-devel. once that is done go to and down load the rpm for your particular system, it should load and run fine. You may or may not have a problem with usb connections to the virtual machine but it’s easily solvable.

Oh Duh. I did that and it worked- grcias.

Okay everything worked up to the pont where it reads the install CD. It fails there. Can you use a OEM copy of the OS?

What are you trying to install, Windows? It’s ok to use that word here, we won’t tell you off for swearing. :wink:

Most OEM Windows CDs are actually recovery CDs that can only be installed on the original equipment.

Yeah XP pro. Welp there is no way I am buying XP, so Banshee will have to do for managing my music.

Thanks for all the help!

FYI - In kde amarok IMO is way better for music.

As for the OEM? I can’t see why it shouldn’t work.

You could try creating a .iso from the cd and then use the .iso as the media for install.

Just a thought

Running a vm just for a music player may not be the best way anyway

Did you think of trying to install the player you like to use in wine? I know winamp installs and works ok in wine

I’m with caf4926 regarding amarok though, I hardly ever use anything else

It might not be mounting your drive, I’ve had this problem. using the virtual machine unmount and remount the drive. also make sure in the setup that you have the correct drive selected. also check the boot devices and their order, move cd/dvd to head of the list, most likely the virtual machine is going to either the Floppy or hard disk first generating a failure.

How do I get the USB ports to work in Virtualbox?

I have never bothered with usb, but I’m sure you need to use the sun .rpm version rather than the OSE from Build Service.

I would check VirtualBox
And download the Doc’s

If you haven’t already done so I’d recommend you to upgrade to VirtualBox 2.1.4 from SUN, usb handling is much enhanced in that version. Forget all fiddling with fstab, only thing to do is adding filters for your usb-devices in the VB settings section. Only device I had some problems with was a smartcard reader for my Banks Electronic Identity Card, but even that was possible to solve.

You need to install VirtualBox from Sun. The OSE doesn’t have usb support as far as I know.

Once you have the Sun version here’s the howto for usb support.
VirtualBox USB Support - openSUSE

Hey ijbreakey
The TS has already migrated to the SUN binary so all he needs to do is to upgrade to the 2.1.14 version and skip the stuff you lniked to. No need to make any changes to fstab any more, my system runs fine with this line in fstab:

usbfs                /proc/bus/usb        usbfs      noauto                0 0

Thats the default line from the installation.