virtualbox, WinXP, floppy drive, SuSE 12.1

That I don’t think you can do, but you could use an ISO editor (KIso, perhaps, or other - KDE3 had them) to edit the contents - basically add/remove files. I never did this, so I don’t know if the resulting iso could be written back to a real floppy - but it probably could if the size is less than 1.44 MB.

On 2011-12-30 17:36, brunomcl wrote:
>
> That I don’t think you can do,

I don’t see why not. Vmware can.

> but you could use an ISO editor (KIso,

It is not an iso image, it is a floppy image.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

Uwe,
You have demonstrated that the physical floppy drive is working and can be used from the hoost system. Also that the VBox client’s viiirtual floppy drive can mount and access a floppy image file.

I wonder if this is another systemd failure in mounting devices correctly. Please try booting the host openSuSE-12.1 system using the F5 key option to use sysvinit. If that allows the VBox client to use the physical floppy drive, then you can add the kernel parameter init=/sbin/sysvinit to grub (I would do this anyway, because there is a good chance on of the systemd errors will bite you somewhere else).

Hi eng-int,

sorry for reporting this, but booting with sysvinit doesn’t change anything!
The floppy drive behaviour is the same as described earlier in this thread.

Happy New Year,

Uwe.

Yes, of course - dumb me. I’m out of ideas.

I guess the biggest problem (at least in my case) will be to find a non broken floppy in my drawer. Here we go.
Let me do it again:

  • I boot in systemd (but I don’t think it matters)
  • I log in in Gnome (but I don’t see how it would matter)
  • I insert a floppy and don’t mount it
  • I format it with mformat:
mformat A:

no output

  • I read the floppy
mdir A:   

 Volume in drive A has no label
 Volume Serial Number is 04FD-154F
Directory for A:/

No files
                          1 457 664 bytes free

  • I copy a file, let’s say /etc/fstab to this floppy using mcopy:
mcopy /etc/fstab A:
no output

  • I make sure it was copied successfully
mdir A:   
 Volume in drive A has no label
 Volume Serial Number is 04FD-154F
Directory for A:/

fstab             8863 2012-01-01   9:37 
        1 file                8 863 bytes
                          1 448 448 bytes free


  • I check the VirtualBox version
$ vboxmanage -v    
4.1.8r75467

  • Before starting the vm, I attach the physical floppy drive to the XP vm as described previously (in post #4).
  • Now I start this vm and login
  • Here’s the output of
dir A:\

in a Command Prompt:

C:\Document and Settings\agnelo> dir A:\
 Volume in drive A has no label
 Volume Serial Number is 04FD-154F
Directory for A:\

01/01/2012 09:37 AM         8,863 fstab
               1 File<s>   8 863 bytes
               0 Dir<s>    1 448 448 bytes free

As you can see, the output of Linux mdir and Windows dir are the same.
I can do whatever I want with this file under Windows (copy, rename, edit, delete).


C:\Document and Settings\agnelo> copy  A:\fstab .
A:
A:\> rename fstab fstab.old
A:> dir

A:\> dir A:\
 Volume in drive A has no label
 Volume Serial Number is 04FD-154F
Directory for A:\

01/01/2012 09:37 AM         8,863 fstab.old
               1 File<s>   8 863 bytes
               0 Dir<s>    1 448 448 bytes free

  • What else can I say? It’s working.
  • Who could have predicted I would one day list the content of a floppy in a DOS command prompt and post the output here? lol!

Happy new year to all of you guys!

Nostalgia perhaps? Wishing for the good old DOS days again?rotfl!

Thank You,

Hi please_try_again,

to make it short: Using the floppy disk perfectly works with mtools! I can format,read and copy
files to the disk. The version number of VirtualBox is the same as yours! But … saying it with your words:
“What else can I say? It’s NOT working” under VirtualBox!!!

It’s workiing perfectly with vmware (Yes I got it working again, see my other thread “D-Bus error?”).
So, where’s the difference?

Thanks again.

Uwe.

PS: Why using floppy disks? Please don’t laugh! If somebody is claiming that his VM (Virtual MACHINE)
is working, it should work with ALL external devices! If not, then there may be some hidden errors in
accessing some other devices, too.

I don’t know. Your floppy disk controller maybe… although I don’t see how virtualbox would care about that. The VirtualBox extension pack maybe? Although I don’t think it has influence on the floppy (but if it were USB, it would). Maybe try to run VBoxExtensionPack. This script is included in the vmscripts package that you can install from my repo or you can copy/paste the code posted in the development forum, but better install from repo.

http://forums.opensuse.org/english/other-forums/development/programming-scripting/459800-update-virtualbox-4-0-extension-pack.html#post2425351

You can type VBoxExtensionPack any time after updating VirtualBox and it will install the latest Extension Pack - more precisely the Extension Pack that matches the installed version. It is necessary for USB (as some users have reported). I doubt it will solve your problem, but it won’t hurt to have the latest Extension Pack anyway.
If the correct version of the Extension Pack is installed, the script won’t do anything and display this message:

# VBoxExtensionPack 
Extension Pack already installed

Also … I would suggest you try to install another virtual machine in VirtualBox and acces the floppy. With vboxlive - also include in vmscripts - you could easily create and run a diskless Linux vm (of most distros), add a floppy controller later, attach the physical floppy drive and see if you can access it. Maybe your XP system has a problem, not VirtualBox.

  • This thread actually belongs in the virtualization forum (!).

Hi please_try_again

Yes, I should have started this thread in the virtualization forum! May be next time.
I installed VBoxExtensionPack and started it. As you suggested nothing changed. The
problem (light goes on and stays on) directly occurs when I start ANY VM with the
floppy disk enabled in the “VM VirtualBox Manager”, so I think it’s an error with virtualbox
or my SuSE installation.

Thanks again,

Uwe.

Uwe,

As I suggested, try to install another vm in VirtualBox. It will definitely tell you more. If it works in the other vm, your XP inside the vm might be faulty.

Hi please_try_again,

sorry to report this: I tried to install DOS 6.22 from the floppys. I
attached the floppy drive inside the “VM VirtualBox Manager” as you
told me. Starting this VM results in turning on the floppy drive light
and … the floppy drive cannot be read! The light stays on until I close
the VM. So, I guess that’s something wrong (?) with the VirtualBox
programm, and nothing with my Windows XP guest.

Thanks again,

Uwe.

I don’t know why you are sorry. I’m not working for VirtualBox and certainly not for Oracle. :open_mouth:
Well, it’s possible that VirtualBox has a problem. I just cannot confirm this behaviour. So if it’s a bug, it doesn’t affect all systems. Maybe it doesn’t like your floppy controller. However I feel that hard to believe but … there must be an explanation though.

Starting the vm? What’s the boot order in the vm? You should not boot from floppy!

Hi please_try_again,

“You should not boot from floppy!” ??? Why? But let’s stop this thread. Now, that I know
how to get vmware working on my machine and my boss is willing to pay for the 7.1.5 —>
8.0.1 upgrade, I’m done. Let’s wait for some upgrades of VirtualBox and/or the 3.1.x kernels.
May be my special problem is solved then.

Thanks a lot to you all for your help,

Uwe.