Virtualbox vboxdrv error

I just started trying to use Virtualbox on my openSUSE 11.0 KDE machine
to install Windows 7. However, I don’t even get the virtual machine
started, because virtualbox tells me that the VirtualBox kernel driver
is not installed. It tells me to run /etc/init.d/vboxdrv setup in a
terminal as root. So I do that, and I get this:

Code:

linux-8amt:/home/dan # /etc/init.d/vboxdrv setup
Stopping VirtualBox kernel module done
Recompiling VirtualBox kernel module, NOT. It has been packaged. done
Starting VirtualBox kernel module failed
(Kernel module not found)

Any ideas as to what might be going on here?

Thanks,
Dan


dbsoundman

dbsoundman’s Profile: http://forums.opensuse.org/member.php?userid=4224
View this thread: http://forums.opensuse.org/showthread.php?t=406856

dbsoundman wrote:
> I just started trying to use Virtualbox on my openSUSE 11.0 KDE machine
> to install Windows 7. However, I don’t even get the virtual machine
> started, because virtualbox tells me that the VirtualBox kernel driver
> is not installed. It tells me to run /etc/init.d/vboxdrv setup in a
> terminal as root. So I do that, and I get this:
>
>
> Code:
> --------------------
> linux-8amt:/home/dan # /etc/init.d/vboxdrv setup
> Stopping VirtualBox kernel module done
> Recompiling VirtualBox kernel module, NOT. It has been packaged. done
> Starting VirtualBox kernel module failed
> (Kernel module not found)
> --------------------
>
>
> Any ideas as to what might be going on here?
>
> Thanks,
> Dan
>
>

The “/home/dan” suggests to me that you are not running as root. You did
run

su

first?


PeeGee

Asus M2V-MX SE, AMD LE1640, openSuSE 11.0 x86-64/XP Home VBox
Asus M2NPV-VM, AMD 64X2 3800+, openSuSE 10.3 x86-64/XP Home dual boot
Asus eeePC 4G (701), Celeron M353, Mandriva 2009.0

dbsoundman wrote:
> I just started trying to use Virtualbox on my openSUSE 11.0 KDE machine
> to install Windows 7. However, I don’t even get the virtual machine
> started, because virtualbox tells me that the VirtualBox kernel driver
> is not installed. It tells me to run /etc/init.d/vboxdrv setup in a
> terminal as root. So I do that, and I get this:
>
>
> Code:
> --------------------
> linux-8amt:/home/dan # /etc/init.d/vboxdrv setup
> Stopping VirtualBox kernel module done
> Recompiling VirtualBox kernel module, NOT. It has been packaged. done
> Starting VirtualBox kernel module failed
> (Kernel module not found)
> --------------------
>
>
> Any ideas as to what might be going on here?
>
> Thanks,
> Dan
>
>

also, you may need to install some packages (as detailed in earlier
threads on this topic).


PeeGee

Asus M2V-MX SE, AMD LE1640, openSuSE 11.0 x86-64/XP Home VBox
Asus M2NPV-VM, AMD 64X2 3800+, openSuSE 10.3 x86-64/XP Home dual boot
Asus eeePC 4G (701), Celeron M353, Mandriva 2009.0

means it was done as su

Did you install VBox with the Sun rpm or from the repo’s?

Check here for help
‘VirtualBox Installation - openSUSE’
(http://en.opensuse.org/VirtualBox_Installation)

If you used the OSE repo version - did you add this repo
‘Index of /repositories/Virtualization:/VirtualBox/openSUSE_11.0’
(http://tinyurl.com/5zkbdp)
then update it


Box: Linux 2.6.27.12-170.2.5 i686 | Fedora 10 | Gnome 2.24.2 | M2N4-SLI
| AMD 64 X2 5200+ | nVidia 8500GT | 2GB RAM
Lap: openSUSE 11.1 | Celeron 550 | (KDE4.2.0)“83.3” | Intel 965 GM |
Lenovo R61e | 3GB RAM

caf4926’s Profile: http://forums.opensuse.org/member.php?userid=204
View this thread: http://forums.opensuse.org/showthread.php?t=406856

caf4926 wrote:
> # means it was done as su
>

Thanks, I’ll make a note of that (only been (seriously) running for 6
months, so still at the start of the learning curve)


PeeGee

Asus M2V-MX SE, AMD LE1640, openSuSE 11.0 x86-64/XP Home VBox
Asus M2NPV-VM, AMD 64X2 3800+, openSuSE 10.3 x86-64/XP Home dual boot
Asus eeePC 4G (701), Celeron M353, Mandriva 2009.0

dbsoundman schrieb:
> I just started trying to use Virtualbox on my openSUSE 11.0 KDE machine
> to install Windows 7. However, I don’t even get the virtual machine
> started, because virtualbox tells me that the VirtualBox kernel driver
> is not installed. It tells me to run /etc/init.d/vboxdrv setup in a
> terminal as root. So I do that, and I get this:
>
>
> Code:
> --------------------
> linux-8amt:/home/dan # /etc/init.d/vboxdrv setup
> Stopping VirtualBox kernel module done
> Recompiling VirtualBox kernel module, NOT. It has been packaged. done
> Starting VirtualBox kernel module failed
> (Kernel module not found)
> --------------------
>
>
> Any ideas as to what might be going on here?

You have installed the crippled SuSE version of VirtualBox from which
the option of recompiling the kernel module has been deliberately
removed, though the error messages referring to it have not been
adapted accordingly.

In theory, YaST would charge itself with updating that module whenever
necessary. In practice, as you have seen, that doesn’t always work.

You could try manually running an online update, hoping that it will
magically retrieve the correct module for you. You could also take the
easy way out: uninstall the openSUSE RPM for VirtualBox and install
the original RPM from Sun instead which is not so crippled. You’ll
need to install the “Kernel Development” package group, though, in
order to be able to recompile the kernel module.

HTH
T: