Virtualbox: vboxdrv doesn't load on openSuse11.3 (raw_notifier_chain_register)


I have problems to get Virtualbox 3.2.8 under openSuse 11.3 (, x86-64) running. I tried both the VirtualBox-3.2-3.2.8_64453_openSUSE113-1.x86_64 package from Virtualbox and self-compiled drivers as well as the newest RPM packages from openSuse(backports). I mostly get the following error during the vboxdrv load:

269.095562] vboxdrv: Trying to deactivate the NMI watchdog permanently…
269.095562] vboxdrv: Successfully done.
269.095562] vboxdrv: Found 6 processor cores.
269.095763] BUG: unable to handle kernel paging request at ffffffffa026f400
269.095763] IP: <ffffffff81077018>] raw_notifier_chain_register+0x18/0x40
269.095763] PGD 1a06067 PUD 1a0a063 PMD 22bfa2067 PTE 0
269.095763] Oops: 0000 #1] PREEMPT SMP
269.095763] last sysfs file: /sys/devices/system/cpu/cpu5/cache/index2/shared_cpu_map
269.095763] CPU 3
269.095763] Modules linked in: vboxdrv(+) snd_pcm_oss snd_mixer_oss snd_seq af_packet mperf nls_iso8859_1 nls_cp437 vfat fat fuse loop dm_mod snd_hda_codec_atihdmi snd_hda_codec_via firewire_ohci firewire_core crc_itu_t snd_usb_audio snd_hda_intel snd_usb_lib snd_rawmidi snd_seq_device uvcvideo videodev v4l1_compat v4l2_compat_ioctl32 sr_mod snd_hda_codec cdrom k10temp sg asus_atk0110 edac_core edac_mce_amd serio_raw pcspkr sky2 xhci_hcd ohci1394 wmi joydev ieee1394 snd_hwdep i2c_piix4 snd_pcm snd_timer snd soundcore button snd_page_alloc ext4 jbd2 crc16 sd_mod fan processor ata_generic ahci thermal thermal_sys pata_jmicron pata_atiixp libata scsi_mod [last unloaded: preloadtrace]
269.095763] Pid: 11830, comm: modprobe Not tainted #1 Crosshair IV Formula/System Product Name
269.095763] RIP: 0010:<ffffffff81077018>] <ffffffff81077018>] raw_notifier_chain_register+0x18/0x40
269.095763] RSP: 0018:ffff88022a2f1ee0 EFLAGS: 00010286
269.095763] RAX: ffffffffa026f3f0 RBX: ffffffffa056aeb0 RCX: ffff88022a375eb0
269.095763] RDX: 0000000000000000 RSI: ffffffffa056aeb0 RDI: ffffffffa00815d8
269.095763] RBP: ffffffffa0580000 R08: 0000000000000000 R09: ffff880229b52000
269.095763] R10: 0000000000000001 R11: ffff88022d7233e0 R12: 000000000060ffb0
269.095763] R13: 0000000000612c00 R14: 0000000000000000 R15: 0000000000406810
269.095763] FS: 00007f0d75afd700(0000) GS:ffff880001ec0000(0000) knlGS:00000000f5fc0710
269.095763] CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033
269.095763] CR2: ffffffffa026f400 CR3: 000000022db65000 CR4: 00000000000006e0
269.095763] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
269.095763] DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
269.095763] Process modprobe (pid: 11830, threadinfo ffff88022a2f0000, task ffff88022e5be140)
269.095763] Stack:
269.095763] ffffffff8148d228 0000000000000000 ffffffffa03cf3eb 0000000000000000
269.095763] <0> ffffffffa03ccf88 0000000000000000 ffffffffa03cb90e 000000000000f189
269.095763] <0> 0000000000000000 ffffffffa0580000 ffffffffa05800da 0000000000000000
269.095763] Call Trace:
269.095763] <ffffffff8148d228>] register_cpu_notifier+0x18/0x30
269.095763] <ffffffffa03cf3eb>] rtR0MpNotificationNativeInit+0x1b/0x40 [vboxdrv]
269.095763] <ffffffffa03ccf88>] rtR0MpNotificationInit+0x18/0x40 [vboxdrv]
269.095763] <ffffffffa03cb90e>] RTR0Init+0x2e/0x60 [vboxdrv]
269.095766] <ffffffffa05800da>] VBoxDrvLinuxInit+0xda/0x1a6 [vboxdrv]
269.095770] <ffffffff810002e4>] do_one_initcall+0x34/0x1a0
269.095774] <ffffffff8108d69d>] sys_init_module+0xdd/0x260
269.095777] <ffffffff81002ffb>] system_call_fastpath+0x16/0x1b
269.095782] <00007f0d75458eda>] 0x7f0d75458eda
269.095782] Code: 00 48 8b 74 24 08 89 c5 eb d1 90 90 90 90 90 90 90 90 90 48 8b 07 48 85 c0 74 22 8b 56 10 3b 50 10 7e 0d eb 18 66 0f 1f 44 00 00 <39> 50 10 7c 0d 48 8d 78 08 48 8b 40 08 48 85 c0 75 ee 48 89 46
269.095797] RIP <ffffffff81077018>] raw_notifier_chain_register+0x18/0x40
269.095799] RSP <ffff88022a2f1ee0>
269.095800] CR2: ffffffffa026f400
269.095802] — end trace eedf36d30d253bec ]—

However I already tried different combinations of previous kernels and virtualbox versions and the error persists. This is somewhat strange. Sometimes I was able to get proper drivers when reinstalling the whole stuff under failsafe mode a couple of times. But still not cleary reproducable.

So would be good to get any hint where to search for this issue because I don’t think it is a general problem.

Thank you and Best regards,


follow this thread carefully, you will be ok, i had the same error and more and now i have vbox puel edition v3.2.8_x64 running super fast on my suse 11.3_x64 kernel

Virtual Box (Sun Version) Install HowTo

Hi, I don’t see that you encountered the same error. You had the problem to build the drivers, but I have the problem to load the driver. So I don’t get your point. Could you please add some more informations. Does the puel edition mean you run your self-compiled drivers, doesn’t it?

Thanks and Best regards,


Finally the cause of this strange vboxdrv misbehavior has been found. The “Cool’n’Quiet” Bios option was disabled and caused this problem. After enabling it the vboxdrv runs fine. Asus Crosshair IV Formula motherboard is used. There had been recently performance problems with enabled “Cool’n’Quiet” therefore it was switched off. But it seems these problems are solved in the Linux kernel meanwhile.