VirtualBox USB grey

Hello,

I have installed the new VirtualBox 2.2 on my 11.1 system.

The visualization works, but the preselected usb devices are disabled(grey) when I start an OS.

What can I do? I’ve searched, but no answer.

Thanks

http://img378.imageshack.us/img378/5489/bildschirmfoto1.png
http://img378.imageshack.us/img378/5457/bildschirmfoto2.png

Those Pics are not much use, post the BB code which should give us a thumb to click and bring up the original.

Hi,
Same as @caf4926 (Pictures too small to read).

What version if any (e.g. 2.1.4) did you have before? Did you upgrade or do clean install of virtualbox? If you upgraded, was usb working on previous release?

Your search failed, but there are some very recent threads and older ones in this forum about usb problems. Try searching on “virtualbox” alone.

Different solutions have worked in various situations. More information about yours and what you tried before failure may help us find the right one for your system;).

Sorry,

the pictures only say that I’ve selected USB devices and then I can’t select them in running mode.

No, I installed it clear without any upgrade. I’s the version from the virtualbox.org site. Not the OSE without usb support.

Ok, I don’t need the pictures. I would like you to try starting VirtualBox from Konsole as root (su and respond with root password). Then do your thing with usb, and test it through to guest os.

Post back here with the result either way. Thanks…

I tested it.

I’t works, I can select the usb devices, but the guest OS doasn’t work and my OS doasn’t work. My mouse an keyboard is still caught into the guest OS.

You should be able to uncapture the mouse and keyboard by pressing the control key to the right of your keyboard (referred to as the host key in virtualbox).

So it works if you start as root, but we need to get it working for your normal user, but first please confirm success or not with uncapturing the mouse etc.

No, I cannot capturer the mouse. If I press any key, nothing works. I’t looks like the keyboard and mouse do nothing.

Everytime I test this, I must restart.

Ok, but restart as** normal user** and make sure the guest works well, before trying to get usb working. If you haven’t read the FAQ and familiarized yourself with the excellent user manual available from the virtualbox site, I recommend you do that now.

I don’t know which guest OS you have, but did you see the usb device mounted in the guest? What type of usb device is it? What guest OS?

No, if I use normal user than the OS and guest OS works, but no USB.
If I use root from console, than my OS crashes and the guest OS doasn’t start. But I can select for 1-2sec all my usb devices.

My guest OS is win vista and my usb devices are: usb sticks, usb hard drives an usb headset.

Thanks for the info. One of the usb devices (or more) may be causing the crash. To reduce complexity for testing (as root for now), I suggest you use just one device only in the vm, i.e. memory stick (mine works well) i.e. the uncomplicated one that you know works all the time on the host. Can you unplug the other devices? Delete the usb filters in virtualbox settings - they are easy to add again later.

My device works this way: exit virtualbox; plug in the device it should mount on the host; start virtualbox, but not the guest; go to usb settings and click on the little + button once (Add Filter fom Device), but don’t click the small white box yet in the popup, just hover the mouse over small white box and it will display the State of the device as “Busy” (if State=Unavailable, don’t bother starting the vm - it will not work); click on the small box to add the filter; start the vm and check it mounts ok.

Tell us what happened…

Okay, I’ve selected only my usb stick.
It works, and it runs.
But only out of the terminal with: su -> VirtualBox
How can I use now with the normal user the usb feature?

That’s good;). Now we know more about the problem as others reported. We could try modifying fstab with various alternative statements, but it’s hit & miss, and time consuming, as they were for different versions of openSUSE. VirtualBox with usb is supposed to just work with release 2.1.4 onwards. Your situation coming from clean install matches what is ongoing in the last stages of this long thread I am involved in. The last proposed solution is being tested. You can go for that or try this one in the meantime, after closing down VirtualBox:

Look in the directory /etc/udev/rules.d/ for the file 10-vboxdrv.rules

If it’s the only file of type xx-vboxdrv.rules, then execute the following command from Konsole (as root) in /etc/udev/rules.d/

mv 10-vboxdrv.rules 60-vboxdrv.rules

Then reboot and test again but as normal user and just the memory stick.

Post back with result or question…

It works gerat.
The speed from usb to virtualOS is realy slow.
But it works, maybe I set up an ftp oder other server to speed up that.

Thankyou for solving my problem :slight_smile:

You’re welcome, and I hope you manage to sort out the rest of your devices:). If you succeed or not, perhaps you could post back here with the results as it could help others following this thread.

If you chose to do the file name change, at some time you could change the name back and try modifying the rules file as detailed toward the end of that thread link in my previous post. The author of the fix, hank_se, is claiming that it would be better.

Finally,

Have a read of this thread, it may give a clue but I haven’t had time to read it properly, so sorry if it doesn’t.

Best of luck.

consused wrote:

>
<snip> That’s good;). Now we know more about the problem as others
reported. We > could try modifying fstab with various alternative
statements, but it’s> hit & miss, and time consuming, as they were for
different versions of
</snip>
<snip>

> Code:
> --------------------
> mv 10-vboxdrv.rules 60-vboxdrv.rules
> --------------------
>
> Then reboot and test again but as normal user and just the memory
> stick.
>
> Post back with result or question…
>
</snip>

OpenSUSE11.1, Vbox 2.1.4 from Sun website.

I have a simular problem. My usb devices show up under settings, but are
greyed out when I start vbox. everything works fine if I manually mount
usbfs before starting vbox. I read the posts and forum on the rules files
but I’m a little confused as to the correct rule. I have both a 10- and 60-
entry in /etc/udev/rules.d. Should I just move the 10- rule to 60-??

/etc/udev/rules.d> less 10-vboxdrv.rules

KERNEL==“vboxdrv”, NAME=“vboxdrv”, OWNER=“root”, GROUP=“root”,
MODE=“0600”
SUBSYSTEM==“usb_device”, GROUP=“vboxusers”, MODE=“0664”
SUBSYSTEM==“usb”, ENV{DEVTYPE}==“usb_device”,
GROUP=“vboxusers”, MODE=“0664”

/etc/udev/rules.d> less 60-vboxdrv.rules
KERNEL==“vboxdrv”, NAME=“vboxdrv”, OWNER=“root”, GROUP=“root”,
MODE=“0600”

Thanks for any help.


Russ
openSUSE 11.1 (2.6.27.21-0.1-default x86_64) KDE 4.2 release 106, Intel
DX48BT2 Core 2 Dual E7200. 4 GB DDR III GeForce 8400 GS, 320GB Disc
(2)

@upscope
Your situation is a little different from the others I have seen, so I would like to clarify some points before answering your question.

The fact you have those 2 files, including 60-vboxdrv.rules, indicates you had a previous version of VirtualBox installed before 2.1.4, so what version was that? How did you make the change, clean install or upgrade using Yast local repo? Did you add any usbfs lines to your fstab?

Thanks…

consused wrote:

>
> @upscope
> Your situation is a little different from the others I have seen, so I
> would like to clarify some points before answering your question.
>
> The fact you have those 2 files, including 60-vboxdrv.rules, indicates
> you had a previous version of VirtualBox installed before 2.1.4, so what
> version was that? How did you make the change, clean install or upgrade
> using Yast local repo? Did you add any usbfs lines to your fstab?

Not sure which version, it was the one that proceeded 2.1.4. All were
openSUSE RPMS downloaded from the SUN website.

Present version:
VirtualBox-2.1.4_42893_openSUSE111-1.x86_64.rpm

Last version:
VirtualBox-2.1.0_41146_openSUSE111-1.x86_64.rpm

All were downloaded from to a temporary directory and then installed with
YaST software management. So I guess you would say I upgraded.

Yes there was a mod mad to FSTAB. It was actually made when I first
started using Vbox per and item on a forum. Otherwise USB would not work.

usbfs /proc/bus/usb usbfs
auto,busgid=1000,busmode=0775,devgid=1000,devmode=0664

If you need any other information please feel free to send email direct to:
Russbucket@nwi.net or thru the mail list.

Russ
openSUSE 11.1 (2.6.27.21-0.1-default x86_64) KDE 4.2.1 release 106, Intel
DX48BT2 Core 2 Dual E7200. 4 GB DDR III GeForce 8400 GS, 320GB Disc
(2)

@upscope
You should not post your email address in the forum.

Thanks for all the info, although not quoted by me here.

The previous version was 2.1.2, but you susbsequently said you upgraded from 2.1.0 to 2.1.4 (my interpretation anyway). However, you didn’t say that you added the temporary directory as a repo to Yast, so I assume you didn’t.

That (i.e. 2.1.0) may explain the rather shorter 60-vboxdrv.rules in your previous post, that would have been left over from your previous install. That file is not deleted by 2.1.4 which was responsible for placing 10-vboxdrv.rules in etc/udev/rules.d/ (also placed there on a clean install).

Unlike the OP, you upgraded from a previous usb-working system, and my understanding is that after the upgrade, it only works if you manually mount usbfs. As you already have a working fstab entry, why not try this first:

  1. Remove 60-vboxdrv.rules to your home directory (in case you need to put it back). Place the command mount -a in the file etc/init.d/boot.local and restart your system. Start VirtualBox and test usb.

If that doesn’t work, try solution 2. or 3. below, and comment-out your fstab mod and the mount -a to test these:

With 11.1 and VirtualBox 2.1.4, fstab modification doesn’t always work, and 2.1.4 is supposed to work without it. There are now two solutions authored by @hank_se, assuming just the file 10-vboxdrv.rules is present as installed by VirtualBox. @hank_se prefers 3. I believe they work, but need more testing to make sure they consistently deliver the same result to the guest os.

  1. Execute the command mv 10-vboxdrv.rules 60-vboxdrv.rules (as root), then restart your system and test. This is effectively a rename to reposition (priority wise) the rules file.

or,

  1. Edit 10-vboxdrv.rules to add NAME=“vbusb” as in the last line
SUBSYSTEM=="usb", NAME="vbusb", ENV{DEVTYPE}=="usb_device", GROUP="vboxusers", MODE="0664"

then restart your system and test.

I hope that helps you decide. As usual we would like you to post back with the result;).