Virtualbox Re-install Required


I have an issue with VirtualBox on my openSUSE 11.2 64-bit system.

I have Windows 7 installed as a guest, and it all works fine…until I reboot the PC. When I try to restart VB, I get the bouncing icon, then nothing. I need to uninstall / reinstall VB, then it works fine until the next reboot.

I’ve tried on the VB site, but the problem seems unique (i.e. they haven’t encountered it), so I am wondering whether it is a distro/kernel issue?

I have VB working fine on another laptop without any issues.

Has anyone experienced this issue, or have a solution?

This sounds like a silly question, but how often do you reboot? If it’s only rarely, there HAVE been several kernel updates in the past couple of months. Maybe it’s just coincidence that you need to reboot, and an update has occurred in the interim! :slight_smile:

What version of VirtualBox are you running? What errors are you getting? What do the logs show? If you start a root terminal prompt and enter, “service vboxdrv restart” what does it show? What happens when you enter “service vboxdrv setup”?

One of the moderators has written a couple of good How-Tos for this. In case you haven’t seen them:

Virtual Box (Sun Version) Install HowTo - openSUSE Forums

Using Virtual Box - Some Quick Tips - openSUSE Forums

Just a thought
Rather hit the Launcher Icon, did you try from a terminal: VirtualBox

I’m running the latest version of VirtualBox (not at home right now, so can’t confirm the version number).

I’ve since reverted to using openSUSE 11.1 - the network manager in 11.2 kept dropping the wireless internet connection at irregular intervals, requiring a reboot, exacerbating the VB problem. 11.1 on my office laptop works without issue (VB, network and so on), so I’ll finish configuring 11.1 and see whether that helps.

No it hasn’t. 11.1 still requires a reinstall of VB after rebooting the PC. Leaving it on permanently isn’t really feasible.

I’ll check the other info and post the results.

No luck. I get the normal kernel rebuild messages (deleting old…done / recompiling…done) without error, but still no start. Going in as root gives me a different profile, although it starts…

Could it be my profile with the existing machine i.e. should I delete the profile and then add the disks…I’ll give that a go and report back.

Well, I’ve just installed the latest version of VirtualBox (3.1.4) and, instead of letting it find the existing configuration, I created a new machine and used the hard disc I had. I’ve just re-booted and it seems to be going well.

Now all I need is to sort out the USB…