Virtualbox permissions keep reseting?

Every time I reboot the permissions for the Virtualbox executable go back to NOT being effective root UID. What I mean to say is…in order to run it as a normal user I have to chmod it every time i start up like

chmod 4711 Virtualbox

I don’t guess this is really a big deal…I was just wondering if anyone knew how to fix it?


Are you created the usergroup vboxusers? Is your user in this group?
It’s described here: VirtualBox Installation - openSUSE.
Good luck.

umm. well. it wasnt added to the group, which i didnt check because I didnt think it would work at all.

Not sure if that fixed it or not…ill keep you posted.

thanks for the help


LOL that fixed it! :slight_smile:

ok so…that wasn’t “THE” problem…

any other ideas?


I have some problems with permitions too
but what file you change permitions?




mine permissions is looking

~> sudo ls -l /usr/lib/virtualbox/VirtualBox
-rwsr-x--- 1 root vboxusers 22274 Дек 10 15:48 /usr/lib/virtualbox/VirtualBox

> sudo ls -l /usr/bin/VirtualBox
-rwxr-xr-x 1 root root 89 Дек 10 15:48 /usr/bin/VirtualBox

Are you a member of the vboxusers group as suggested to me? What if any error messages are you getting?

It looks like its not group executable (if i remember how to read the permissions…which i wouldn’t bet on)
try this:

chmod 4711 /usr/lib/virtualbox/VirtualBox


Mine are:

$ ls -lL /usr/bin/VirtualBox /usr/lib/virtualbox/VirtualBox
-rwxr-xr-x 1 root root 2384 2008-11-22 09:06 /usr/bin/VirtualBox
-r-s–x–x 1 root root 23776 2008-11-22 09:07 /usr/lib/virtualbox/VirtualBox

The shell script should not be setuid but the binary it calls in /usr/lib/virtualbox/VirtualBox should be setuid root.

I did not suggest you anything… I have no idea how this can be fixed…
but when i run
>sudo chmod 4711 /usr/lib/virtual/VirtualBox

as you suggest VirtualBox is starting fine :slight_smile: for me

so i will try restart and look at permissians

i check one more

~> sudo ls -l /usr/lib/virtualbox/VirtualBox
-rws--x--x 1 root vboxusers 22274 Дек 10 15:48 /usr/lib/virtualbox/VirtualBox

oops it very strange… permissions not changed but VirtualBox is start… very strange now i try to reboot

Also IIRC it was in version 2.0 that the binary became setuid. In version 1.x it was not setuid. If you are running 1.x, then it does not have to be setuid and you are chasing a red herring. If you have problems starting a VM without the setuid, then it’s because of other reasons, like not being in group vboxusers or not having permissions on the VM files.

I am reboot
and have VirtualBox runs just fine :slight_smile: thank god :slight_smile:

thank you ken_yap for clearing this :slight_smile:
+1 in reputation

before survey i did not know about exist of such thing here…