virtualbox on 11.1 - no luck

I have spent the last hour or so trying to get virtualbox working. I also had a go at getting the virtualisation software that is embedded in YAST working, but had no idea what was going on with that one.

Anyway, virtualbox - had a look at this post Virtualbox doesn’t work at all - openSUSE Forums

None of the suggestions worked. I just get the bouncing cursor, then nada.
N.B. nothing happens if I enter virtualbox at the bash shell.

Does anyone know how to get it working on 11.1?

Cheers

Yes, for me works without any problem.

If you type virtualbox OFC nothing happens, the executable is called VirtualBox :wink: BTW do not try to start it, it think you have no permissions.
So, go to YaST -> Security and User -> User and Group Management. In the users tab select your user, and hit the Edit key. In the next window switch do Details tab and in the Additional Groups check the vboxusers.
Reboot.
Good luck.

Thanks for that. I followed those instructions. Now, VirtualBox is at least responding. I am getting the following error:

http://i218.photobucket.com/albums/cc303/onefootswill/vbError.png

Not sure what that means.

Are you installed VirtualBox from this repository:
Index of /repositories/Virtualization:/VirtualBox?

Yes. I used the following url for my repository - Index of /repositories/Virtualization:/VirtualBox/openSUSE_11.1

Okay, then check the listed dependencies:
VirtualBox Installation - openSUSE and ensure that in YaST -> System -> System Services
the vboxdrv abd vboxnet modules are enabled - highlight them and hit Enable. Reboot.

Yes. Those services are all running.
The Xml transformation apps are installed.

I still get the same error.

Ok, then it should be work, but…
Google for this: Failed to create virtualbox com object.

Thanks for trying ram88.

I have re-installed VirtualBox to no avail.

Don’t understand why it won’t work. Baffled.

What says


su
/etc/init.d/vboxdrv setup

?

Hi.
I’m not an expert on VB but I had the same problem as you.

The way I fixed it was:
Uninstall any previous VBox installation
Install Kernel sources and kernel-syms and re-install the package from Sun’s site’as superuser (root)…
Register yourself as a vboxuser in Yast > users and groups.
After this, you must modify your /ect/fstab an another file to have USB access, which I don’t remember, but you caan search the correct info in this forum.
Good luck

Luis

Thanks Luis, I shall have a go at that if I have no luck with ram88’s line of enquiry.

ram88, the output of that command is:

linux-oi2t:~ # /etc/init.d/vboxdrv setup
Stopping VirtualBox kernel module done
Recompiling VirtualBox kernel module, NOT. It has been packaged. done
Starting VirtualBox kernel module done
linux-oi2t:~ #

Yeah go with the Sun package instead of the one from the repo like Luis suggested.

OK. I attempted to install the Sun package with no luck. Here is the error message:

linux-oi2t:/home/dave/Desktop # rpm -i VirtualBox-2.1.0_41146_openSUSE111-1.i586.rpm

Creating group ‘vboxusers’. VM users must be member of that group!

No precompiled module for this kernel found – trying to build one. Messages
emitted during module compilation will be logged to /var/log/vbox-install.log.

Compilation of the kernel module FAILED! VirtualBox will not start until this
problem is fixed. Please consult /var/log/vbox-install.log to find out why the
kernel module does not compile. Most probably the kernel sources are not found.
Install them and execute

/etc/init.d/vboxdrv setup

as root.
I thought the kernal sources were installed. Here is a screenshot to display what is installed:

http://i218.photobucket.com/albums/cc303/onefootswill/kernalSrc.png

What have I done wrong?

Why not follow the big hint instead of guessing?

Please consult /var/log/vbox-install.log to find out why the kernel module does not compile.

By the way, those aren’t kernel sources checked off in that picture. They’re the kernel MODULES for VirtualBox. That’s very different. If you want kernel sources then you need a file that’s actually called Kernel-Source.

kernel-source-2.6.27-7.2.i586.rpm for example… :wink:

virtualbox from the official repository works fine for me on 11.1.

You need a few things before it works:

  1. Install VirtualBox
  2. Install VirtualBox Kernel Module
  3. Add yourself to the vboxusers group

Then Re-Boot. The modules need to be loaded by the kernel and the services need to be started before it will work.

Hi necrolin.

I had already tried that. For one reason or another, installing by way of YAST did not work. And I had added myself to the vboxusers group.

Thanks also for pointing out that those items were not kernel sources. I’m not quite sure how to get the kernel sources that Luis referred to in his post above.

Yast=>Manage Software=> search term: kernal-source

I recommend installing some of the other programs used to build, although they should install as depends.

Do you have gcc installed?