virtualbox not working


Virtualbox won’t work with the newest kernel 4.13.12-1
Can not /sbin/vboxconfig the kernel.
Back to kernel 4.13.11-1, all is fine.

Gerrit Jan

some info

Het is niet gelukt een sessie te openen voor virtuele machine Kubuntu.
The virtual machine 'Kubuntu' has terminated unexpectedly during startup with exit code 1 (0x1).
Resultaatcode:NS_ERROR_FAILURE (0x80004005)
Interface:IMachine {b2547866-a0a1-4391-8b86-6952d82efaa0}
=== Building 'vboxdrv' module ===
make[1]: Entering directory '/usr/src/kernel-modules/virtualbox/src/vboxdrv'
make KBUILD_VERBOSE= SUBDIRS=/usr/src/kernel-modules/virtualbox/src/vboxdrv SRCROOT=/usr/src/kernel-modules/virtualbox/src/vboxdrv CONFIG_MODULE_SIG= -C /lib/modules/4.13.12-1-default/build -j4 modules
make[2]: Entering directory '/usr/src/linux-4.13.12-1-obj/x86_64/default'
/usr/src/linux-4.13.12-1/Makefile:942: *** "Cannot generate ORC metadata for CONFIG_ORC_UNWINDER=y, please install libelf-dev, libelf-devel or elfutils-libelf-devel".  Stop.
make[3]: *** [Makefile:145: sub-make] Error 2
make[2]: *** [Makefile:24: __sub-make] Error 2
make[2]: Leaving directory '/usr/src/linux-4.13.12-1-obj/x86_64/default'
make[1]: *** [Makefile:305: vboxdrv] Error 2
make[1]: Leaving directory '/usr/src/kernel-modules/virtualbox/src/vboxdrv'
make: *** [Makefile:41: all] Error 2

And solved : this is the problem after the last Tumbleweed update: please install libelf-dev, libelf-devel or elfutils-libelf-devel

Thank you Jan! It solved the problem for me too.
BTW, I had to install the virtualbox-host-source package too.


Aha! Thanks for this – that was the critical bit of information I just needed. :¬)