virtualbox not opening


when i click on virtualbox it won’t start.

i tried in terminal with executing virtualbox with normal user and i got this:

Qt FATAL: FATAL: The application binary appears to be running setuid, this is a security hole.
[1]    22709 abort      virtualbox

again i ran it with sudo and i got this:

Qt WARNING: QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
Qt WARNING: QXcbConnection: Could not connect to display 
Qt CRITICAL: Could not connect to any X display.

note that i had changed Xorg config to run rootless and i want to keep this config, i mean this:

sudo touch /etc/X11/Xwrapper.config
sudo echo "needs_root_rights = no" >> /etc/X11/Xwrapper.config

also i have needed modules like vboxdrv running
thanks in advance

Whenever anyone posts about Virtualbox,
You have to state whether you installed virtualbox from the openSUSE repos or downloaded the install from the Oracle website.
In fact, if you installed from Oracle, you may want to try the openSUSE supplied version first… remove/uninstall the existing install before using YaST Software Manager or the zypper tool, eg

zypper install virtualbox


Just in case something here is relevant (with respect to your user-initiated xorg environment)…