VirtualBox network setup


I installed VirtualBox and realized that I need “direct” access to my network in order to be able to connect to my company’s vpn.
I only got NAT to work with VirtualBox.
How do I need to setup my virtual machine’s network settings in order to get a direct IP address from my router? Do I need a bridge? How can I configure such?

Thanks for any help!

Maybe this will help. It’s for openSUSE 10.3 though.

There’s a chapter in the Virtualbox user manual that talks about Virtualbox networking and in particular bridging which has to be used instead of NAT if your VPN uses any non-TCP or -UDP protocols. Bridging’s only possible on Windows and Linux/Unix hosts at the moment. The PDF of the manual is at

For NAT limitations the manual says:
Protocols such as GRE are unsupported: Protocols other than TCP and UDP are
not supported. This means some VPN products (e.g. PPTP from Microsoft) cannot
be used. There are other VPN products which use simply TCP and UDP.

And the VPN i have works via PPTP :frowning:

Well, I’ve figured out how to make a bridge and i have following now:

br0 Link encap:Ethernet HWaddr 00:1C:25:03:B0:F3
inet addr: Bcast: Mask:
RX packets:1423239 errors:0 dropped:0 overruns:0 frame:0
TX packets:860600 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:781309039 (745.1 Mb) TX bytes:121571860 (115.9 Mb)

eth0 Link encap:Ethernet HWaddr 00:1C:25:03:B0:F3
inet6 addr: fe80::21c:25ff:fe03:b0f3/64 Scope:Link
RX packets:45508855 errors:0 dropped:0 overruns:0 frame:0
TX packets:25196944 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:4042533163 (3855.2 Mb) TX bytes:2623107733 (2501.5 Mb)

which ever (eth0 or br0) i set as “internal network” adapter - the virtual system i’m running (winXP) can’t get an IP address.

Okay, I got quite a bit further but it’s still not working :frowning:
I know I need to take “Host interface” and i can forget about the bridge i created - but VirtualBox will connect using TAP.
But now I tried to assign the tap to my user with:

linux-c73s:/home/reg # sudo tunctl -t tap0 -u reg
Set 'tap0' persistent and owned by uid 1000
linux-c73s:/home/reg # sudo tunctl -t tap1 -u reg
Set 'tap1' persistent and owned by uid 1000

because I get the error “VERR_HOSTIF_INIT_FAILED” when i try to start my virtual machine with “host interface” networking - may anyone still help me? I’m getting stuck here :frowning: What do i gotta do? :frowning:

I’ve now also tried making use of my bridge and setup a permanent host networking interface using “VBoxAddIF vbox0 reg br0” but this didn’t work either, my guest OS isn’t able to get an IP…

Hmm… :frowning: I feel as if I’ve tried it all but… :frowning:

Not trying to discourage you from posting here, but have you tried posting in the Virtualbox forums? There should be a much larger number of people there who are familiar with the sort of sertup you want to create. Myself, I’m just starting out and finding it interesting.

Sure, will try that, thanks for the hint anyways :wink: