Virtualbox - Leap 42.3 hosts - vboxsf: Unknown symbol VBoxGuestIDC (err 0)

Cannot install Guest Additions on linux guest.

First remark : Using any version of windows as guest on Leap 42.3 on any version of virtualbox ( oracle or opensuse ) works correctly.
I first install Leap 42.3 as guest on virtualbox ( oracle version ) and I could not access the shared folder but I did not write back any error messages.
I tried different things that did not work.

So I decide to redo every things and noted what happens.
From my point of view the problem is : vboxsf: Unknown symbol VBoxGuestIDC (err 0)

Here the test with virtualbox-5.2.8-389.1.x86_64 from opensuse virtualization :
see :

Here the test with virtualbox-5.1.34-47.1 from opensuse standard repos :
see :
and cited image 1 :
and cited image 2 :

Here the test with virtualbox-5.1.34-47.1 from oracle :
see :

Any help is welcome

The host-kmp should only installed in the host.
The guest-kmp should only be installed in the Guest.

guest-kmp was never installed.

Ok I will re-read this chapter about the guest additions.

But before I try to install guest addition ( in the very beginning of this story some weeks ago, or today when I tried again ) I got the same error :

Message in popup window :
VBoxClient: VBoxClient (seamless): failed to start. Stage: Setting guest IRQ

And then ?

Any help is welcome.

What I try to explain :

up to now :

A1-) install virtualbox
A2-) install a guest
A3-) restart the guest
A4-) install the guest addition.


B1-) install virtualbox
B2-) install a guest
B3-) restart the guest
Got error

VBoxClient: VBoxClient (seamless): failed to start. Stage: Setting guest IRQ

Folowing Installing the Linux Guest AdditionsThe VirtualBox Guest Additions for Linux are provided on the same virtual CD-ROM file as the Guest Additions for Windows described above. They also come with an installation program guiding you through the setup process, although, due to the significant differences between Linux distributions, installation may be slightly more complex.
Installation generally involves the following steps:

  1. Before installing the Guest Additions, you will have to prepare your guest system for building external kernel modules. This works similarly as described in Section 2.3.2, “The VirtualBox driver modules”, except that this step must now be performed in your Linux guest
    instead of on a Linux host system, as described there.> If you suspect that something has gone wrong, check that your guest is set up correctly and try executing the command
    rcvboxadd setup as root.
sudo rcvboxadd setup
VirtualBox Guest Additions: Building the VirtualBox Guest Additions kernel modules.
VirtualBox Guest Additions: Running kernel modules will not be replaced until the system is restarted
VirtualBox Guest Additions: Starting.
**VirtualBox Guest Additions: modprobe vboxsf failed**
You may need to restart the Window System (or just restart the guest system)
to enable the Guest Additions.

In any try I made vboxsf always failed.

Yes I’ve also found that the Guest Additions automatically installed by openSUSE do not usually support Shared Folders, so I’ve also installed the Oracle VBox additions for that functionality. I haven’t noticed anything else that the openSUSE Guest Additions are deficient.

Before you can install Oracle Guest Additions in an openSUSE Guest, you have to first remove the openSUSE version, which especially means removing related kernel modules. As you’ll see, don’t trust anything to happen automatically, you should be certain by removing manually.

The following is my SOP for installing Oracle Guest Additions in an openSUSE Guest.
If you’re installing in any other Guest, with minor modification (primarily removing an already installed Guest Additions is likely unnecessary), the same procedure should work.
If upgrading an old Guest Additions which won’t upgrade automatically, then these steps should work for that scenario, too.


  1. Remove the openSUSE Guest Additions.
    I don’t usually remember what I do in every install, I’ve always worked from scratch each time. Without actually creating a new Guest, this is what I think I’ve been removing (If the following is inaccurate, I’ll run through the whole procedure and document properly and post an update to this thread)
zypper rm virtualbox-guest-kmp-default virtualbox-guest-tools virtualbox-guest-x11
  1. Install the Oracle Guest Additions prerequisites. .
    Install the prerequisites for building kernel modules. The following assumes you’re running the “Default Kernel” which is… what is default today unless you’ve installed a different kernel.
zypper in gcc make kernel-devel kernel-default-devel
  1. Mount the Guest Additions ISO
    If anything is already mounted in your Guest Virtual CDROM, then remove/unload. This is a “must”
    If your Virtual CDROM is pointing to your physical CDROM, this shouldn’t be necessary.
    In your Guest graphic console,
    Devices > Insert Guest Additions CD Image…

  2. The following should execute the Oracle Guest Additions install where “user” is your account Username and is for VBox 5.2.8 (you may need to modify if your VBox is a different version)

# /run/media/user/VBox_GAs_5.2.8/

When complete,
**Now **you can reboot your Guest.


In any try I made vboxsf always failed.

Post as root:

modprobe vboxsf


zypper se -si virtualbox kernel

Thank you for helping.
But if you read my three attempts to run a guest fully configured as explain in post #1

Here the test with virtualbox-5.2.8-389.1.x86_64 from opensuse virtualization :
see :

Here the test with virtualbox-5.1.34-47.1 from opensuse standard repos :
see :
and cited image 1 :
and cited image 2 :

Here the test with virtualbox-5.1.34-47.1 from oracle :
see :

For the test (A) I started from scratch.
And I got an error before installing the guest addition as I said :

Install the VM with minimal softawre addon ( kate, nmap, …)
Do zypper up
Install some more software ( c/c++ , linux kernel dev, … )
Start VM Leap 42.3 :

Message in popup window :
VBoxClient: VBoxClient (seamless): failed to start. Stage: Setting guest IRQ

Install VBoxGuestAdditions
Cannot mount shared folders

For the rest I agree with you, but that do not solve my problem.

From what you posted,
I strongly suspect that the kernel module for vboxsf was not successful.

That is why I posted the absolute required steps I use when I replace openSUSE Guest Additions with Oracle Guest Additions, if you stray from what I posted, your result will be a failure.

To verify…
I strongly recommend you re-install Guest Additions as I describe,
And** look carefully at your Guest Additions install stdout.**
If you’re not running your install in an xterm console, you can scroll through and review your entire stdout until you close that console window.
You <must> see successes at every step of the way, a kernel module build failure will be reported as non-critical and the install will continue but such failures are essential to understanding that feature won’t work later.

I’ve found that the most common reason for a kernel module build failure is not properly removing the <entire> openSUSE Guest Additions first.

If you want an extra measure of certainty (although probably not itself a complete indication), you can reboot and see if things like full screen auto-expansion works (it shouldn’t. Without Guest Additions, it should remain the original resolution).


Minor Update:
Decided to inspect a number of my LEAP VBox Guests,
Although almost all launched and updated without any problems,

One is displaying the same error described in this thread.
At the moment, I’m not sure what makes this Guest different than the others…

But at least I’m going to be able to take a closer look at this problem.

Oracle Guest Additions were installed withut any reported error, so that’s not a solution (yet).
One of the things I’m going to do of course is remove and clean out the existing installed Guest Additions as much as is practically possible and re-installing.

Might not have any answers in the near term…

Current Guest Additions is 5.2.8.
This particular Guest is upgrading from 5.2.6.


That was quick.

I determined that somehow the openSUSE virtualbox packages were installed in this 42.3 Guest.

As I described in my previous post,

Manually removed the openSUSE virtualbox packages.
Installed the Oracle Guest Additions.
No error displayed on boot.
Checked Guest Additions functionality, both auto-fill Full Screen and configured Shared Folders.

Both work.
**Problem solved **(at least in my case, should for anyone else as well).


You got it.
On the guest VMFor a reason I cannot explain (I only click on choose-box in yast2), the version of virtualbox-guest-kmp-default was for kernel 104 (5.1.32.k4.4.104_39-42.1) and the VM run kernel 120 (4.4.120-45-default).
Running zypper up, update the 3 package to 5.1.34 and particularly virtualbox-guest-kmp-default was update to (5.1.34.k4.4.120_45-47.1)

Thread is closed.

Many thanks to Sauerland and Tsu2