Virtualbox is down for the count

Live upgrade of opensuse 15.0 to 15.1 and virtualbox can’t define any new vdi’s for linux installs.
In virtualbox 5.??? on 15.0 I had win xp, win 7, linux 11.2, linux 11.3 and 13.1 all working properly with extension pack and guest additions on each. Did the upgrade to Leap 15.1 and amongst a whole list of new problems is a broken virtualbox. Virtualbox 6.0.12 was the new upgrade for the Leap new version and it is useless.

Windows xp runs perfect
Windws 7 runs perfect
Linux 11.2 and 13.1 run kinda ok some complains that it can’t reach shared drives but it’s been so long I may have changed things since I last ran them.

So I need to install Raspberry Pi emulator and I created the vdi for it attached the iso to cdrom and chose install from the screen as normal. It has extension pack already and it should have worked but upon installation finish it reboots and crashes with a system halt message.

Going to internet oricle says virtualbox can’t run linux without guest additions being installed first. Cute. You can’t install guest additions until you have installed the os and have it up and running. So I download guest additions for virtualbox 6.0.12Beta and attach it to the cdrom. start the system again and try to stop booting until I have added the guest additions and it can’t find the cdrom (it shows in the list) but install from cd fails and offers to download them. Ok I choose download and install and it gets to 99% and stops saying download failed do you want to install from cdrom. Choose yes and it says no cdrom could be found … downloading from virtualbox site and repeats ending again with failed. Then it finishes boot of os with error system halted.

Didn’t anybody check that virtualbox new edition actually worked??

I did notice that all my other virtual guest had guest additions for the virtualbox that was running at the time the OS was installed. So each guest is running a different guest additions matched to virtualbox that was used to create the guest drive.

Is there a work around or do I have to abandon virtualbox because it no longer works.

First step to solving your problems is to collect information…
What version of Virtualbox is currently installed? Don’t guess.
Don’t worry about your Guest Additions at least for the moment… If you have a version mis-match, AFAIK your Guests should still boot up but will be lacking in features. In fact, if Guest Additions were your only problem, you should at least see the Guest boot as far as Plymouth (past the Grub menu and prior to where you might login if you didn’t have Auto login enabled)

It’s also important to know if your original Virtualbox from before you upgraded was installed from an openSUSE repository or if you installed from a download from the Oracle website.

Whatever your situation,
There is a solution.
Ideally, if your current Virtualbox can be fixed easily, then that’ll be done.
Else, or if you choose to do so, it wouldn’t be difficult to remove your existing Virtualbox and install whatever version you prefer from scratch… Although only VBox 6 is available from openSUSE, both VBox 5.7 and 6 should be available if installed from Oracle downloads. Your Guests should work with any of these choices without a problem. And, wherever you read that Guest Additions have to be installed before you can boot your VM, you’re probably misunderstanding what was said, so don’t worry about that.

Although I don’t think anything should be at risk, of course this is a good time to remind that anything important should be backed up, or at least copied somewhere off the machine for safe storage if anything disastrous should happen.


windows guest were from 11.2 and 13.1 opensuse using virtualbox from oricle site as at the time linux repos version wouldn’t install.
Linux 11.2 and 13.1 were installed as guests from leap 42.3 using Linux opensuse repos.

Info straigh from oricle says Virtualbox 6,x onward require gust additions before you can run Linux flavors inside them as without them they will fail upon selecting to run guest. Took hours to find the guest additions on their site and only one marked beta could be found for opensuse hosts.

I should be ok as nothing is ever saved to the guest OS. I attach a link to a network partition shared by all OS’s and store my info there. That way if virtualbox goes down I lose nothing important and am free to re-install the guest OS.

I have no idea at this point which version of virtualbox was previously installed because during updates I tegularly see virtualbox being updated and it doesn’t tell you what version it is changing it too. Originally Virtualbox was version 3.?? and in Leap 15.0 it was virtualbox 5.?? this time due to the problem I made note that it was 6.0.12

current already made vdi’s are working I just can’t add any new ones. I had thought if I make a clone of a working vdi and change the clone to take a new version by install over the old OS maybe that might work.

Question is will making a clone putting a new OS on the vdi will that delete the guest addition??

hate the new yast software management it says virtualbox is not installed, rpm says it is installed, That Discovery thing says it is not installed and I can see it and run from my desktop!!

That’s likely your problem right there.
The Virtualbox from the Oracle site is not exactly the same as the Virtualbox from openSUSE… they’re very similar but there are some differences.
I strongly suspect you have a mish-mash of files from your Oracle version partially changed by the openSUSE upgrade.

I recommend “cleaning” your system by purging all your Virtualbox application files, then re-installing either from openSUSE (which should support future upgrades) or installing from Oracle again for other reasons.

I described how to do this for another User who had to remove Virtualbox in the following post. You may also find a skim of that person’s problems useful for your situation, too

Although it’s fairly certain you’ll be able to fix your Virtualbox, you may want to delay this in favor of making sure the other problems you described in another post about your upgrade are fixed first so that if you decide that a re-install might be preferable over fixing your problems individually, then your time to fix Virtualbox won’t be extra, wasted effort.


You may be right a clean fresh install after so many upgrades the opensuse way may be in order but I worry now for my sanity. I have so much software that took years to get going and likely is not available anymore. A clean up grade gives me a working system with out much mish mash but it will still be a big gamble as to how much I will lose in the process. I currently have 4 opensuse versions in grub 11.2 13.1 15.0 and 15.1 because of things that opensuse has deleted due to no more support. My 15.1 is freshly upgraded but has new things added that can’t be to my knowledge re-installed because the repos are no more and I have no sources saved. Add to this I am running out of space to keep putting new OS’s and keep my vm’s too.

I guess first I need to identify all the packages I have installed and find a way to download source installs for each of them. move them safe and hope the reinstall of 15.1 isn;t so broken. AND That it can actually re-install the packages I find download and archive. That’s the biggy.

Yes. Inventory your apps. it’s also a good opportunity to update your apps. There may be new versions and sources for newer versions. If you have problems locating install sources for your apps post in the Apps forum. there may also be better equivalent apps in some cases.

If you have enough disk space, you can also install a new system side by side with your old so you can decide what to upgrade and what not to upgrade in a new install.

Or you can get your virtualbox running so that you can test new versions of your applications in a new system in a virtualized environment before doing a new rebuild.



zypper lr -d
zypper se -si virtualb

Well I cannbaliszed my system to death.

  1. Killed off 11.2 and 13.2 as the programs i was using on them come back with tons of errors and no repos to go to, to fix them.
  2. Fresh Install of 15.1 instead of doing an another upgrade cause they seem not to be so great.
  3. Installed as many apps as I could to match what I had all from opensuse repos.
  4. Re-installed Virtualbox from opensuse repos and virtualbox is working but way different than ever before. It no longer supports install from usb flash only choices are CDROM or .iso :’(. Ok I get it maybe the programers are lacking talent of their predecessors. No problem made an .iso of bootable USB and attached that to cdrom as image. Worked. 13.2 is now in virtual space as are XP , win7, win2k, Even was able to install extension pack for virtualbox 6.0.12 to match my version of virtualbox.

Problem is that now virtualbox upon running XP, win7, Win2k complains that I should upgrade guest additions immediately but won’t mount the iso image to do it. As for Linux13.2 it complains that no guest additions are installed and won’t attach iso to do it.

It says the .iso is not accessible It’s right there in my download folder in my home folder. and i attach it to the cdrom but in ALL the virtual guests all shared drives and the cdrom are not visible. And the option to install guest additions says it can;t find them either and asks if I want to download them. You may have guessed, that feature is a non stop loop of download failed retry the dowmload…

The rest of my issues lie elsewhere like in applications so all need in this category is how to get my guest additions in for the guests.

btw the raspberry Pi emulation on cdrom iso image can not be installed to run in virtualbox. when you try to run it it gives two options run live from cd or install from cd. run from cd has 2 choices with persistance or without persistance and they work but you can’t share with your running system. You can’t access the usb either. Those are reserved for installed system which crashes upon restart from install.

So need to investigate if I can use qemu but from what the basic info says it may take days just to figure out how to set it up.

This all seems like too much work all to have a way to use my 8pen plotter, my large scale scanner, openoffice 4.11, quanta3plus, xbasic, and altimately to finish my EV motorhome design.

What is the “raspberry Pi emulation on cdrom” do you have a download link?

That is the link to the official site it has two versions noobs and raspbian. raspbian can be run from virtualbox in live mode with/without persistance
Install does the install then crashes upon reboot. Raspberry sites explain that it needs guest additions before it is launched or it will crash. But you can’t install guest additions until it has fully loaded.

I also have the .iso files for it. qemu is supposed to also be able to run it but the info is all in ubuntu format so quite unreadable unless you have time to learn about ubuntu stuff.

To make the control displays link to GPIO controller I need to use a raspberry PI computer so I can have full access to master and slave GPIO devices on the i2c bus. So I need to emulate the PI, Write the code to control it and test it, then migrate it to the pi for actual EV Motorhome operation.

I ask a lot from my pc;s I guess.

I just use openSUSE and SLES for my RPi3’s… I use wiringpi or there is python… then just hook up a breadboard for development, then there is also Fritzing

The iso images are maintained in the ports repository:

python on raspberry pi is an interpreter so you can’t use it for much more than testing few gpios, wiring pi is a commandline tools as I discovered and also not usable without a ;c; or similar language to control interactions. There is a very primative basic language for the pi but again not system ready.

My EV will have a 296 channel GPIO using i2c protocol going to a multiplexed mcp23017 gpoi expander board tied to all vehicle operations including multi chargers, sensor for everything, main moter control etc. The program has to be fast and runs using 3 PI computers to handle all operations. That’s why I need to get xbasic functioning in linux, and in the pi emulator so i can fully test everything. Then I can link to c code for some stuff while the main system runs from assembly code.

At this point, I read the info on pi 3, bought the first PI and all stuff to make the system, Designed the multiplexed system board that will connect to 2 pi’s by serial communication and using one to communicate with the system board to all automotive functions. Internal motorhome stuff and the chargering system for 3 huge battery packs is handled by wifi from one of the pi3. So togther all 3 Pi’s are working hard at keeping everything in tip top shape.

One Pi controls the dashboard, one controls the camera’s, reading and writing the GPIO and third talks by wifi to monitor batteries, charging from 5 sources, and when parked handles the water system too.

If you’re still using physical external media as install sources for your VMs, tsk-tsk.
You should convert all your installations to using ISO files or their equivalents, and then store them somewhere for unversal access (local directory, network share, etc)
Good management of your install sources can greatly improve productivity… not only are files faster, but you don’t have to search for them whenever you need them, and even that should be relatively rare… Once you build an image you like, consider making a copy as your “Golden Image” from which new machines are cloned.

All VBox installs should have the correct Guest Additions ISO available as a menu item link in every Guest graphical console.
Easy access, and no worrites about a wrong version because it’s always sync-d to the Virtualbox app running in your HostOS.

You should understand that the Raspian and likely the Noobs version that runs on a PC is not emulation (the last time I looked at it, and nearlly 100% certain is still true). It’s an x86 build. The difference is enormous, particularly if you’re developing… An x86 build will run natively on a PC (or virtualization running on an x86 machine) which can mean enormous differences depending on what you’re building. There <may> be GPIO emulation if it exists because that doesn’t exist on an x86 system.

Now, there <are> emulators that work differently than installing directly on x86 hardware or virtualization like Virtualbox… In those you run an ARM based image(perhaps same as what you’d install in a real RPi) in the emulator.

QEMU has the capability to do full hardware emulation, but that isn’t part of Virtualbox… Although both Xen and KVM both have integrated parts of QEMU, I’d recommend KVM’s QEMU for this kind of use.

The other approach is to run a full-blown, dedicated emulator. I haven’t looked at what is available for RPi recently (only for smartphones), so don’t know what is currently recommended. In any case though, I don’t know any instruction which recommends developing using emulation for an RPi at any stage, they all describe getting yourself a real RPi (after all, even the most expensive is less than $50 list), and there are plenty of special hardware add-ons to assist setting up your GPIO connections, particularly supporting hats.

Although not discussed often, almost all code is written for RPi is in python.
That’s OK if that is your preferred language but if you prefer to code in another language, there are probably interpreters and frameworks that support those other languages… I personally prefer Javascript so I write a number of my apps using cylon.js. And, by writing to a framework in theory my code is portable across a large number of embedded devices.


I have been using KVM, so I don’t have “virtualbox” experience.

With KVM, there are no obvious options to boot from USB. However, I have worked out how to do it.

I configure the VM to provide a boot menu on start up. When I see the boot menu, I plug in my USB. I then use the option to send the VM a CTRL-ALT-DEL. That restarts it, but it now sees the USB and when the boot menu shows there is an option to boot from the USB.

I do not know whether something similar would work for “virtualbox”.

USB install is available in VirtualBox 6 - you have to create a vdmk to the usb drive to do it.

Also you need to make sure that the USB VirtualBox extensions are installed to VirtualBox. I wrote a script to install it. Run it as root or sudo it. Do it without VirtualBox running.

SUSE:~ # cat bin/addvbext
if  ! -d "/tmpx" ]
echo make tmpx
mkdir /tmpx
chmod 777 /tmpx
echo update VirtualBox
VBOX_VERSION=`/usr/bin/VBoxManage --version | awk -F_ {'print $1'}`
VBOX_EXT=`echo Oracle_VM_VirtualBox_Extension_Pack-${VBOX_VERSION}.vbox-extpack`
cd /tmpx
echo Y | /usr/bin/VBoxManage extpack install --replace $VBOX_EXT
rm -f $VBOX_EXT

SUSE:~ # 

If you're still using physical external media as install sources for your VMs, tsk-tsk.

I use what I have on hand. I killed the 13.2 partition but did have 13.2 on usb for re-install so when it wouldn’t boot from usb I just made iso from usb and installed that way. I quit making cdrom’s/dvd’s years ago so didn’t have them available and search on net did turn up any results for 13.2 opensuse

consider making a copy as your "Golden Image" from which new machines are cloned

Love to and in one of my posts asked how it could be done. My memory is getting worse so where I thought there was a way to make a clone of the source partition another part of me says no I am mistaken. I thought of using dd <infile=working partition> but that seems like too simple it probably won’t be bootable on a new system.

VBox installs should have the correct Guest Additions ISO available as a menu item link

True you start the guest and the menu says install guest additions from cd (this is totally broken in version 6) even with guest iso additions attached to cdrom it can’t find the cdrom even tho it shows up as available in cdrom menu under devices. In the guest you normally should be able to open the cdrom drive and install from there but the cdrom drive isn’t there.

It's an x86 build. The difference

That I get. The arm64 is not an x86 so an x86 build is designed to run the arm basic functionallity on the x86. But they have also got the emulator which is supposed to emulate the pi so you can develop code and test it before moving it to a live pi. On a Pc x86 I can put an I2C-USB and an SPI-USB which will test the master I2C/SPI on a windows PC and in theory it says you can do master and slave on any Linux machine. So testing the EV Controller would be possible. I was hoping that with virtualization I could program and test the three control systems on the PC using xbasic connecting thru I2C-USB to test the boards. Then compile the code to assembly language and port it to the emulated PI to compile and test in emulation. Once it functions there cross compile to arm64 and copy to real PI.
I have looked into many scenerios and being that it has been years since I really did any programing I wanted a drag and drop GUI design software. Windows has Studio-C, studio-c#, studio-VBasic and xBasic only xbasic is portable to linux type os’s. The c code from studio does api calls for which linux does not have the equivelant so useless. Since the target is linux based, and I have a linux machine why not just scrap windows and do in linux. Here I am supposed to have xbasic but in changing the machines over the years I can’t get xbasic back functioning It used to function very well in 11.2 and 13.2 (reason to have 13.2 in virtualbox) and I know it can run any code done in windows in linux without any problems. It compiles fast and clean to assembler. Tried Python but it makes script code which is totally too slow for this type of app and the making of the gui is very hard to do. Was trying QTdesign/creator but now can’t get it to install either. Started to look at xForms which compiles to c but now it won’t install saying missing xpm and jpeg libraries.

QEMU supports many physical hardware platforms, and has recently added [support for the Raspberry Pi 3]( with the raspi3  model. However, there is currently no emulation of the BCM2835 USB  controller, so there is no USB support and also, more critically, no  networking support. Furthermore, the raspi3 model only works for 64-bit linux kernels, and the Raspbian kernel is 32-bit.

Looks like qemu will not work as it can’t handle BCM2835 so USB and GPIO and I2C/SPI are not available in the emulator and because of 32bit 64bit conflict it likely won’t work as an emulator.

On the Internet, nothing is gone forever.
Install sources for old, discontinued versions of openSUSE can be found at the following location

The Virtualbox User Manual should be first stop for such things as how to clone VMs and usual Guest Additions maintenance. Your situation may be different though, I don’t remember if there were special problems upgrading Guest Additions from a major version to another (5.7 to 6.0),in this special situation I’ve sometimes had to completely uninstall the old Guest Additions in a separate step before installing a new version. And it shouldn’t be a critical issue to not have working Guest Additions when starting up a VM… It should just be lacking in features until the problem is resolved.

The Virtualbox User Manual section on Guest Additions is here

Uninstalling Guest Additions is described here

I’d caution against using Visual Studio to write code in general and RPi in particular… Although I am a big fan of Visual Studio for what it does, it’s important to understand and respect its limitations. Microsoft enforces a “Microsoft Way” in every project, most importantly in how code is organized, supported and implemented which can cause a variety of compatibility and integration problems(unless you decide to go 100% Microsoft). Compiled code will be CLR, and . There used to be a 3rd party version of Visual Studio that supported python called IronPython, looks like it’s now been made available as a set of tools in Visual Studio. I don’t know that very many people write RPi applications in C, I think I remember an Intel toolkit for doing that some years ago. And no, Qt probably isn’t a good choice either… AFAIK it’s a Desktop level toolkit so unless you’re running a Desktop on your device that provides those components, ti wouldn’t make sense.

Python is the standard language used for writing code for RPi, and likely because unless you decide to install an odd OS most of what you need to run your app would be already installed by default. The Cylon.js I run requires installing Javascript libraries, but I live with that. If you run almost any other language, you’d be dealing with similar issues.